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Introduction
Welcome to OrgChart Professional, the premiere application for all your chart cre‐
ation needs. With its dynamic and powerful interface, the designing of any chart ‐
from the layout of a single department, to the hierarchy of an entire corporation ‐ is
just a few mouse clicks away.
This is possible because OrgChart’s unique workflow allows complex structures to
be organized simply, quickly and efficiently. Whether you prefer dragging and
dropping or simply double clicking, changes ranging from the universal to the
individual are immediately applied to whatever element you choose.
To further increase productivity, the work environment can be customized and
rearranged to meet your personal preferences. Never use a menu? Simply hide it.
Like a toolbar on the bottom instead of the top? Just re‐dock it. Have what you
want, when you want, where you want it.
To make certain that your charts get the attention they deserve, OrgChart also pro‐
vides a wide range of themes, backgrounds, borders and unique shapes to make
presentations that people don’t just have to look at, but ones they want to look at
(see below).
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Moving on
The following chapters will introduce you to OrgChart Professional’s work envi‐
ronment, teach you to master its powerful tools and ultimately show you how to
present your final, polished vision to the world. So let’s get started and make those
charts a reality!
(Please visit us online at http://www.officeworksoftware.com for additional tips,
tutorials and the latest events in the OrgChart Professional world.)
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What’s new in OrgChart Professional version 5.0?
(Effective 5‐1‐09)
Version 5 of OrgChart Professional has new features that make it easier to use and
configure to get the chart formats you need.

A Brief overview of new features
1. AutoAdjustSize – As you build a chart the boxes all expand or contract to match
the size of the largest box. You still have the ability to manually control the size
of the box, but with Autosize the chart automatically adjusts to give you a
balanced result.
2. New Photo and Data Format ‐ A new properties dialog allows you to place a
photo on the left or right side of a box, and also arrange box data in multiple
columns.
3. Hide Shape – Allows you to not show an individual, or to create a new layout.
4. Preview – “Quick Data View’ is a new info tip that displays a box’s data when the
mouse is hovered over the box. Very useful when working with large charts.
5. Optimization ‐ Optimization of overall operations and drawing speed. Larger
chart sizes now load and maneuver more quickly.
6. Silent Update – You can now schedule automatic daily updates to the org chart
using data from your HR database. The OrgChart program can be run using
command line parameters. Updates may be made to a web site, PowerPoint,
and more.
7. Format Toolbar – complies with commonly used standards ( i.e., MS‐Word)
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Detailed Descriptions of New v5.0 Features
1. New AutoAdjustSize
AutoAdjustSize is a powerful new feature that helps you – automatically ‐ create a chart
with boxes of uniform size. In previous versions of OrgChart you would have boxes of
different size based upon the amount of text you placed in them. If you wanted to
make boxes the same size you would adjust them individually or use the Paint Formatter
function.
When first creating the chart all boxes automatically become same size.

We added this AutoAdjustSize feature to make it easier to build a chart with boxes of
uniform size.
How AutoAdjustSize Works.
As you build a chart, a box’s size is determined by the amount of data that is entered. In
addition, as you add more boxes, their sizes will all automatically adjust to the size of
the largest one. This makes creation of a chart with uniform box size easy.
For example here is the first box in the chart.

Page 12 of 318

OrgChart Professional

New in Version 5.0

Next we add another person (reporting to James) with a larger name. Notice how
James’ box expands to match the size of the new one.

As we add new boxes to a new level they are un‐sized until filled

OrgChart v5’s AutoAdjustSize will work to optimize the size of boxes at each level. That
is why we now see the third level of boxes sizing the same as Stuart’s box.
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Next, let’s give someone a very long name, and watch the sizing that takes place.

Instead, here is what I would have expected…(levels 1 and 2 unchanged, but level 3
maintaining new common size.)
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Boxes all expand or contract to match the size of the largest box. You still have the
ability to manually control the size of the box, but with Autosize the chart automatically
adjusts to give you a balanced result.

Note: AutoAdjustSize Rules
Org charts In Version 4 and prior would have boxes of different sizes until adjusted
manually or by applying the Format Painter command. But in version 5 we have
enabled the program to determine box sizes using some rules of thumb.
Keep in mind, if you still want to manually determine a box size, you can. Or you can let
the program do it automatically.
Pay attention to a few AutoAdjustSize rules:
1. AutoAdjustSize is turned on by default. You can turn it off for a single box or
group of boxes. Look under the local menu under View.
2. Using AutoAdjustSize, a box size is determined by the length of the longest
data field.
3. The longest (widest) box determines the size of the others, provided they
have AutoAdjustSize turned on. Boxes with AutoAdjustSize turned off will be
skipped in the adjustment calculation.
4. Box size may be smaller if Word‐Wrap is turned on. To see if Word‐Wrap is
on, look at the local menu under View. Remember that word wrap works based
upon spaces in a character string.
5. Paint Formatter has options that can be viewed under special mode. If you
are using paint Formatter the default is AutoAdjustSize – but you may change it
to manual.

Page 15 of 318

OrgChart Professional

New in Version 5.0

6. Version 4 and previous chart files may look different in V5. This is because V5
will not allow text to go beyond the borders of a box.

2. New Photo and Data Format
A new properties dialog allows you to place a photo on the left or right side of a box,
and also arrange box data in multiple columns.
A. Multiple Columns
Our customers asked for more design options and so in Version 5 we added the ability
to have data shown in multiple columns. For example, the person’s photo can now be
shown in a separate column to the left or right. (This example shows box information in
two columns)

V5 now has many new layout options for a chart box. The following is an example with
data in three columns.

And just to make the point (not that you would necessarily want to do this), here is an
example with data in four columns. (Red dotted lines are for illustration only.)
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B. Word Wrap
Version 5 now supports word wrap. You can turn this feature on or off for the entire
box or any field.

Word Wrap turned ON (allows box to be
more narrow)

Word Wrap turned OFF (Causes box to
expand to accommodate longest data field)

C. Properties Dialog
Now that you can see the results of the new formatting let’s look at the Properties
Dialog box that makes it possible.
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Explanation of Fields
Section 1.
The fields show in this window look similar to V4, but now you can select multiple fields
and give them a common treatment such as Cell Alignment, Show Field Title, or Word
Wrap.
Section 2.
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After selecting a field in Section 1 you may move it up or down using the arrows. If you
want to use the right or left arrows the box must contain at least two columns.
Also in this section you will see two icons with faces. Use one of them to place the photo
on the right or left of the chart box. The box will instantly turn into a two‐column box
with the photo image on the side.
Section 3.
In this field you can set the number of columns you want to show in your chart box. If
you want the Photo image to show on the left side of the box, you can click on the
proper icon in Section 2, or you can set the Columns to 2 and begin moving each data
field to the right using the arrows in section 2.
Section 4
Here is where you can set the Word Wrap for a field that has been selected. You can
set this for multiple fields as described above in section 1. Keep in mind that Word
Wrap means that a field, such as name, will break and start a new line where there is a
space in the name. Turning off the Word Wrap may also result in causing the box to
become wider to accommodate the text.
Word Wrap On

Word Wrap Off

Page 19 of 318

OrgChart Professional

New in Version 5.0

Section 5
This option is the same as in V4. Here you can determine the scope of the change you
are making. It can be specifically for the box you have selected, the current division, or
the entire chart.
Section 6
The tabs in Section 6 have not changed in V5. Here you can determine the visibility of a
field (using Define Layout) or the contents of a field (using Edit Data).
If you have selected multiple boxes before opening the Properties dialog, you can use
the Edit Data tab to make changes to the contents of a particular field for those boxes
selected.

3. Hide Shape
With the ability to hide a shape you can hide the display of a person or create new styles
of arrangements.
Here is an example of how the person or shape can be hidden:
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Here are three examples of how new chart arrangements can be made simply by hiding
some boxes.

‐ Different Arrangements Made Using the Hide Box Function ‐

Keep in mind that when using Hide Shape the data still exists in the hidden box and the
database, but it simply is not showing on the chart.
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4. Preview / Quick Data View
In previous versions of OrgChart you would need to click on a box to see the detail of its
contents. With Quick Data View you can simply hover the mouse cursor over a box and
a bubble with the contents will automatically display.
For example, when hovering over Ron Holt, the bubble with his name appears, along
with a link to the detailed properties.

You can still double‐click on the edge of a box to open the Properties dialog – or you can
click on this link.
Note: The Box item view has changed in V5. Let’s use one box on the chart for
illustration purposes.

If you look in the Box Item view (lower left corner of the program’s screen) you will see
the view with two tabs: Data View and Layout View. In V5 we have moved the Layout
tab to the Properties dialog. You can still see the contents of a selected box in the Data
view, but please note that the Layout tab is no longer present here.
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‐ Box Item: V4 and V5 Data View ‐

‐ Box Item: V4 Layout View (Removed in V5) ‐
In V5 the way you change the fields that are visible is to use the Properties dialog, or to
click on the preview bubble.
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By clicking on the Properties link you will see the following dialog. It is here that the
fields can be selected for viewing on the chart.

Just as in V4, this dialog can also be brought up by right clicking on the chart box item,
or by just double‐clicking.
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5. Chart Optimization
Optimization of overall operations and drawing speed. Larger chart sizes now load and
maneuver more quickly.

6. Silent Update
You can now schedule automatic daily updates to the org chart using data from your HR
database. The OrgChart program can be run using command line parameters. Updates
may be made to a web site, PowerPoint, and more.
This feature was added for customers who receive frequent changes to their HR data
and want to update the OrgChart on a daily basis. They do not want to have to take the
time and human effort to run the OrgChart program manually.
With Silent Update you can schedule a job that calls the OrgChart program, runs it using
the most recently updated organization / HR data, and automatically updates the
common outputs such as a PowerPoint presentation or Flash web site. (Details can be
found here: www.officeworksoftware.com/programs/documentation/silentupdate.pdf

Contact us
At OfficeWork Software we are dedicated to providing tools and methods to build
world‐class organizations and businesses. We are always interested in making our
software more beneficial for our clients. Please let us know what questions you have,
success stories, or any recommendations for new features. We can be reached at
support@officeworksoftware.com.
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Previously Released in OrgChart Professional version 4.5
(Effective 1‐1‐08)
At OfficeWork Software we are always looking to implement improvements that help
meet your needs in building a better organization. The following are summary and
detailed descriptions of improvements effective with the January 1, 2008 version 4.5
release:
1.

Create Charts from Multiple Files. Create a master chart by combining one or
more chart files. Or divide/break down a larger chart into smaller chart files for
easier distribution and communication.
2. New Auditing Compare Tool for Tracking Org Chart Changes. The Compare tool
creates a color‐coded, visual presentation revealing ‘what has changed’ as you
continue to make chart updates. You can compare charts within one file, or
compare charts in two separate files.
3. Flexible Data Import Supports both One and Two Column Hierarchy Methods.
Hierarchies are typically built on Subordinate / Supervisor reporting relationships.
In v4.5 a single column hierarchy, such as an Organizational Breakdown Structure
(OBS) or Work Breakdown Structure (WBS) can be used to develop the chart
hierarchy.
4. Dynamic Name Field Formatting and Recognition. New in version 4.5 is the ability
to format names to be compatible with most HR databases. Names stored as Last,
First, Middle Initial can be displayed as First, Middle, Last, or 39 other common
formats – without making any changes to the data. These formats will be
automatically recognized through the normal import process.
5. Microsoft Project Import and Export for WBS View. OrgChart Pro 4.5 now reads
MS Project Schedule (.mpp) files, presenting the project outline in a work
breakdown structure (WBS) format.
6. Flash Web Publishing now Includes Search Function. Any chart published to Flash
now has a search function that allows a search on any attribute of an employee.
7. Full Unicode Symbols Support. OrgChart Professional now supports Chinese,
Japanese, Korean, Greek, and other languages requiring Unicode.
8. Quick Search in Data View. Quick search in outline view.
9. Date Fields now Support International Date and Time Formats. Any date stored
in a chart can be presented in any International date and time format.
10. Expanded Data Import and Export. Import and export now handles System
Columns, Assistants, Arrangements, Dotted line reporting relationships, and more.
11. Performance Optimization. Improved performance of calculated fields updates.
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Detailed Descriptions of v4.5 Features
1. Create Charts from Multiple Files. Save Division to file / Create Division from
file ‐ This gives you the ability to break a larger chart into smaller, separate chart files,
or create a larger chart from many smaller chart files.
OrgChart has long had the ability to break a chart into divisions (or smaller sub charts),
making it easier to arrange a presentation in the most readable format. The new
feature in the Divisions menu (Division / Save to file …) allows you to save a division to a
separate chart file. The delete feature was also modified so that you can delete
members of a division by deleting the division manager. Finally, a smaller chart can
have multiple charts appended by using the ‘Division / Create from file’ command. This
feature is perfect for larger companies where one person is responsible to aggregate the
charts of different groups into one master chart.
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Save Division to a file
In this example we save Steve’s division to a separate file names scs1.toc.

Delete Division
Delete Steve’s division and all of its members.

The result: Steve and all of his team have been removed.
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Create Division from file
We will now add in Steve’s division from the previously saved file.

… select the file …

Page 30 of 318

OrgChart Professional

New in Version 5.0

Specify the top level.

The result: Steve’s chart has been incorporated into the larger chart.

It is important to note that multiple files can be appended at the same time. Also note
that the columns of chart data will require mapping if not identical in both files.
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2. The Auditing Compare Tool for Tracking Org Chart Changes
Common situation: You have made numerous changes to a chart since last month. So,
what changed? How can you know if all of the intended changes were made?
The new Compare Tool creates a color‐coded, visual presentation revealing ‘what has
changed’ as you continue to make chart updates. You can compare charts within one
file, or compare charts in two separate files.

When making changes to a chart it is recommended that you work with a copy. After
making changes you can run the compare utility to illustrate exactly what has changed
from the previous version of the chart.
It is important to note that this feature will only work with version 4.5 files and later.
You will not be able to run the compare utility on chart files created with earlier versions
of OrgChart Professional.
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Chart Before (Red arrows indicate three positions to be removed)
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Chart After (The three positions have been removed)

Compare Tool Results Reports
The comparison of the two charts reveals changes with color coding. Red indicates
deleted records, Green for added, and Blue for any field that has changed. All results
can be published to Excel with color coding.

Page 34 of 318

OrgChart Professional

New in Version 5.0

3. Flexible Data Import Supports both One and Two Column Hierarchy
Methods.
Hierarchies are typically built on Subordinate / Supervisor reporting relationships. In
v4.5 a single column hierarchy, such as an Organizational Breakdown Structure (OBS) or
Work Breakdown Structure (WBS) can be used to develop the chart hierarchy.
For example, this is an Excel worksheet with a standard two‐column hierarchy method
(each employee has a supervisor):

The Two Column hierarchy option shows in the import process as the following:
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But we can also import the following Excel file using the single column (outline number)
method:

In the import process the Single Column radio button is checked, along with the
appropriate delimiter. This is all that is needed to establish the chart’s hierarchy.
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This latter single column hierarchy method is appropriate for an Organizational
Breakdown Structure (OBS) or a Work Breakdown Structure (WBS).

4. Name field formatting and recognition.
New in version 4.5 is the ability to format names to be compatible with most HR
databases. Names stored as Last, First, Middle Initial can be displayed as First, Middle,
Last, or 39 other common formats – without making any changes to the data. These
formats will be automatically recognized through the normal import process.

Without changing any data, this:

Can easily be displayed as this:
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5. Microsoft Project Import and Export ‐ Work Breakdown Structure (WBS)
Modeling
OrgChart Professional 4.5 now reads MS Project Schedule (.mpp) files, presenting the
project outline in a work breakdown structure (WBS) format. Now you can import an
MS‐Project schedule and turn it into a WBS view in OrgChart Professional.
Communicate the project plan with greater clarity. Many times a different picture can
help team members, management, and clients understand and plan a project. The new
Work Breakdown Structure (WBS) view available through OrgChart helps condense even
large complex project plans into a presentation that can be easily navigated, analyzed,
communicated, and understood.
This project plan, can also be viewed as a WBS chart

The import process takes seconds and gives you the option of working with the project
in a top‐down, structured planning method.

The MS‐Project chart in this example contains more activities, which also can be seen in
the WBS view in OrgChart. Each of the nodes can be expanded or collapsed for optimal
viewing. If you want to see the entire project on one large piece of paper, just select a
larger paper size or plotter output.
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Below is the MS‐Project outline Gantt that the above chart represents:
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6. Flash Web Publishing now Includes Search Function.
Any chart published to Flash now has a search function that allows a search on any
attribute of an employee.

7. Full Unicode Symbols Support.
OrgChart Professional now supports Chinese, Japanese, Korean, Greek, and other
languages requiring Unicode.

8. Quick Search in Data View.
Finding people is now easier than ever. Search according to any attribute in the data
outline view quickly and easily.
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9. Date Fields now Support International Date and Time Formats.
Any date stored in a chart can be presented in any International date and time format.
Formatting selection is available in the Import process, and also through the Chart /
Chart Data Set menu item.

10. Expanded Data Import and Export.
Import and export now handles System Columns, Assistants, Arrangements, Dotted line
reporting relationships, and more.
Dotted line relationships are established at the following dialog in the import process:
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System fields are available for import at the next dialog.

You now have complete control over the data that is imported into your chart
anddatabase.
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11. Performance Optimization.
In version 4.5 we have implemented a number of performance enhancements to enable
very large charts load, save, and display more quickly.

Contact us
At OfficeWork Software we are dedicated to providing tools and methods to build
world‐class organizations and businesses. We are always interested in making our
software more beneficial for our clients. Please let us know what questions you have,
success stories, or any recommendations for new features. We can be reached at
support@officeworksoftware.com.
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Previously Released in Version 4.0
(Summer 2007)

Version 4.0 of OrgChart Professional introduced a wealth of new features to enhance
your chart making experience, including:

Flash Publishing ‐ the world (wide web) at your command
OrgChart Professional now offers Flash Publishing, which harnesses the power of
Macromedia Flash ‐ one of the worldwide standards for internet graphics. So now
your charts can be posted directly to the web for the whole world to see. In addi‐
tion, since Flash documents are viewable in any browser installed with Macromedia
Flash Player 8 or later, almost anyone, anywhere, can see your latest chart creations.

Data Synchronization ‐ charts as dynamic documents
OrgChart Professional provides the latest in dynamic project creation through Data
Synchronization ‐ an on‐the‐fly method of updating a chart’s information in almost
real time. With this amazing tool, you can constantly ‐ and automatically ‐ update
your OrgChart by linking it to a database containing your newest information. Then,
by simply clicking a button, or setting OrgChart to resynchronize when launched,
your chart will instantly reflect any new changes ‐ without any additional effort on
your part.

New Paint Format ‐ the ultimate component modifier
This amazing tool allows you to take the visual attributes of one component ‐ such
as its shape, color and font ‐ and instantly transfer those same attributes directly to
other components in your chart. Augmented with a new Scope feature, now the
changes can be as sweeping, or as precise, as you need ‐ from individual compo‐
nents, to divisions or even to the entire chart.

Unified Data Organization ‐ one stop for every need
Designing, organizing and utilizing data fields is now a snap due to OrgChart’s new
integrated data field system. Featuring a new set of interconnected interfaces,
every aspect of data control ‐ from creation to deployment ‐ can be accomplished in
seconds; so even the most complex information challenges become a breeze.
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Master Page View ‐ a canvas for universal elements
Master Page view is a powerful mode which allows universal elements to be applied
to every page of multi‐page charts. Acting as a canvas reserved solely for global
elements, it is perfect for placing titles, graphics, logos, autotexts and almost
anything else you want to appear on every sheet. Running in the background and
only accessible in Master Page view, these designs are then visible as you work, but
completely protected from the day to day tasks of building and updating charts.

Thumbnail View ‐ “I can see my house from here”
With Thumbnail View, OrgChart Professional solves one of the greatest challenges
posed by large charts ‐ making the zoom factor small enough to conveniently
navigate through complex organizations while still being close enough to actually
find what you are looking for. Launched on command, Thumbnail View’s convenient
and versatile, free‐floating frame acts as a combined chart navigator and magnifier;
providing two views at once ‐ one displaying the entire chart and the other showing
an enlarged view of whatever area you select. Now you have the best of both
worlds.

Outline View Control Bar ‐ “the bar is open”
Introduced in OCP v.4, Enterprise Edition, this new toolbar is the latest addition to
OrgChart’s constantly expanding toolset. Conveniently located atop the Outline
View, this area provides one stop access for the creation, editing and manipulation
of data ‐ from its creation, to its viewing and even to its export. It just may be the
last toolbar you ever need.

Emailing a Chart ‐ one click does it all
Now you can share your charts with friends and colleagues by simply emailing it to
them. With one command, OrgChart Professional will automatically save your chart,
launch your personal email client and insert the chart as an attachment. All you have
to do is insert an address and click the Send button. It’s that easy!

The “Image” component ‐ “Image is everything”
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In this latest version, OrgChart Professional introduces the new Image component.
Unlike previous components, this item does not attach directly into a chart’s hier‐
archy. Instead, the Image component launches a combined image browser and
graphics editor. It is the perfect tool for finding, modifying and placing graphics onto
a chart. It can even be used with the new Master Page feature to place graphics on
every page at once.

Apply Scope ‐ one click makes all the difference
Apply Scope is a powerful and intuitive interface which allows you to quickly set the
range and locations of the changes in your chart. The days of manually applying
modifications are over. Now, with a single mouse click you can effect everything
from the data in an individual component to the look and feel of the entire project.

New AutoTexts ‐ let the computer do the work
OrgChart now has four additional AutoTexts ‐ including fields that are automatically
filled in with information supplied directly from your computer’s operating system
(such as Current Time and Current Date). With Autotext’s expanded selection and
features, just sit back and relax ‐ let Autotext do the work.

New Arrange for Wide Organizations ‐ “Bigger is better”
OrgChart Professional now includes three new autoarrange buttons ‐ Horizontal
Four Columns, Horizontal Six Columns and Vertical Four Columns ‐ which are
specifically designed for large projects. Only becoming active after a chart has
exceeded a certain size, they take the trouble out of arranging large numbers of
components in attractive ways. Clutter is banished in a single click ‐ allowing the
underlying beauty and order of large organizations to shine through.

Clipart ‐ a picture is worth a thousand words
OrgChart Professional now ships with an integrated clipart library to enhance your
presentations. Now part of the newly expanded Chart Design Palette, the entire
clipart catalogue can be seen at once, or viewed by individual topic. In addition,
OrgChart allows you to create and import your own image libraries which can then
be viewed right in the program itself. Adding a nice, personal touch has never been
easier.

Free move and Resize mode ‐ put your chart anywhere
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This powerful feature allows you to move and resize your entire chart with the same
convenience and ease as moving and resizing individual components. With the click
of a single button, this function creates an area around the entire chart which allows
it ‐ as a whole ‐ to be dragged and dropped anywhere or expanded and contracted
to suit your needs. Now your chart can ‐ quite literally ‐ go anywhere.

Improved Box Properties - everything at your fingertips
OrgChart Professional now provides a completely redesigned Box Properties area.
Built from the ground up, this improved interface utilizes tabbed browsing to combine the best of data management and graphic arrangement in one convenient, central
location.

Box Item Photos - seeing is believing
The Box item area now has the ability to display photos. This engaging feature means
that if, for example, you are working on personnel you can actually see the individual
- which adds both convenience and a personal touch which can often be lost when
just working with data alone. With Box Item photos, people aren’t just numbers any
more.

Additional features:
OrgChart Professional contains many other new features and enhancements that are
too numerous to list here. Please see the rest of the manual to discover them all.
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Quick Start Guide: Building a chart in minutes
Creating eye-popping org charts is fun and easy. In this section, we will show you
how to build the following chart in three, 5 minute tutorials.

Note: details on each step and many other incredible functions, options and
resources for chart creation are covered in-depth in other parts of this manual
Okay, let’s get started!
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Part 1: Building a 3-D chart in 5 minutes
1. Open a new OrgChart by pressing the New button (located in the upper left
corner, just beneath the File menu).

A new OrgChart will appear with a single component on screen.
2. Set the Zoom level to 100% by clicking in the Zoom Toolbar and either
picking 100% from the drop down menu or using your mouse scroll wheel
(recommended).

3. Go to the Chart Design Palette (on the left side of the screen) and open up the
Components area (by clicking on the Components title bar).

Page 49 of 318

OrgChart Professional
minutes

Quick Start Guide: Building a chart in

4. Scroll down the list of components and choose the component labeled 3
Positions.

5. Holding down the Left mouse button, drag the 3 Positions icon from
the Components area and drop it directly onto the on-screen component
(an icon will indicate that the component is in the correct position).

6. You will now have a parent component with 3 subordinate components. It
will look like this:
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7. You now have a basic chart. But plain boxes are pretty boring, so let’s jazz
things up by giving our components unique shapes for each level.
8. Select the bottom three components by holding down the Left mouse
button and dragging an area slightly larger than the components we want to
select.

When you release the mouse button, the selected components will appear
with dotted lines around them. (Note: sometimes they will also appear with
either arrows or small boxes on each node - as in these illustrations depending if you are in Move or Resize mode.)

9. Open up the Shapes area of the Chart Design Palette by clicking on Shapes.
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10. Scroll down and select Folder Shape. Just as you did in Step 4, hold down
the Left mouse button, drag the Folder Shape icon from the Shapes area
and drop it on to any of three highlighted components.

Release the icon. All the selected components will now have folder shapes.

11. Now our chart has distinct shapes for each level, but it still looks flat. We’ll
give the components a nice three-dimensional feel by creating Drop Shadows.
12. To create drop shadows, select all the components by holding down the Left
mouse button and dragging an area slightly larger than all the components
(see below).
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Release the mouse and they will all be selected.

13. With all the components still selected, Right mouse click in an empty area
of any of the components. This will launch a pop-up menu.

14. In the pop-up menu go to View > Drop Shadow (shown above).
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15. Choose Drop Shadow. Click in an empty area of the chart to de-select the
components. Notice that the drop shadows are present, giving the components
a nice three-dimensional feel (see below).

16. The basic OrgChart is complete. Now let’s save it. To save your chart, go to
File > Save As.

17. When the Save As menu appears, type in the words ‘OrgChart Tutorial 1’
and click ENTER.
Congratulations! You have just created an OrgChart in record time! When you
are ready, move on to the next 5 minute segment where you will learn how to
enter information into the chart you just created.
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Part 2: Customizing data fields in 5 minutes
(Note: this lesson uses the chart built in Part 1. To load that chart, go to File > Open,
choose the file named OrgChart Tutorial 1 and click Open. The chart will appear in
the Main Work area).
In the previous lesson, you learned how to make a 3-D chart with components that
were unique on the outside. Now it is time to learn how to make components that are
unique on the inside.
The different areas inside a component are known as Data Fields. Data fields can
hold many types of information including text, attachments and even images. In this
exercise, we are going to customize the Name and Title data fields of our components.
Although there are many ways to do this, we will concentrate solely on using the Box
Item menu (located by default on the lower left side of the screen, directly below the
Chart Design Palette) to make our changes.

Box Item pane with Data View tab open on the left and Layout tab open on the right

Important: the Box Item menu only becomes active when a component is selected. If
no component is selected then it will appear empty with no data fields present.
Now that you are familiar with the basic principles of data fields, let’s move on to the
step-by-step process of using the Box Item menu to customize the names and titles of
each component.
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1. Let’s start by naming the parent component. To do this, click on the parent
component (the top one).

Notice that the Box Item menu is now active and is displaying the
component’s data fields.
2. To alter a data field, simply double click the field inside the Box Item menu
(to make it editable) and type the new information into the (highlighted) area.
With the parent still selected, double click inside the Name field in the Box
Item menu, type in the word ‘Parent’ and hit the ENTER key.

Box Item pane with ‘Parent’ in Name field on left and ‘OrgChart’ in Title field on right

Hitting ENTER applies the change to the on-screen component. It also
highlights the next lower data field in the Box Item menu and makes it
editable (in this example, the Title field).
3. In the Title field, type in the word ‘OrgChart’ (see above) and hit ENTER.
The title will appear on-screen.
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4. Repeat Steps 2 & 3 for each subordinate component.
To do this, select the subordinate component on the left side and type ‘Child
1’ into the Name field and ‘Subordinate’ into the Title field.
Do the same with the other components, typing ‘Child 2’ and ‘Child 3’ into
each respective Name field and ‘Subordinate’ into the Title fields of both.
Type in both the Name and Title fields for each subordinate component
BEFORE moving on to the next.
Notice that OrgChart remembers the last entry entered into a field (regardless
of component) and displays it - making re-typing the same information
unnecessary.
When you are done, the chart should look like this:

Now that your components have distinct names and titles, it is time to save
your work.
5. To save this chart, go to File > Save As, type in the name ‘OrgChart
Tutorial 2’ and click Save (for more details, see Part 1, Steps 15 & 16).
Congratulations! You have now learned the basics of data fields and how to customize the names and titles for each component. The final tutorial in this section will
show you how to add colors, titles, designs and more to give your chart a polished,
professional look.
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Part 3: Making your chart look professional in 5 minutes
(Note: this lesson uses the chart built in Part 2. To load that chart, go to File > Open,
choose the file named OrgChart Tutorial 2 and click Open. The chart will appear in the
Main Work area).
You now have a fully functional OrgChart. Now let’s snazz it up by adding colors, a
design, a title and even arranging all the elements in an eye pleasing fashion.
1. First, let’s set up our work area so we can see the entire chart. To do this, go
to the Zoom Toolbar and choose Fit to Window from either the drop down
menu, or click in the box and use the mouse scroll wheel.

2. Next, let’s automatically resize the components so they fill the page nicely.
To do this, simply click the Fit Chart to Pages button on the Select View
Toolbar.

The chart will now appear like this (see below):
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3. Now that the basics of our components are set up, it’s time to put them on a
nice background.
To apply background, go to the Chart Design Palette and click on the
Backgrounds bar.

4. Scroll down and select Grid. To apply the theme, hold down the Left mouse
button, drag the Grid icon from the Backgrounds area and drop it anywhere
on the chart. Notice that an attractive grid design now appears behind the
components (see below):
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5. Now let’s apply some colors! there are many ways to add colors to a chart
and its components, but the easiest is to simply use a Theme. Themes are
color coordinated, professional designs that can be applied by simply
dragging and dropping them on to a chart.
To apply a theme, go to the Chart Design Palette and click on the Theme bar.

6. Important: in default mode, themes do not affect the look or color of the
components.
To have components adopt a theme’s attributes, first select all the
components either: 1) manually by holding down the Left mouse button
and dragging an area slightly larger than all the components or 2) going to
Edit>Select All.
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Once all the components are selected, go to Shape > Format > Force
Apply Theme (see below):

Choosing this will force the theme to be applied to the components in
addition to other chart (and workplace) elements.
7. Scroll down and select Lavender. To apply the theme, hold down the Left
mouse button, drag the Lavender icon from the Themes area and drop it
anywhere on the chart. Notice that a color scheme and pattern is applied to
the entire chart and all the components (see below):
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Remember, backgrounds and borders can be applied using the same steps. .
8. The next step will be to name our chart. To do this, go to the Chart Design
Palette and click on the AutoTexts bar.

Select Chart Title. To apply, hold down the Left mouse button, drag the
Grid icon from the AutoTexts area and drop it in the center of the chart below
the components. (Notice that the default name of ‘Chart 1’ appears in the
element).
9. To change the name that appears in the Chart Title, AutoText element, go to
Data Outline View at the bottom of the Main Work area and click on the
Divisions View tab to bring up Divisions View (see below).
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10. Click on the word ‘Chart 1’ and Right mouse click to launch a pop-up
menu (see below):

11. Type in the words ‘OrgChart Professional’ and hit Enter or click OK to
apply the changes. The new title will appear in the on-screen AutoText.
12. The text in the AutoText Chart Title element is too small, so to make it larger,
click in the AutoText. A dark box will appear around the text to indicate that
it is editable. With the text still selected, go to the Format Toolbar and do the
following:


Click on the Font Type drop down box and choose Arial (if this is not
already present by default).



Click on the Font Style drop down box and choose Bold.



Click on the Font Size drop down box and choose the number ‘36’ (see
below).
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13. The changes will be applied automatically. Your chart should now appear
very similar to the following example:
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14. We’re almost done! All the elements are now present; now we just have to
arrange them in an attractive pattern. To do this, we will move the
components to the middle of the chart and center the title.
15. Components can only be moved when you are in Move mode. To enter Move
mode, click the Move Mode button (located on the Select View Toolbar).
(Note: the Move Mode button is a toggle switch which turns on and off if
selected repeatedly, so you may need to press it twice to get into Move mode.)

16. To move a group of components, click on the group’s parent. Green arrows
will appear on the parent’s nodes to indicate which directions are available
for movement. Red ‘X’s will indicate which directions are not available (see
below).
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17. Grab the DOWN GREEN ARROW on the parent component and while
holding down the Left mouse button drag downward to place the entire
group in the middle of the chart.
18. To center the title, simply grab the title (the words ‘OrgChart
Professional’) and holding down the Left mouse button, drag it to the
center of the screen. Your final result should look like this:

Congratulations! You have completed your first polished OrgChart! For more
detailed information on all of the processes involved in this tutorial, please see the
rest of the manual. Additional tips and resources are also available online at http://
www.officeworksoftware.com
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Chapter 1: OrgChart basics
This chapter will introduce you to the OrgChart environment, teach you how to
customize the workspace and outline many powerful and diverse chart making tools.
(Note: screens may appear slightly different on different systems.)

Welcome Screen
When OrgChart Professional loads, the user is greeted with the Welcome Screen.

This interface is active by default and contains a variety of tools to quickly and
efficiently facilitate the chart making process.
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Activating and deactivating the Welcome Screen


To deactivate the Welcome Screen, uncheck the “Show Welcome Screen
on startup” box. (Once this box is deactivated, the Welcome Screen will no
longer appear automatically when OrgChart loads.)



To activate the Welcome Screen, go to Edit > Options. On the General
screen, check the Welcome Screen - Display on application startup box.

Hiding and revealing startup Tips box
The Tips button is a toggle switch which changes depending on whether the box is
hidden or visible. The Tips box is visible by default.
1. To hide the Tips box, click the Tips button
2. To reveal the Tips box, click the Tips button

Welcome Screen chart creation and launch options
The Welcome Screen has five options to accelerate the chart development process:

Create new
blank
OrgChart
project

Create new
OrgChart
from existing
project or

Open existing
OrgChart
Professional
project

Launch Import
Wizard for data
importing
process

Create
OrgChart with
aid of Chart
Wizard

template

Note: All these processes can be accessed in other areas of OrgChart Professional

•

To activate options: Double click icons or click the OK button.

•

To cancel choice and/or close Welcome Screen: click the Cancel
button.
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Interface Overview
The following is OrgChart Professional’s powerful default configuration:

1

2
3

11

6
7

13
12

4
8

14

5

1.
2.
3.
4.
5.
6.
7.

9
10

Main Menu
Main Toolbar
Format Toolbar
Chart Design Palette
Box Item View
Select View
Arrange Subordinates

8.
9.
10.
11.
12.
13.
14.

Main Work Area
Outline View Control Bar
Data Outline View
Arrange Toolbar
Arrange Assistants Toolbar
Magnification / Zoom
Tutorial Pane

NOTE: this dynamic interface can be customized to match your own creative style. It
may also appear different on different hardware configurations and operating
systems. Certain buttons and interfaces may also be present or absent and appear in
different combinations depending upon your particular version of OrgChart.
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Toolbars and menus
Upper Tool Deck
The main location of OrgChart Professional’s tools is the Main Menu. From here,
you can gain access to virtually all of the program’s features (see below):
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Main Toolbar
This controls common file functions and several component editing features.

1

2

3

4

5

6

7

8

9

10

11

12 13

14

15

The Main Toolbar commands include:
1. New Chart - starts a new chart.
2. Chart Wizard - opens the chart wizard automated chart designer.
3. Open chart - opens a stored chart.
4. Save Chart - stores the chart for later retrieval.
5. Print - opens up the standard Windows print interface.
6. Chart /Layout Print Pages - this arranges multiple pages to cover an entire
chart.
7. Print Preview - opens the Print Preview screen to view your chart before
committing to printing.
8. Cut - removes an item from the workplace and places it on the Windows clipboard.
9. Copy - the original item stays in the workplace as a copy of it is placed on
the clipboard.
10. Paste - pastes items from the clipboard.
11. Paint Format - an amazingly powerful tool that takes the visual attributes of
a component (size, shape, text fonts, etc.) and applies them to another component or group of components. Fantastic for assigning unique formats to positions, divisions and professions.
12. Undo - this “un-does” mistakes (up to 20 previous actions).
13. Redo - “re-does” up to 20 previous actions that were “undone” by Undo.
14. Delete - removes an item or component.
15. Help - launches the OrgChart Professional help interface.
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Zoom Toolbar
From here, you can control the magnification of the chart area.

1

2

3

4

The Zoom Toolbar commands include:
1. Zoom in - increases magnification.
2. Zoom out - decreases magnification.
3. Magnification drop down menu - a list of default magnifications.
4. Background visibility - toggles Backgrounds on and off. (Note: the Background Visibility button will only become active after a Background has been
applied.)

Select View Toolbar
This controls the visual appearance of the work area.

1
2 3
4
5
The Select View Toolbar commands include:

6

7

8

1. Normal view - the default chart creation view (visually simple and uncluttered).
2. Print layout view - optimized view for printing (with ‘print safe’ borders,
extra tools and the ability to show how a chart is spread across multiple
pages).
3. Master Page view - a powerful mode which allows universal changes to be
applied to every page of a multi-page chart. It is extremely valuable for creating titles, logos, division names, etc. you wish to repeat on every sheet. This
view only reflects universal changes so elements which change from page to
page - such as individual chart elements and components - are hidden in this
mode. They reappear once Master Page view has been deactivated.
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4. Move mode - allows components to be moved on the chart. It effects components only and is only active when a component is chosen (see Moving
Components for details).
5. Resize mode - allows components to be resized on the chart. It effects
components only and is only active when a component is chosen (see
Resizing Components for details).
6. Fit chart to pages - resizes the components on a chart to fill up as much of
the available space as possible (see below).

Same chart BEFORE (left) and AFTER (right) ‘Fit Chart to Pages’ applied

7. Free move and resize mode - creates an area around the entire chart which
allows the chart - as a whole - to be moved and resized. (The moveable area
appears as a gray box with nodes at the corners - see below.)

Figure 1 Same chart BEFORE (left) and AFTER (right) 'Free move and resize' mode applied



To move the chart - place the mouse cursor in the gray box, hold down
the Left Mouse Button and drag to the desired location.



To resize the chart - place the mouse cursor over one of the nodes, hold
down the Left Mouse Button and drag to the desired size.



To exit Free Move and Resize mode - click the button again to toggle the
mode on and off.

8. Restore default chart position - returns the chart to its original location.
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Arrange Toolbar
This controls how certain Components are arranged on the chart.

1

2

3

4

5

The Arrange Toolbar commands include:
1. Autoarrange shapes - this automatically arranges components in a logical
order.
2. Reset subordinates’ positioning - this returns the subordinates to their
optimal location after having been manually repositioned. The subordinate’s
parent must be chosen for this button to become active.
3. Reset positioning - this returns a subordinate component back to its
previous optimal location after having been repositioned.
4. Move Sibling Left / Up - moves equal subordinates left (or up) the same
level.
5. Move Sibling Right / Down - moves equal subordinates right (or down) the
same level.

Format Toolbar
This controls font attributes:

1
2
3
4
The Format Toolbar provides the following font controls:

5

6

7

1. Font type - a drop down menu with a list of available alphabets.
2. Font style - a drop down menu with choices on letter orientation and weight.
3. Font size - a drop down menu for choosing the size of the letters.
4. Font color - this launches a palette of pre-defined and custom color options.
5. Left align text - text starts on the left side and expands to the right.
6. Center align text - text starts in the middle spreads evenly to the sides.
7. Right align text - text starts on the right and expands to the left.
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Themes Drop Down Menu
Clicking on the arrow opens up a list of Themes. (These themes can also be found in
the Themes area of the Chart Design Palette.)

Arrange Subordinates Toolbar
This menu is used to automatically arrange Subordinates in a variety of professional
patterns.

1 2 3
4
5 6
7
8
9 10 11 12
Important: the Parent component must be chosen for the Arrange Subordinates
functions to become active.

The following arrangement options are available:
1. Horizontal align center - distributes the subordinates equally on each side;
creating a very balanced pattern.
2. Horizontal stagger - creates a ‘stair-step’ pattern starting with the first
subordinate higher, followed a lower component, then followed by another
high one. This pattern is repeated with all the subordinates in a chain.
3. Horizontal align right - places all the subordinates in a horizontal line to the
lower right of the Parent.
4. Horizontal align left - places all the subordinates in a horizontal line to the
lower left of the Parent.
5. Horizontal Four Columns (Wide Organization) - equally distributes the
first four subordinates on a horizontal line beneath the Parent. Any additional
subordinates will appear in a new row beneath the first, using the Parent as
the center. A new row is formed every time the maximum number of four
subordinates is reached. (Note: this button only becomes active after four
subordinates are present, before that threshold, the button remains ‘grayed
out’.)
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6. Horizontal Six Columns (Wide Organization) - equally distributes the
first six subordinates on a horizontal line beneath the Parent. Any additional
subordinates will appear in a new row beneath the first, using the Parent as
the center. A new row is formed every time the maximum number of six
subordinates is reached. (Note: this button only becomes active after four
subordinates are present, before that, the button remains ‘grayed out’.)
7. Vertical align right - places all the subordinates in a vertical line to the
lower right of the Parent.
8. Vertical align left - places all the subordinates in a vertical line to the lower
left of the Parent.
9. Vertical side-by-side - stacks the subordinates side-by-side beneath each
other (very much like stacking crates). It is similar to Align center in that it
attempts to create a balanced pattern using the center for alignment.
10. Vertical staff right - effects only Staff components and places all staff elements on a vertical line facing to the right of the Parent.
11. Vertical staff left - effects only Staff components and places all staff
elements on a vertical line facing to the left of the Parent.
12. Vertical Four Columns (Wide Organization) - equally distributes the first
four subordinates on a horizontal line beneath the Parent. Any additional subordinates will attach vertically to the component above it, moving from left to
right, until the maximum number of four components per row is reached.
After that number, the process begins again on a new row. (Note: this button
only becomes active after four subordinates are present, before that threshold,
the button remains ‘grayed out’.)
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Arrange Assistants toolbar
This menu is used to automatically arrange Assistants in a variety of professional
patterns. (Note: Assistant buttons only become active when more than one Assistant
component is attached to the same Parent.)
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1. Assistant align right – Places all assistant components on a vertical line
facing to the right of the Parent.
2. Assistant align left – Places all assistant components on a vertical line
facing to the left of the Parent.
3. Assistant side-by-side – Stacks the assistant components side-by-side
beneath each other (very much like stacking crates). It is identical to normal
Side-by-side except it only works on Assistant components.
4. Align Assistants horizontal right – Stacks the assistant components on the
same level and side-by-side horizontally to the right of the Parent (very much
like a the links in a chain).
5. Align Assistants horizontal left – Stacks the assistant components on the
same level and side-by-side horizontally to the left of the Parent.
6. Align Assistants horizontal side-by-side – Stacks the assistants on the
same level and evenly* on either side of the Parent component.
7. Align Assistants vertical right – Stacks all of the assistants on top of each
other to the right of the Parent (very much like stacking crates, but only on
one side).
8. Align Assistants vertical left – Stacks all of the assistants on top of each
other to the left of the Parent.
9. Align Assistants vertical side-by-side – Stacks all of the assistants on top
of each other evenly* on either side of the Parent.
(*Note: Assistants are only stacked evenly if there are an even amount of
components. If an odd number of assistants are present, then one more assistant will
appear on one side of the Parent than on the other.)
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Outline View Control Bar
Introduced in OCP v.4, Enterprise Edition, this toolbar sits atop the Outline View
area and provides a convenient, central location for buttons and menus that are also
found in other areas of the program (see below):
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The Outline View Control Bar contains the following functions:
1. Edit Chart Data Set - launches the Chart Data Set menu. The Chart Data
Set interface sets global changes which can affect every component if you so
choose. From this menu you can: a) create new data fields, b) load predefined
fields, 3) edit fields, 4) rearrange the order in which fields appear and 5)
delete existing fields. (For more information on mastering data fields, please
see the Chart Data Set section.)
2. Edit Current Data View - launches the Edit Data View (Static) menu. By
modifying the currently selected data view, this interface determines what
data fields appear in the Box Item and Outline View areas. It also determines
the order in which these fields are displayed.
3. Define Data Views - launches the Define Data View menu. This interface is
used to add new data views which will then become available in the Current
Box Layout drop down menu. It can also be used to edit currently existing
data views.
4. Print Data Outline Pane - launches the standard Windows print interface.
This prints the names and values of the data fields currently displayed in the
Outline View area.
5. Print Preview Outline - launches a preview screen showing how the data
fields in the currently displayed Outline View area will appear when printed
out.
6. Locate Person - displays where a person’s component is located. It
automatically expands the division which contains the person and centers
their component on the screen.
7. Copy - takes information from one area and makes it available in another.
8. Export Wizard - launches the Export Wizard which takes the user step-bystep through the process of exporting data fields to various formats and
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locations. (For more information on exporting data, please see the Export
Wizard section of this manual.)
9. Data View Quick Selector - this drop down menu allows for the rapid
selection of available data views. This menu performs the same function as
the Current Box Layout drop down menu available in the Box Item area.
10. View Options - provides a choice of the different display options available
in Outline View.

Docked Menus
Two of OrgChart Professional’s most powerful and commonly used menus are the
Chart Design Palette and the Box Item menu. By default, both of these are docked on
the left side of the screen. (Note: both of these menus can be “un-docked” and
dragged almost anywhere in the workspace.)

Chart Design Palette
This is where most of the actual chart creation takes place. The Chart Design Palette contains the following seven (7) expandable areas:


Themes: visual motifs which effect the appearance of the chart, applied
components and certain menu views.



Backgrounds: patterns which appear only on the chart (but don’t effect
components).



Borders: designs which appear only along the outer edges of the chart.



Shapes: styles that modify a component’s shape. IMPORTANT: a shape can
only be applied to components that are already present on the chart.



Components: the building blocks of a chart. Components can be moved,
linked, hidden and resized. By default, they display an entry’s Name and Title
but can show an almost infinite range of information.



AutoTexts: boxes which contain the titles of Chart and Division which can
be automatically applied to the chart and customized.
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Note: Information inside an AutoText can only be changed from the Divisions
View. To change an AutoText, do the following:
1. Place an AutoText on the Chart.
2. Open up Divisions View.
3. In Division View, highlight the name of the level the AutoText is on.
The level will have a default name such as ‘Chart’, ‘Division 1’,
‘Division 2’, etc.
4. Press the F2 key to make the default Division name editable - or
right-click to rename.
5. Input the text you wish to appear in the AutoText.
6. Hit ENTER to apply the change.


Clipart: graphics and images designed to be inserted into charts to visually
enhance your presentations. OrgChart Professional comes with a preinstalled library of images. Users may also import images from almost any
source.

To expand an area of the Chart Design Palette click on an area’s title bar (In the
example below, the Components section has been expanded by clicking its title bar)
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Box Item menu
Dynamic in nature, this dialog displays the Data Fields for any currently selected
component. (Note: the Box Item menu will only become active after an ‘on screen’
component has been selected.)

Note: In versions prior to v5 there we two tabs in this Box Item view: Data and Layout. The Layout tab can now be found
in the Properties dialog for each box.

Data Outline View
Located at the bottom of the work area, the Data Outline View is an area that allows
the centralized management of component information. It can also be used to connect
components, assign Supervisors, and change Data Field content. (Note: Data Outline
View can only be toggled ‘on’ and ‘off’ through View > Data Outline View.)
Data Outline View can display information in list or hierarchy form.

Data Outline View with Hierarchy ON

Data Outline View with Hierarchy OFF
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To toggle Hierarchy View on and off go to View > Data Outline Pane >
Show Hierarchy. (A check mark will appear next to the title to indicate if
the view is on or off).

For the hierarchy view a plus sign (+) means the list can be expanded into a hierarchy. A minus sign (-) means the hierarchy is fully expanded. Clicking inside the
box a second time will toggle between views. Each level or component can have its
own hierarchy which can be expanded or contracted. The Data Outline View has
these additional features:


Edit multiple components and their data fields simultaneously -Note:
for multiple data fields to be edited at once, the data field being edited must
be empty in ALL of the chosen components. If any of the selected
components has an entry already in that field the process will not work.

To edit data fields in multiple components simultaneously, do the following:
1. Make certain that there is more than one component on the chart.
2. Choose multiple components by holding down the Left Mouse Button and
dragging diagonally across an area just wider than all of the components.
3. Examine the Data Outline View. Notice that the data fields for all the chosen
components turn blue.
4. With all of the components still selected, place the mouse cursor in one of
the on screen components.
5. Right click the mouse to bring up a pop-up menu of options.
6. Choose Properties from the pop-up menu. This will launch the Data
Properties interface.
7. In the Data Properties menu, edit the data field of choice and hit OK (for
more details on editing data fields, see the Editing component data section).
8. Click OK again to close the Data Properties menu.
9. Notice that your new entry appears in all of the components. (Note: the edited
data field must be set to ‘visible’ for each component or the change will not
be noticeable on screen.)
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Create new data fields with their own unique titles - New data field titles can
be created through a variety of methods. These new headings - such as Name,
Company, or any other topic you choose - will be displayed along the horizontal title
bar in the Data Outline View. For more details on creating new data fields, please see
the Changing component data section.

(Note: new data field headings will only appear on the Data Outline View title bar
after they are set to ‘visible’ in the Box Item menu. For more information on hiding
and revealing data fields, please see the Displaying and hiding a component’s data on
the chart section.)


Arrange the title bar in any order - Data field headings (such as Name,
Company, etc.) can be arranged in any order along the horizontal title bar in
Data Outline View. To change a heading’s location, do the following:

1. Click on the section of the title bar you want to move (i.e. Name, etc.).
2. Holding down the Left Mouse Button drag the section horizontally
across the title bar to a new location.

Rearranging by dragging across the title bar

A translucent copy of the section being moved will indicate the field’s
location as it is being moved. The copy will disappear when the mouse is
released.
3. Release the mouse button. The section will appear in the new location.


Resize title bars - to resize existing title bars:

1. Place the mouse cursor on the divider between one title area and another.
It will turn into a two sided arrow (see below):

1. Holding down the Left Mouse Button drag the arrow horizontally across
the title bar, making the area either larger or smaller. Notice that the size
of the data field changes accordingly.
2. Release the arrow. The title bar and the data field are now the new size.
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Moving and resizing toolbars
Moving a toolbar
Many of the toolbars can be moved from their original locations and placed almost
anywhere on the screen. To move a toolbar:
1. Left click on either: 1) the toolbar’s title or 2) the small vertical bar on the
toolbar’s left side.
2. Holding the Left Mouse Button, drag the toolbar to the desired position and
release.

Resizing a toolbar
To change a toolbar’s size:
1. Place the mouse cursor over either: 1) one of the toolbar’s edges or 2) in the
corner of the toolbar.
2. The mouse will change into a Duplex Arrow.
3. Hold down the Left Mouse Button and drag the toolbar to the desired size.
(Note: only the Chart Design Palette, Box Item menu, Data Outline View and Tutorials window can be resized; the small toolbars on the upper tool deck cannot be
changed.)
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Hiding and revealing toolbars
Toolbars can be hidden and revealed to un-clutter the workspace. In the View >
Toolbar menu, a check mark will be present or absent to indicate that the toolbar is
visible or hidden.

Hiding toolbars
To hide a visible toolbar:
1. Go to View > Toolbars.
2. Click on the name of the toolbar you wish to effect.
3. The toolbar will disappear.

Revealing toolbars
To display a hidden toolbar:
1. Go to View > Toolbars.
2. Click on the name of the toolbar you wish to effect. (Notice that there is no
check mark beside the tool’s name.)
3. The hidden toolbar will reappear.
NOTE: Hidden toolbars will reappear in their previous locations

Revealing and hiding other sections
The Data Outline View, Box Item, Status Bar and Tutorials window are not listed on
the Toolbars menu; instead, they are listed directly on the View menu. To hide and
reveal these areas:
1. Go to View.
2. Click on Data Outline View, Box Item, Status Bar, or Tutorials.
3. The chosen area will toggle in and out of view accordingly.
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Preparing the work area
Measuring tools and guides
For precision work, OrgChart Professional provides the following three measuring
tools and guides:


Rulers: Rulers can be added to the top and left of the work area. To perform
this operation, go to View > Show Rulers.



Grid: To superimpose a grid over a chart, go to View > Show Grid. (Note:
although visible on-screen, the grid never appears in the final version of the
chart.)



Snap to Grid: This option forces items to ‘snap’ only to the grid lines and
not to the spaces in-between. It is very good for precise alignments. To toggle
this option, go to View > Snap to Grid.

Zooming in and out
Chart magnification can be adjusted in the following two areas:


View > Zoom on the Main Menu.



The Zoom Toolbar.

By default, the work area view is set to “Fit to Window”. To change this setting:


Click the Zoom In button to increase magnification.



Click the Zoom Out button to decrease magnification.



Open up the Zoom Toolbar’s drop down menu and choose from the
magnification list.

Page 86 of 318

OrgChart Professional

Chapter 1: OrgChart basics



Manually enter a new zoom setting in the Zoom Toolbar. To do this:



Click in the Zoom Toolbar’s drop down menu.
1. Highlight the numbers in the drop down box by either double clicking
on the numbers or placing the cursor to the left or right then holding down
the Left Mouse Button and dragging over the numbers.
2. Type in a new magnification setting.



Left click in the drop down box and roll the Mouse Scroll Wheel to
increase or decrease magnification.

o Roll down to zoom in.
o Roll up to zoom out.
TIP: clicking in the Zoom Toolbar drop down box and using the mouse scroll wheel
is the most convenient way to zoom in and out.
(Note: to return the chart to its default view, open the Zoom Toolbar’s drop down
menu and choose ‘Fit to Window’.)

Screen Modes
Modes are screen configurations which have unique layouts and toolsets to streamline
the chart making process. OrgChart Professional has the following modes:


Full Screen



Chart Normal View



Master Pages View



Chart Print Layout View



Thumbnail View



Data Outline View



Divisions View
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Full Screen mode
This mode maximizes the work area by hiding distracting toolbars and frame elements.

Activating Full Screen mode
There are two methods to activate Full Screen mode:


Go to View > Full Screen.



Press the F11 key to toggle Full Screen mode on and off.

Returning to Chart Normal mode
There are three ways to return to Chart Normal mode:


Go to View > Full Screen.



Press the F11 key to toggle Full Screen mode on and off.



Click the ‘floating’ Return To Chart Normal box in the work area.

Chart Normal view
This is OrgChart Professional’s default configuration. This mode displays the
maximum number of tools to optimize all stages of chart creation while simultaneously allowing access to numerous data entry and information retrieval fields.

Activating Chart Normal mode
There are two ways to activate (or return to) Chart Normal mode:


Go to View > Normal View.



Press the Normal View button in the Select View Toolbar.
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Master Page View
Master Page view is a powerful mode which allows universal changes to be applied
to every page of a multi-page chart. This is extremely valuable for creating titles,
graphics, logos, information areas and anything else you wish to repeat on every
sheet.
In essence, Master Page view is a blank canvas which only reflects the universal
changes. Therefore, elements which change from page to page - such as individual
chart elements and components - are hidden in this mode. They reappear once Master
Page view has been deactivated.

Activating Master Page view
There are three ways to activate Master Page mode:


Go to View > Master Page.



Right click on an empty area of the chart. When the supplemental menu
appears, click on Master Page.



Press the Master Page button

in the Select View Toolbar.

Tips for Mastering ‘Master Page’ View
At first, Master Page view can seem confusing, but if you keep the following in mind,
you can master this powerful tool:


The chart seems to disappear in Master Page view - don’t worry! It is still
there, just hidden. It will reappear once Master Page view is deactivated.



Components cannot be placed on the Master Page - this occurs because the
Master Page will only accept universal (repeating and non-changing)
elements, whereas OrgChart interprets components as dynamic. Therefore, it
will not allow them to be placed in this mode.



Elements applied to the Master Page cannot be removed or modified
EXCEPT in Master Page view - this is done on purpose. By ‘locking’ these
repeating elements in the background, OrgChart allows for the unhampered
modification of your chart without having to worry about changing the
overall format.
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Applying a graphic using Master Page

1
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4

To apply a graphic using Master Page, do the following:
1. Star with a chart in Normal View.
2. Go to the Select View toolbar and click on the Master Page button to
switch to Master Page View (notice that the chart from Step 1 is now hidden).
3. Apply a graphic to the Master Page.
4. Close the Master Page by choosing another view (Normal, Print, etc.)
5. The process is complete. Notice that the chart from Step 1 and the graphic
from Step 3 are now both visible.
IMPORTANT TIP: AutoTexts as well as graphics can be applied in Master Page
view. Use AutoTexts for chart titles, division names, dates, or any other text you want
to appear on every page of your chart.
Fun Bonus Tip: Almost any type of graphic can be applied in Master Page view including photos. If you want to apply a photo and have it appear through a component of the chart, first apply the picture in Master Page view, then return to Normal view, choose the component you want the picture to appear through and set its
Transparency to 100% (Format > Fill Style > Color tab).
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Chart Print Layout view
This mode is optimized for chart printing. When in this view: 1) dotted ‘printer safe’
lines will appear in the work area and 2) several ‘grayed out’ areas of the Print
Toolbar will become active. From this mode, you can:


Add and delete print pages.



Change page orientation between Portrait and Landscape modes.



Arrange multiple pages to optimize the printing of oversized charts (charts
larger than a single page).

Note: the user must be in Print Layout view for certain print functions to become
active.

Activating Print Layout view
There are two ways to activate Print Layout view:


Go to View > Print Layout View.



Press the Print Layout View button on the Select View Toolbar.

Thumbnail View
One of the challenges posed by large charts is being able to conveniently navigate
while still seeing enough detail to actually find what you are looking for. OrgChart
Professional has solved this problem by creating the Thumbnail View.
In essence, the Thumbnail View acts as a reverse magnifying glass - showing a small
version of the entire background chart (which would otherwise be hidden
because of the high zoom factor). A red, selection rectangle in the thumbnail represents the enlarged area of the chart currently visible in the Main Work space (see
below).
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Thumbnail View in front of zoomed chart in Main Work pane (the red rectangle indicates the magnified area of the chart)

IMPORTANT TIP: the selection rectangle in Thumbnail View is most effective when
you are zoomed in close enough to see the details of individual components. If you
are zoomed out too far, the thumbnail - and its selection square - are indistinguishable
from the zoomed out view of the chart in the main work space.
Thumbnail View has two vital elements:



The Thumbnail pane - this displays a small picture of the entire chart.
The selection rectangle - this rectangle (red in color) appears inside the
thumbnail. It represents the area of the larger background chart which is currently in view. There are two ways to move the rectangle:

o With the mouse - place the mouse cursor inside the selection
rectangle, hold down the Left Mouse Button and drag the rectangle
to the desired location. A zoomed view of that area will appear on the
chart in the main work space.
o With the chart scroll bars - In the main work area, move the vertical
and/ or horizontal scroll bars (by either clicking on the bar and
dragging, or using the arrow buttons at the extremes of the bar).
Notice that the selection rectangle within the Thumbnail View moves
as you scroll.



To launch Thumbnail View - go to View menu and select Show Thumbnail.
To close Thumbnail View - choose from one of the following options: 1)
click the red X in the upper right corner of the Thumbnail View pane or 2) go
to the View menu and reselect Show Thumbnail (this will toggle the view off).
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Data Outline View
Located at the bottom of the work area, the Data Outline View is an area that allows
the centralized management of component information in table form. It can also be
used to connect components, assign Supervisors, and change Data Field content.

To access the Data Outline View (this view is on by default):


Go to View > Data Outline View to toggle the Data View on and off.



Choose the Data View tab at the bottom of the Data Outline View area.

Division View
Division View shares the same window as the Data Outline View but is accessed
through a different tab. This view allows you to view and navigate complex charts
easily. It does this by displaying the entire chart - including all hidden division subcharts - in an elegant and simple tree structure.

To access the Divisions View:


Go to View > Data Outline View to toggle the Data View on and off.



Choose the Divisions View tab at the bottom of the Data Outline View area.
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Tutorials window
OrgChart Professional contains an assortment of helpful web-based Flash tutorials
which quickly demonstrate how to perform many chart creation tasks (see below):

Viewing Tutorials
To view a tutorial:
1. Click on a subject to expand the list of available tutorials (the arrow next to
the subject will rotate from horizontal to vertical to indicate that the list is
open).
2. Click on a topic in the expanded list.
3. The tutorial movie window will open and display a menu of topics identical
to the expanded list.
4. Click on a topic in the tutorial movie window.
5. The tutorial will play automatically.
6. When the tutorial is finished, the options of Replay and Menu will appear in
the lower right corner of the movie window.



Replay - repeats the movie.
Menu - returns the user to a list of available tutorials.
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7. When you are finished watching the tutorials, click the “X” in the upper right
corner of the movie window to close the viewer.

Security - protecting your chart
OrgChart Professional comes with a password security feature which can be applied
to individual charts (see below). After a chart’s security is set, a prompt will appear
requiring the correct password to be entered before the chart will open.
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To access the Document Security screen - go to the Main Menu and
click on Tools > Protect Project.



To set the password - enter an identical password in both the Enter
password and Confirm password fields.



To access a protected chart - enter the correct password when the
OrgChart security prompt appears (see below):

Important: DO NOT lose your password! Password protected documents cannot be
accessed once the password is lost.
To complete this screen, choose one of the following options:


OK - enters the password.

o If the password is correct - the chart will open.
o If the password is incorrect - an Incorrect Password notification
will be displayed. (Remember, passwords are case sensitive so
double-check that you are entering your code correctly.)


Cancel - closes the security prompt without opening the locked chart.
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Chapter 2: Chart Creation
In this chapter, you will learn how to use OrgChart Professional’s many tools to
create compelling and informative charts.

Arranging chart elements
All charts are constructed by applying some (or all) of the following five elements.
They can be mixed and matched to create an almost infinite number of unique
designs.


Themes: visual motifs which effect the appearance of the chart, applied
components and certain menu views.



Backgrounds: patterns which appear only on the chart (but don’t effect
components).



Borders: designs which appear only along the outer edges of the chart.



Shapes: styles that modify a component’s shape. IMPORTANT: a shape can
only be applied to components that are already present on the chart.



Components: the building blocks of a chart. Components can be moved,
linked, hidden and resized. By default, they display an entry’s Name and Title
but can show an almost infinite range of information. (IMPORTANT: people
(components) can only be applied through the graphics interface.)



AutoTexts: boxes which contain the titles of Chart and Division which can
be automatically applied to the chart and customized.



Clipart: graphics and images designed to be inserted into charts to visually
enhance your presentations. OrgChart Professional comes with a preinstalled library of images. Users may also import images from almost any
source.

(Note: most of these elements can be accessed several different ways; though the
most convenient is often through the Chart Design Palette.)
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Working with Components
Components are the ‘building blocks’ of a chart. Movable, scalable, linkable and able
to contain vast amounts of information, they are the most basic and important
element of any project. Components are found in the Components Area of the
Chart Design Palette.
IMPORTANT! People (components) can only be applied through the graphics
interface!
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Opening the Components Area
1. Make certain the Chart Design Palette is visible (see Chapter 1: How to hide
and reveal toolbars).
2. Place the mouse cursor over the Components bar and Left Click the button.

Types of components
There are ten (10) basic components:


Single element components (only one element appears when the
component is dragged on the screen):

1. Executive: the largest default sized component. It is often used to start a
chart or head a division.
2. Position: the third largest default sized component. This size is the
default scale for most of the other components.
3. Assistant: a unique component designed to be attached and arranged to a
parent. It creates its own space on the main connector and acts independently of any other subordinate components which may be attached.


Multiple element components (several components appear as a group
when the component is dragged on the screen):

4. Multiple: launches the Multiple Shapes menu. From there, the number of
components and their styles are chosen before being placed on the chart.
5. 3 Positions: places three standard (position) sized components on the
chart. If this is attached as a subordinate, then the three components will
be linked when they appear.


Unique single components:

6. Team Frame: a scalable area with an editable title that can ‘frame’ other
components
7. Staff: a component with an ‘invisible’ border so only its ‘text’ information appears on-screen. To make a staff visible either: 1) go to the Chart
Design Palette, grab a Shape and drop it on the staff or 2) Right click
the staff and on the pop-up menu go to Format > Shape Style.
8. Text Block: a component designed for text entry.
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9. Dynamic Connector: a configurable connector used to join other components together.
10. Image: a combined image browser and image editor perfect for finding,
modifying and placing graphics onto a chart. It is also perfect for positioning logos (and the like) on multiple chart pages simultaneously by
placing them on a chart in Master Page View.

Adding components to a chart
Components can be placed on the chart in the following ways:


From the Components area - Double click a component.



From the Components area -Hold down the Left Mouse Button and
drag a component on to the chart.



From the Main Menu - Go to Chart > Add Component and choose a
chart from the pop-up menu.



Use the hotkeys - Alt + A.

Selecting Components
Once components have been placed on the chart they can be selected individually or
in groups.


To select an individual component, you can do any of the following:

o Click on the component with the mouse.
o Hold down the Left Mouse Button and drag diagonally across an
area just wider than the component.
o Go to Data Outline View and click on the component’s name.


To select multiple components at once:

o Hold down the Left Mouse Button and drag diagonally across an
area just wider than all of the components.
IMPORTANT: when multiple components are selected, all changes (new shapes,
formatting, etc.) will be applied to all of the components.
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Moving components
To move a component, do the following:
1. Enter Move mode -Important! Components can only be moved when Move
mode is active. To enter Move mode:


Go to View > Move Mode. Left mouse click this button to toggle
between the Move and Resize modes and back again. A check mark will
appear next to the name to indicate which mode is active.



Left click the Move Mode button on the Select View toolbar:

2. Select component - To select a component do the following:


Left click on the component with the mouse.



Hold down the Left Mouse Button and drag diagonally across an area
just wider than the component.



Go to Data Outline View and click on the component’s name.

3. Green arrows will appear on certain nodes to signify the component is ready
to be moved (see below).
Can move in ALL
directions

Can move in ONE
direction

Note: green arrows will only appear in the directions the component can be
moved. Red ‘X’ marks will appear in all the directions that are not available.
4. Left mouse click on any of the available arrows (nodes) to grab it.
5. Hold down the Left mouse button and drag the component in any of the
available directions.
Important: Although many components can be moved at once, only one component
can be highlighted at a time for movement.
To move many components at once, highlight the highest component in the hierarchy
(the uppermost parent) and move it. The rest of the subordinate components will
move along with the parent (as a group).
Page 101 of 318

OrgChart Professional

Chapter 2: Chart Creation

Resizing Components
To resize components, do the following:
1. Enter Resize mode -Important! Components can only be resized when
Resize mode is active. To enter Resize mode:


Go to View > Resize Mode. Left mouse click this button to toggle
between the Resize and Move modes and back again. A check mark will
appear next to the name to indicate which mode is active.



Left click the Resize Mode button on the Select View toolbar:

2. Select component(s) - Components can be selected individually or in
groups. There are three ways to select components:


Left click on the component with the mouse.



Hold down the Left Mouse Button and drag diagonally across an area
just wider than the component. This technique also works for selecting
multiple components.



Go to Data Outline View and click on the component’s name.

3. Blue boxes will appear on each of the component’s nodes to signify it is
ready to be resized (see below).
Component in
Resize Mode

4. Left mouse click to grab one of the nodes.
5. Hold down the Left Mouse Button and drag in or out to resize the
component.
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Deleting components
To delete a component from the chart:
1. Highlight the component.
2. Press the Delete key.

Component Cut, Copy and Paste
Components can be cut, copied and pasted. Each of these performs the following
function:


Cut: this deletes the selected component from the screen and places it on the
Windows Clipboard (in memory where it can be retrieved later and placed
elsewhere).



Copy: the selected component remains on-screen and a copy of it is placed
on the Windows Clipboard.



Paste: this puts the (previously cut or copied) component from the Windows
Clipboard on to the work area.

Connecting components through Cut, Copy and Paste
Components can be connected by cutting, copying and pasting. These commands can
be accessed in two ways:


Go to Edit on the Main Menu.



Use the Main Toolbar.

To connect components by cutting, copying and pasting:

1. Make certain two (unconnected) components are on the chart.
2. Cut or copy a component (we will call this Component #1).,
3. Highlight the second component (we will call this Component #2).
4. With Component #2 still highlighted, paste Component #1 from the
clipboard.
5. When Component #1 appears, it will be connected to Component #2.
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Editing component data
On-screen graphics are just a small part of what components can do. Components can
also contain vast amounts of information which can be entered, edited, exported and
even printed out.
A component’s information is displayed in Data Fields. These Data Fields appear in
the following areas:


The Box Item menu.



The Data Outline View area.



The Data Properties box.

Displaying a component’s data in the Data Fields
Click on a component to display its data. (Note: the Box Item menu and the Data
Outline View will remain empty until at least one component is selected.)

Displaying and hiding a component’s data on the chart
A component can have dozens of Data Fields - far too many to be displayed on the
chart. To solve this, the user can control which fields are visible. By default, the
Name and Title fields are active. To select which fields will be displayed:
1. Click on the desired component.
2. Right-click and select Properties. (or you can press Alt-Enter)
3. Go to the Define Layout tab in the Box Properties dialog. Notice that
each Data Field has a small check box. A check mark in the box indicates that
the field is visible; an empty box indicates it is hidden (see below):
4. Click in the visibility box to hide or display a field on the chart.
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Accessing individual Data Fields
There are four ways to access a component’s data fields:


Box Item: single click in a the box next to the field’s name.



Data Outline View: double click in the field of choice.



On-screen Component (method 1): double click in an empty area in the
component. This will launch a new Box Properties window. Once the
window appears, single click in a field for data entry.



On-screen Component (method 2): right click in an empty area of the
component. This will launch an additional menu. Go to the bottom of the
menu and choose Properties. This will launch the Box Properties interface.
Click on a data field and edit as normal.

Data Fields information types
Information fields may be of the following types:


Text -text information can be typed directly (or cut and pasted) into these
fields.



Link - double clicking this field launches a new interface for link creation.



Image -stored images are linked to a component through this field (see
Appendix B).



Attachment - stored information files are linked to a component through this
field (see Appendix B).

Changing components’ Data Fields
Data Field customization takes place in the following areas:


Global changes to ALL the data fields are made on the Default Fields Set
menu (for more details, please see the Default Fields Set section).



Changes to a single component’s data fields are made on the Data
Properties menu (for more details, please see the Data Properties section).
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Connecting components
Charts are created by taking independent components and linking them together in a
logical order (or hierarchy). There are six ways to link components together:


Drag and drop one component on another.



Drag a node from one component and attach it to a node on another component.



Use a Dynamic Connector to link two elements together.



Paste a (previously cut or copied) component on a highlighted element.



In the Box Item menu, click on the Supervisor field and choose from the
list.



In the Data Outline View, click on the name of a component and drop it over
the name of another component in the table.

Connecting by dragging and dropping
Most commonly you will use this method to connect boxes in the OrgChart.
1. Select an on-screen component by clicking on it.
2. With the original component still highlighted, go to Chart Design Palette >
Components.
3. Left mouse click on a new component.
4. Still holding down the Left mouse button, drag the new component over
the (still highlighted) on-screen component you wish to connect to.
5. Small icon boxes will appear indicating when the new component is in the
correct position to link either to the left, center or right of the original onscreen component (see below).

LEFT

CENTER
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6. When the icon indicates the direction you wish to place the new component,
release the left mouse button and drop it on the (still highlighted) onscreen component.
7. Notice that the new component appears to “jump off” the original element
and that the two are now connected.

Connecting components with a Dynamic Connector
A dynamic connector is unique because it does not show up in the database. It is
graphical only. Use the dynamic connector when you want to show a person who
reports to more than one supervisor.
1. Make certain two (unconnected) components are on the chart.
2. Go to Chart Design Palette > Components and drag a Dynamic
Connector on to the chart (between the two components).
3. Place the mouse cursor over one of the Dynamic Connector’s end nodes. The
cursor will turn into a pointing finger.
4. Hold down the Left Mouse Button and drag the Dynamic Connector’s end
node to a node on one of the components (a red square will appear to signify
that the connector can successfully link to the node; see below):
Component &
Dynamic
Connector

5. Repeat steps 3 -5 and attach the free end of the Dynamic Connector to a node
on the second component.
6. The two components are now linked.
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Connecting components through Cut, Copy and Paste
Components can be connected by cutting, copying and pasting. To do this:
1. Make certain two (unconnected) components are on the chart.
2. Cut or copy a component to the windows clipboard (we will call this component #1).
3. Highlight the second component (we will call this component #2).
4. With component #2 still highlighted, paste component #1 from the clipboard.
5. When component #1 appears, it will be connected to component #2.

Connecting components through the Box Item menu
1. Make certain two (unconnected) components are on the chart.
2. Click on a component.
3. Go to the Box Item menu and scroll down until the Supervisor field is
visible.
4. In the Supervisor field, click on ‘None’.
5. The ‘None’ field will appear to turn into a box. Click on the small arrow to
open up a menu that contains the names of other components on the chart (see
below):

6. Select the name of a component from the list.
7. On the chart, the two components are now linked.
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Connecting components through Data Outline View
1. Make certain two (unconnected) components are on the chart.
2. Go to Data Outline View. The names of both components are listed.
3. In the Name field, click on the first component’s name and drag and drop it
onto the name of the second component.
4. On the chart, the two components are now linked.
5. In the Data Outline View, the linking of the two components is signified by a
line which joins their names. (In the below illustration, Box 1 is the ‘parent’
and ‘Box 2’ is the ‘child’.)

Collapsing Subordinates in Data Outline View
In Data Outline View, the hierarchical tree of linked components can be collapsed or
expanded by clicking the box next to the Parent component’s name (see above
illustration).
Rule: A plus sign (+) in the box next to a name indicates that the tree is collapsed and
a minus sign (-) indicates that the tree is expanded.

Arranging components automatically
In addition to manual placement, components can be arranged automatically through
the following:


Parent components - use the Arrange Toolbar.



Subordinate (child) components - use the Arrange Subordinates commands. These can be accessed in the following ways:

o Go to Shape > Arrange Subordinates.
o Choose the Arrange Subordinates toolbar on the main interface.
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Arranging parent components
Parent components are arranged using the Arrange Toolbar (see below).

1

2

3

4

5

The Arrange Toolbar commands include:
1. Autoarrange shapes - this automatically arranges components in a logical
order.
2. Reset subordinates’ positioning - this returns the subordinates to their
optimal location after having been manually repositioned. The subordinate’s
parent must be chosen for this button to become active.
3. Reset positioning - this returns a component back to its previous optimal
location after having been repositioned. a drop down button with 5 vertical
arrangements for subordinate components.
4. Move Sibling Left (up) - moves equal subordinates left (or up) the same
level.
5. Move Sibling Right (down) - moves equal subordinates right (or down) the
same level.

Arranging subordinate components
A subordinate component (sometimes referred to as a child) is an element which is
beneath another component in a chart’s hierarchy. (The higher component is often
known as the parent.) Subordinate components can be arranged either manually or
through the Autoarrange Shapes functions.
Note: all automated arrangement functions require that the parent component be the
only selected element. If the parent is not selected, the options will be inactive (or
‘grayed out’). The only exception to this is Move Left/Right, which only becomes
active when a sibling is selected.
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Arranging a subordinate manually
1. Select an on-screen subordinate by Left mouse clicking on it.
2. Holding down the Left mouse button, drag the new component over
another sibling. An outline of the sibling being moved will appear (see
below).
Parent

Sibling 1

Sibling 2

Sibling 3

Sibling One being manually dragged & dropped into Sibling Three's position

3. A small icon box (with tiny direction arrows or a box pointing up or down)
will appear (see above).
4. When the icon indicates the direction you wish to place the original sibling,
release the left mouse button.

5. Notice that the original sibling has taken the position of the one it was
dropped on. All the additional siblings shift place accordingly.

Arranging subordinates automatically
The Autoarrange Shapes functions can be accessed in two ways:


Go to Shape > Arrange Subordinates.



Click on any of the functions on the Arrange Subordinates toolbar.

1

2

3

4

5

6

7

8

9

10

11 12

Important: the Parent component must be chosen for the Arrange Subordinates
functions to become active. Also, Assistant align right, Assistant align left and
Assistant Side-by-side only become active when more than one Assistant component
is attached to the same Parent.
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The following arrangement options are available:
1. Horizontal align center - distributes the subordinates equally on each side;
creating a very balanced pattern.
2. Horizontal stagger - creates a ‘stair-step’ pattern starting with the first
subordinate higher, followed a lower component, then followed by another
high one. This pattern is repeated with all the subordinates in a chain.
3. Horizontal align right - places all the subordinates in a horizontal line to the
lower right of the Parent.
4. Horizontal align left - places all the subordinates in a horizontal line to the
lower left of the Parent.
5. Horizontal Four Columns (Wide Organization) - equally distributes the
first four subordinates on a horizontal line beneath the Parent. Any additional
subordinates will appear in a new row beneath the first, using the Parent as
the center. A new row is formed every time the maximum number of four
subordinates is reached. (Note: this button only becomes active after four
subordinates are present, before that threshold, the button remains ‘grayed
out’.)
6. Horizontal Six Columns (Wide Organization) - equally distributes the
first six subordinates on a horizontal line beneath the Parent. Any additional
subordinates will appear in a new row beneath the first, using the Parent as
the center. A new row is formed every time the maximum number of six
subordinates is reached. (Note: this button only becomes active after four
subordinates are present, before that, the button remains ‘grayed out’.)
7. Vertical align right - places all the subordinates in a vertical line to the
lower right of the Parent.
8. Vertical align left - places all the subordinates in a vertical line to the lower
left of the Parent.
9. Vertical side-by-side - stacks the subordinates side-by-side beneath each
other (very much like stacking crates). It is similar to Align center in that it
attempts to create a balanced pattern using the center for alignment.
10. Vertical staff right - effects only Staff components and places all staff elements on a vertical line facing to the right of the Parent.
11. Vertical staff left - effects only Staff components and places all staff
elements on a vertical line facing to the left of the Parent.
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12. Vertical Four Columns (Wide Organization) - equally distributes the first
four subordinates on a horizontal line beneath the Parent. Any additional subordinates will attach vertically to the component above it, moving from left to
right, until the maximum number of four components per row is reached.
After that number, the process begins again on a new row. (Note: this button
only becomes active after four subordinates are present, before that threshold,
the button remains ‘grayed out’.)

Arrange Assistants toolbar
This menu is used to automatically arrange Assistants in a variety of professional
patterns. (Note: Assistant buttons only become active when more than one Assistant
component is attached to the same Parent.)

1

2

3

4

5

6

7

8

9

1. Assistant align right – Places all assistant components on a vertical line
facing to the right of the Parent.
2. Assistant align left – Places all assistant components on a vertical line
facing to the left of the Parent.
3. Assistant side-by-side – Stacks the assistant components side-by-side
beneath each other (very much like stacking crates). It is identical to normal
Side-by-side except it only works on Assistant components.
4. Align Assistants horizontal right – Stacks the assistant components on the
same level and side-by-side horizontally to the right of the Parent (very much
like a the links in a chain).
5. Align Assistants horizontal left – Stacks the assistant components on the
same level and side-by-side horizontally to the left of the Parent.
6. Align Assistants horizontal side-by-side – Stacks the assistants on the
same level and evenly* on either side of the Parent component.
7. Align Assistants vertical right – Stacks all of the assistants on top of each
other to the right of the Parent (very much like stacking crates, but only on
one side).
8. Align Assistants vertical left – Stacks all of the assistants on top of each
other to the left of the Parent.
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9. Align Assistants vertical side-by-side – Stacks all of the assistants on top
of each other evenly* on either side of the Parent.
(*Note: Assistants are only stacked evenly if there are an even amount of
components. If an odd number of assistants are present, then one more assistant will
appear on one side of the Parent than on the other.)
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Arranging siblings with the Move Left and Move Right buttons
Siblings are child (or subordinate) components that are on the same hierarchical level
(see below):

Siblings can be rearranged on the same level by using the Move Left and Move
Right buttons. Important: the Move Left/Right function only becomes active when a
sibling is selected.

There are two ways to access the Move Left and Move Right functions:


Go to Chart > Move Sibling > Move Left/Up - Move Right/Down.



Choose either button from the Arrange Toolbar.

BEFORE Left / Right move

AFTER Left / Right move
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Controlling graphics with the Image component
The Image component is one of the easiest and most powerful ways to place graphics
on a chart.
Unlike the other components, such as Executive or Team Frame, this item does not
attach directly into a chart’s hierarchy. Instead, the Image component launches a
combined image browser and graphics editor. It is perfect for finding, modifying and
placing graphics onto a chart. It is also ideal for positioning logos (and the like) on
multiple chart pages simultaneously by placing them on a chart in Master Page View.

Activating the Image component
Similar to the other components, the Image component is activated in the following
two ways:


Double click the Image icon in the Components area.



Hold down the Left Mouse Button then drag-and-drop it onto the chart.

Unlike the other components, however, the component will not appear on the chart.
Instead, the Image Component interface will be automatically launched (see below):

The Image Component interface is a combined image browser and graphics editor
that can perform the following functions:


Navigate to an image.
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Adjust an image’s brightness, contrast, opacity, tint and tint color.



Adjust or maintain an image’s aspect ratio (Note: these two options are only
available after an image has already been placed on the chart and the Image
Control interface is opened by double clicking on the image.)

Using the Image component to place a graphic
To use the Image component to place a graphic on a chart, do the following:
1. Go to the Components area of the Chart Design Palette.
2. Activate the Image component by either double clicking on it, or dragging
and dropping it onto the chart work area.
3. The Image Component interface will open.
4. Click the Select Image button to open up the browser.
5. Use the browser to navigate to the desired image’s location.
6. Once the graphic has been located, highlight it and click the OK button.
7. The graphic will appear in the Image Component interface’s Preview Pane.
8. If necessary, use the sliders to adjust the image’s brightness, contrast, opacity
and tint. Press the Tint Color button if you wish to access additional options
regarding the graphic’s tint. (Note: the Maintain Aspect Ratio While Resizing
and Restore Original Size options only become available when adjusting a
graphic which is already on the chart.)
9. Click the OK button.
10. The image will appear on the chart.
To adjust the attributes of a graphic which is already on the chart

1. Double click on the graphic.
2. The Image Component interface will open.
3. Use the sliders to adjust the image’s brightness, contrast, opacity and tint.
Press the Tint Color button if you wish to access additional options regarding
the graphic’s tint. If necessary, check or unchecked Maintain Aspect Ratio
While Resizing and Restore Original Size depending on your preferences.
4. Click the OK button and the changes will be applied to the image on the
chart.
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Divisions
Divisions are groups of subordinate components which can be hidden or expanded in
the main chart. Each Division can be also displayed on its own page. Divisions are
ideal for organizations that want to represent business units, teams or groups.
Tip: When creating charts with many people, breaking the chart up into divisions is
very helpful.

Creating, expanding and hiding Divisions
To create a Division:
1. Choose a component which will be the division head. We will refer to this as
the division Parent.
2. Make certain a subordinate component is connected to the Parent.
3. Select the Parent component and either:


Choose Division > Create from selected on the Main Menu.



Right mouse click and choose Create Division from the pop-up menu.

4. A large down arrow will appear in the Parent component to indicate that a
Division has been successfully created (see below).
Division
Parent

Click down arrow to display Division sub-chart

5. Click the large down arrow to display the Division sub-chart. This chart will
appear on its own page. The division’s Parent (the same component which
appears on the main chart with the down arrow) will appear at the top of the
division’s sub-chart, but this time with a large up arrow (see below)
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Division sub-chart
(Click up arrow to return to main chart)

Division
Parent

Division
Subordinate

6. To hide and expand a Division sub-chart in the main chart, click the
small hide/reveal icon in the division’s Parent component (it will appear as a
small triangle in the right corner). When a division is displayed on the main
chart, the large down arrow (used to switch between the main chart and
Division sub-chart) appears at the bottom of the division’s bounding box (see
below).

Same chart with Division hidden (left) and revealed (right)
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Division View
Division View allows you to view and navigate complex charts easily. It does this by
displaying the entire chart - including all hidden division sub-charts - in an elegant
and simple tree structure (see below).



To access Division View:
1. Make certain that Data Outline View is active by choosing View > Data
Outline View.
2. Click the Division View tab at the bottom of the Data Outline View window (see above).



Divisions View tree conventions:
o Main chart - situated at the top of the tree in the upper left corner.
o Highest tier Divisions - these first divisions run vertically along the
left of the diagram.
o All additional (lower) divisions - run in a staggered (stair step)
pattern from left to right; starting from their Parent (first tier)
divisions (see below).
o Navigating in Division View - simply click on the division’s
name and the chart for that division will appear in the Main Work
Area.

MEGA-TIP: The easiest way to move between data fields is to highlight a field and
use the keyboard ARROW keys. (This works for both on-screen components and
data field menus such as Data Outline View, Box Item and Division View.)
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Shapes
Shapes are styles that modify a component’s outline. By default, OrgChart Professional comes with the following shapes (see below):

(IMPORTANT: a shape can only be applied to components that are already present
on the chart.)
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Accessing the Shapes menus
Shapes can be accessed in the following ways:


Go to the Chart Design Palette and click on the Shapes button (pictured
above).



Select a component, then go to Shape > Format > Shape Style.



Right click a component to launch a pop-up menu. On the pop-up menu
click Format > Shape Style.

Applying shapes to a chart
Shapes may be applied in the following ways:


Drag and drop a shape icon from the Shapes menu directly on to the chart.



Double click a shape icon in the Shapes menu and it will appear on the
chart.



In the floating menu launched by Shape > Format > Shape Style, either:
1) double click a shape icon or 2) select an icon and press OK.

Example of a component with an applied shape

BEFORE

AFTER

Hiding and revealing shapes
1. Right click a component. A pop-up menu will appear.
2. On the pop-up menu, go Format > Hide Shape. The shape modification will
disappear (although the component will still be visible on screen). A check
mark will appear on the menu to indicate that the shape is hidden.
3. Repeat steps 1 and 2 to toggle the shape back into view.
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Apply Scope
Apply Scope is a powerful and intuitive interface which allows you to quickly set the
range and locations of the changes in your chart. Now, with a single mouse click you
can effect everything from the data in individual components to the look of the entire
chart (and everything in between).

There are slightly different variations of the Apply Scope interface in different parts
of OrgChart, but all have versions of the same following options:


Selection - effects only the currently selected components (this option is
available in Paint Format’s scope but not in Themes, Backgrounds or
Borders).



Entire Chart - effects the entire chart.



Current Division - effects only the currently selected division.



Division and below - effects the currently selected division and every
division beneath it.

To use Apply Scope:

1. In the Chart Design Palette double click on a Theme, Background or
Border. The Apply Scope interface will appear. (Drag and drop activation is
only available in certain versions.)
2. Click the appropriate radio button to choose the scope, then click OK.
3. The changes will be applied.
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Themes
Themes are visual motifs which effect the appearance of the chart, most of the chart’s
components and certain menu views. By default, OrgChart Professional comes with
the following themes (see below):
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Accessing Themes
To access Themes, do one of the following:


Go to the Chart Design Palette and click on the Themes button.



Go to Chart > Theme .



Right click in an empty space in the chart to bring up the contextual menu
and choose Themes. A menu similar to that shown below will appear.

Applying Themes to a chart
To apply Themes, do one of the following:


Drag and drop a theme icon from the Themes menu directly on to the chart.



Double click a theme icon in the Themes menu and it will appear on the
chart.



Choose a theme from the Themes Drop Down Menu.



In the Chart > Theme floating menu, choose a theme and click OK.
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Example of an applied Theme
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Backgrounds
Backgrounds are patterns which appear only on the chart but don’t effect components. By default, OrgChart Professional comes with the following backgrounds (see
below):
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Accessing Backgrounds
To access Backgrounds, do one of the following:


Go to the Chart Design Palette and click on the Backgrounds button (pictured above).



Go to Chart > Background > Style (this will launch a menu similar to the
one pictured above).



Right click in an empty area of the chart and choose Background Style from
the pop-up menu.

Applying backgrounds to a chart
To apply a background, do one of the following:


Drag and drop a background icon from the Backgrounds menu directly on
to the chart.



Double click a background icon in the Backgrounds menu and it will
appear on the chart.



In the floating menu launched by either Chart > Background > Style or
right clicking an empty space and choosing Background style either: 1)
double click a background icon or 2) select an icon and press OK.
Example of a chart with an applied background
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Hiding and re-displaying a background
The background on a chart can be toggled from visible to hidden by:


Going to Chart > Background > Hide.



Right clicking an empty space on the chart to bring up a pop-up menu and
choosing Hide Background.

Borders
Borders are designs which appear only along the outer edges of a chart. They can be
resized and placed on charts which already have themes and backgrounds. By default,
OrgChart Professional comes with the following borders (see below):
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Accessing Borders:
To access Borders, do one of the following:


Go to the Chart Design Palette and click on the Borders button.



Go to Chart > Border.

Applying borders to a chart
To apply a border, do one of the following:


Drag and drop a border icon from the Borders menu directly on to the chart.



Double click a border icon in the Borders menu. It will appear on the chart.



Go to Chart > Border and either: 1) double click a border icon or 2) select
an icon and press OK.
Example of a chart with an applied border

Selecting Borders
To select a border do one of the following:


Place the mouse cursor over the border. A dotted line will appear at the edge
of the chart. Click the border to secure the selection.



Click in one of the border’s text areas.
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Customizing borders - text
Many borders have text areas which are designed to be customized.
To modify all border text at once:

1. Select the border (see Selecting Borders for details).
2. Access a text format modification area by doing one of the following:


Go to Shape > Format > Font Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Font Style.



Go to the Format Toolbar (see below).

3. Once in any of these areas, use the methods of each toolbar or menu to
choose the new text attributes and apply them accordingly.
To modify just one area of border text:

1. Select the border (see Selecting Borders for details).
2. Place the mouse cursor over a text area. The letter “T” will appear at the base
of the mouse arrow.
3. Double click the text area. It will turn black (this signifies that the text area
is selected).
4. Access a text format modification area by doing one of the following:


Go to Shape > Format > Font Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Font Style.



Go to the Format Toolbar (see above).

5. Once in any of these areas, use the methods of each toolbar or menu to
choose the new text attributes and apply them accordingly.
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Customizing borders - line style
1. Select the border (see Selecting Borders for details).
2. Access a Border Style menu by doing one of the following:


Go to Shape > Format > Border Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Border Style.

3. In the Border Style menu, make all your choices and apply them accordingly
(for details, see Appendix A: Border Style).

Customizing borders - fill style (color)
1. Select the border (see Selecting Borders for details).
2. Access a Fill Style menu by doing one of the following:


Go to Shape > Format > Fill Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Fill Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Border Style. Once in the Border Style menu,
click the Fill button.

3. In the Fill Style menu, make all your choices and apply them accordingly (for
details, see Appendix A: Fill Style).

Replacing border styles
To change from an already applied border style to a new one:
1. Select the applied border (see Selecting Borders for details).
2. Remove the border by pressing Delete.
3. Apply a new border by either:


Going to Chart > Border. When the floating menu appears, select a new
chart design and apply it (see Applying borders to a chart).



Open Chart Design Palette > Borders and apply a border (see
Applying borders to a chart).
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AutoTexts
AutoTexts are fields which contain both automatically generated and user defined
information which can be applied to a chart.


User defined AutoTexts require manual input of information, such as a
Chart’s title, or the name of a division. User defined AutoTexts are: 1) Chart
Title, 2) Division Title and 3) Division Number.



Automatically generated AutoTexts supply information directly from your
computer’s operating system, such as the user, time and date. These
AutoTexts include: 1) Creator Name, 2) Organization, 3) Current Time and 4)
Current Date.

NOTE: All of these fields can be edited manually by: 1) highlighting the current entry
and then 2) typing in the new information

Accessing AutoTexts:


Go to Chart > Add Autotext Element.



Go to the Chart Design Palette and Left mouse click on Autotexts.
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Applying AutoTexts to a chart
AutoTexts can be applied in the following ways:


Drag and drop an icon from the AutoTexts menu directly on to the chart.



Double click an icon in the AutoTexts menu and it will appear on the chart.



Go to Chart > Add AutoTexts Element. This will open up the Add
AutoText Element menu. From here, either: 1) double click an icon or 2)
select an icon and press OK.

Modifying Autotexts text
Important: Information inside an AutoText can only be changed from the Divisions
View. To change an AutoText, do the following:
1. Place an AutoText on the Chart.
2. Open up Divisions View.
3. In Division View, highlight the name of the level the AutoText is on. The
level will have a default name such as Chart, Division 1, Division 2, etc.
4. Press the F2 key (or right-click) to make the default Division name editable.
5. Input the text you wish to appear in the AutoText.
6. Hit ENTER to apply the change.
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Clipart
OrgChart Professional is designed to incorporate a wide range of graphics to visually
enhance your presentations. OrgChart ships with a clipart library that can be accessed
directly through the Clipart area of the Chart Design pane, or users may import their
own images from almost any source.

Accessing OrgChart’s Clipart Galleries
To access the built in clipart libraries:
1. Go to the Chart Design Palette.
2. Left mouse click on Clipart.
3. The clipart area will expand, revealing an area similar to the illustration
below. (Please note: the appearance of the images in this area will be
different depending upon the clipart and gallery you have chosen):
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Placing Clipart on a Chart
Clipart may be placed on a chart in two ways:


Double click the desired piece of clipart in the Clipart area:

1. The picture will then appear in the upper left corner of the chart.
2. To move the picture, hold down the Left Mouse Button and drag the
graphic to the preferred position, then release.


Drag and drop

1. Place the mouse cursor over the picture in the Clipart area.
2. Hold down the Left Mouse Button and drag the picture to the desired
location on the chart, then release.

Placing a Clipart Image on Multiple Chart Pages
To place a piece of clipart on every page of a multi-page chart, do the following:
1. Switch to Master Page View (View > Master Page).
2. Place the clipart on the Master Page by using one of the methods detailed in
the Placing Clipart on a Chart section (above).

Clipart Galleries
OrgChart Professional organizes clipart images by placing them in galleries.
Galleries are collections of images based on similar subject matter, such as Sports, or
Office Supplies (which are two galleries that ship with certain versions of Org-Chart).
To access a gallery click on the Galleries drop down menu in the Clipart section
and choose from the available list (see below).
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Manually Adding a Clipart Gallery
In addition to using OrgChart’s built in clipart libraries, you can manually create
your own unique image galleries and have them appear in the program’s Clipart area.
In OrgChart, every clipart gallery is represented by a single, unique XML file. In this
system, you can either specify an image’s exact location, or create a relative path
leading to the directory which contains the gallery’s descriptor file.
How to Create a Clipart Gallery

To build a clipart gallery (which will appear in the program) you must first create an
XML file. The file must adhere to the following rules:


File name - You can name the file anything you wish so long as it has the
xml extension at the end. For example, a file might be called
“Gallery_0000.xml” or “MyCoolGallery.xml”. Choose a name that will be
descriptive of the contents and easy for you to identify.



Directory structure - The best approach is to create a separate directory for
each gallery. This directory should then contain: 1) the clipart images and 2)
the XML gallery descriptor file. For example, you might create a directory
folder entitled “Gallery_0000” - this folder would then contain the XML
descriptor file (let’s call it “Gallery_0000.xml”) and any clipart images (for
example “Image01.gif”, “Image02.bmp”, etc.).



Placement of clipart directories (Paths) - Upon loading, OrgChart
searches the following paths to locate any clipart galleries:

o <Documents and Settings Director>\All Users\ Application Data\OrgChart Professional\OrgChart Professional\Clipart\
o <Documents and Settings Director>\<Current User>\Application
Data\OrgChart Professional\OrgChart Professional\Clipart\
Your gallery should be located at the end of either of these paths to be found
and loaded into the program.
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Example of XML gallery (descriptor) file format:

<?xml version=“1.0” encoding=“UTF”-8”?>
<Gallery>
<Name>Gallery Name goes here</Name>
<Description>Gallery Description goes here</Description>
<Items>
<Item>
<Path>image0.jpg</Path>
<Description>Image description goes here</Description>
</Item>
<Item>
<Path>image1.emf</Path>
<Description>Image description goes here</Description>
</Item>
...
</Items>
</Gallery>

Changing the order of data fields
To change the order of a component’s data fields:
1. Select the component. Its data fields will appear in the Box Item menu.
2. Go to the Box Item menu and select the field you wish to move.
3. Click the Move arrows at the top of the Box Item menu to move the selected
data field higher or lower on the list (see below).
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Customizing the appearance of components and connectors
Components and connectors can be customized to meet all your chart making needs.
By default, components first appear as simple rectangles which display the Name and
Title fields in 12 pt. (bold) Arial font. Connectors appear as plain black lines. These
can be changed to much more interesting designs through the Shape > Format
menus.

Accessing the Shape modification menus
The Shape modification menus can be accessed in two ways:


Go to Shape > Format on the Main Menu and choose from the expanded list
of menus. Note: for this method an on screen component must be selected or
the shape modification menus will be inactive (‘grayed out’).



Right click an on screen component to launch a pop-up menu. When the
menu appears, go to Format and choose from the expanded list of menus.

The following is a detailed look at the various shape modification menus and how to
use them to customize your components and connectors:

Page 140 of 318

OrgChart Professional

Chapter 2: Chart Creation

Fill Style menu
This menu is divided into the following four areas (pictured below):

Accessing Fill Style menus
Click on a tab to display any of the Fill Style menus:



Color: choose a standard fill color or create a custom one.



Gradient: choose a gradient (gradual transition) from one color to another.



Pattern: choose from a menu of pre-loaded patterns.



Picture: choose a picture then apply a tint color (to change its shade).
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Font Style menu
This custom interface allows you to assign Font Family, Font Size, Font Weight,
Effects, Script and Fill Style (see below).

Note: text alignment cannot be done through this menu. To align text within a component, go to the Format Toolbar and choose either the Align Left, Align Center or
Align Right buttons (a component’s text is centered by default).

Page 142 of 318

OrgChart Professional

Chapter 2: Chart Creation

Border Style menu
This menu controls the appearance of the line which defines a component’s shape.
You can control the following: Line Style, Line Width, Fill Style, Join Style and
Transparency.

Connector Style menu
This controls the appearance of a component’s connector and of Dynamic Connectors. From here you can control: Line Style, Line Width, Join Style, Fill Style, and
how a connector starts and ends (i.e. with an arrow, plain, etc.). See below:
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Important: you cannot directly select the connector between two components (if you
wish to edit it). Instead, you must choose one of the components and then bring up the
Connector Style menu.

Drop Shadow
This option creates a shadow effect; thereby giving the component a three dimensional appearance. Clicking this entry toggles the shadow on and off (a check mark
will appear next to the entry accordingly).

Drop Shadow OFF

Drop Shadow ON
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Using Auto Adjust Size & Word Wrap on components
Components can hold and display an almost encyclopedic amount of text. To keep
this information orderly and within each component’s confines, OrgChart Professional has Word Wrap and Auto Adjust Size.


Word Wrap - keeps the length of the text within the width of a component. It
makes the component longer to accommodate excessive text.



Auto Adjust Size - extends the width of the component to accommodate the
length of the text. This feature was enhanced in v5 to calculate the size of all
visible boxes in a chart to the same size. This feature will automatically be
turned off for any box whose size is manually adjusted.

Note: Both of these functions are on by default:
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To toggle Text Wrap and Auto Adjust Size on and off:


Go to Shape > View and choose either Word Wrap or Auto Adjust Size.



Right mouse click a component to launch a pop-up menu. When the menu
appears go to View and choose either Word Wrap or Auto Adjust Size.
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Paint Format: the ultimate component modifier
One of OrgChart Professional’s most powerful modifiers is Paint Format. This
amazing tool allows you to take the visual attributes of one component - such as its
shape, color and font - and transfer those same attributes directly to other components
in your chart.
The changes can be as sweeping, or as precise, as you need - from individual components, to divisions or even to the entire chart. Paint Format even has the ability to
focus on specific professions or titles. So, for example, you could create a unique
format for each profession, then apply those unique changes across the entire project
(such as automatically applying a gold chevron to all supervisors and a green folder
to all accountants).
Tip: Think of Paint Format as a clone tool that only effects a component’s appearance, yet leaves all the component’s unique information intact and unchanged.
Paint Format has two modes:



Selection mode (this is on by default).
Special mode.

To toggle between these two modes, click the small arrow to the right of the button
(see below):
BEFORE Paint Format applied

Source Component

Destination Component

AFTER Paint Format applied

Source Component

Destination Component

Note: The Paint Format button will only become active when a single component is
currently selected; otherwise it will appeared ‘grayed out’.
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Selection mode
Choose this mode when you wish to manually copy format changes. To use Selection
mode, do the following:
1. Select the source component which contains the format you wish to copy.
2. Click the Paint Format button -notice that the button stays depressed.
3. Highlight the destination component(s) you wish to apply the changes to. (For
single components, simply click on the component. For multiple components,
hold down the Left Mouse Button and drag a rectangle around the group;
the components will appear highlighted when the button is released.)
4. The destination component(s) will now have the same visual format as the
source component.

Special mode
Select this option when you wish to apply format changes automatically. Special
mode works by launching the Paste Format interface (see below):

This interface is divided into two basic areas: 1) scope and 2) conditions.
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1. Scope - this area determines the range and locations in the chart that your
changes are going to effect. The available ranges are:


Selection



Entire Chart



Current Division



Division and below

2. Conditions - this area is used to choose which component(s) are going to be
effected based on certain parameters. In essence, from here you choose the
component(s) that you want to change based on something in their data - such
as a name or title.
This is a powerful tool because it allows you to group components based on a
relationship between their data. This means that you can either locate, or assign
factors for certain components and then control how every one of them appears
- no matter where they are located in the hierarchy.
This makes Paint Format amazingly efficient at applying sweeping changes that
make entire groups, positions and professions immediately recognizable based on
their format (such as having all managers appear as blue ovals).
The Conditions area contains the following sections:


Apply if meets condition - this box must be checked to activate the rest of
the Conditions area.



Find what - tells Paint Format what to look for. Any data or text may be
entered into this area. Click the arrow on the right to activate a drop down
menu which holds a record of the criteria previously entered into this field.



Find where - determines which data fields Paint Format is to search when
matching the text or data entered into the Find what field. The default is Any
Field. If you need to specify one data field in particular, click the drop down
menu and a list of all the available data fields will appear.



Comparison - click the arrow to open up a menu of additional search
parameters (such as Contains (default), Equal to, etc.).
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Match case - checking this box sets Paint Format to recognize capital letters,
upper and lower case, etc. (Tip: leave this box unchecked most of the time.
When it is active, components may not be found or effected because of
simple errors, such as someone forgetting to capitalize a name or title, etc.).



Options - click this button to open up a menu of additional options.

Using Special mode

To use Special mode, do the following:
1. Select the source component which contains the format you wish to copy.
2. Click the Paint Format button - if necessary, click the arrow next to the
button and select Special from the drop down menu.
3. The Paint Format interface will appear.
4. To activate the Conditions area, check the Apply if meet conditions box. The
Conditions section will now become active.
5. Type your criteria (position, title, etc.) into the Find what field.
6. Go to the Find where area and choose from the list of available data fields.
7. If necessary, go to the Comparison section, click the arrow to open the drop
down menu and choose from the available additional search parameters (the
default is Contains).
8. Check the Match case box if you want Paint Format to recognize capital letters, upper and lower case, etc.
9. If necessary, specify any additional options with the Options button.
10. Go to the Scope section and click the appropriate radio button to choose the
range and locations in the chart that your changes are going to effect.
11. Click OK.
12. When the interface closes, notice that your changes have been applied.

Page 150 of 318

OrgChart Professional

Chapter 2: Chart Creation

Box Properties interface
On-screen graphics are just a small part of what components can do. Components can
also contain vast amounts of information which can be entered, edited, exported and
even printed out. An important area for the manipulation of this information is the
Box Properties interface. (This area has two tabs. The image below shows the Box
Properties menu with the Edit Data tab selected).

Displaying the Box Properties interface
Once a component is selected, the Box Properties interface can be accessed in the
following ways:


Go to Shape > Properties.



Double click an empty area inside a component (an area with no text or
graphics, etc.).
Right click a component to launch a pop-up menu. In the pop-up menu
choose Properties.
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Use the hotkey combination of Alt + Enter.

Box Properties: Scope
Scope is a powerful and intuitive interface which allows you to quickly set the range
and locations of the data changes in your chart. It is found in the Apply To section at
the bottom of both Box Properties tabs. It has the following options:



Selection - only applies changes to the currently selected component(s).



Entire Chart - applies changes to every component in the chart.



Active Division - only applies the changes to the division of the currently
selected component.

Special Tip: Scope is one of OrgChart’s most useful features because it can be
applied to any data field in any combination anywhere on the chart. This means that
you can set certain fields, like the company’s name or telephone number, to appear in
every component in the division or chart, but leave all the other data fields
unaffected. Since you can have any data (or field) appear anywhere, the possibilities
and time saving features of scope are almost limitless.

Box Properties: Edit Data
This area is used to define what data will be associated with certain component(s). To
use this section:
1. Click in the right hand column of the data field you want to edit. The area
will turn blue in color.
2. Enter the data.
3. Press ENTER or click in another field to apply the data.
4. Set the scope of the changes by going to the Apply To area and clicking one
of the available choices.
5. Click the OK button to apply the changes and close the menu.
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Box Properties: Define Layout
This area determines the visual appearance the data in the component. It determines
what is visible and where (see below):

This tab consists of the following areas:


The Data Field area - displays what data fields are available (this changes
depending on what field data view you have chosen). It contains the
following:



Data field names in the left column.



Visibility box in the right column. Check this box to toggle the
selected field between being visible and hidden.
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The Preview Pane - displays a simple diagram of the component. It shows:







The data fields that will be visible - to change this, check or uncheck
the visibility box in the Data Fields area.



The order of the data fields - to change the order, highlight the desired
field in the Data Fields area, then click the Move Up or Move Down
buttons. (Note: The Move Up and Move Down buttons will only
become active if a data field with a check in the visibility box is
selected. These buttons will also either activate or deactivate
depending which data field is selected.)



The component’s text font - this is selected in the Display Properties
area (see below).



The component’s text alignment - this is selected in the Display
Properties area (see below).

The Display Properties area - determines certain visual properties of the
component. It contains the following:



Display Column Name - check this box to make the title of the data
field appear in the component (for example, with the box checked a
person named ‘Mr. Sample’ would appear in the component as ‘Title:
Mr. Sample’.)



Text alignment buttons - click any of the three buttons to determine if
the text will be aligned on the left, center or right of the component.



Font Style - click this button to open the font menu (for more details,
please see the Font Style section of this manual).

The Apply To area - determines the scope of the changes which have been
determined in the other areas (for more details, please see the Box Properties:
Scope and Apply Scope sections of this manual).

Once you have made your selections from the above sections, click the OK button to
apply the changes and close the menu.
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Displaying and hiding a component’s data on the chart
A component can have dozens of Data Fields - far too many to be displayed on the
chart. To solve this, the user can control which fields are visible through the Layout
tab in the Box Item menu.
By default, the Name and Title fields are active. To select which fields will be displayed click in the box on the far right of each line in the Visible checkbox:

A check mark in the box signifies that the field is visible; an empty box indicates it is
hidden. (In the above illustration, Name, Title and Photo will be displayed in the
component, but Supervisor will not.)

Arranging Data Fields by using the Move Up and Move Down
buttons
To change the order of Data Fields (by moving them higher or lower on the list),
choose the desired field in the Layout tab of the Box Item menu, then click the Move
Up or Move Down button.
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Data Fields information types
Information fields may of the following types:


Text -text information can be typed directly (or cut and pasted) into these
fields. Single click to open.



Salary - is a powerful field used for dynamic, on-the-fly calculations of budgets and expenditures. It is used in conjunction with the Headcount and Team
Budget fields.

To use this function, single click the Salary data field and type in numbers
(note: this field accepts numbers only). When finished, hit the ENTER key.
The input will be applied and a dollar sign ($) will automatically be placed in
the field.


Link - this is where links are created (see Appendix B). Double click in the
field to open the Link Data menu (see below):



Image - stored images are linked to a component through this field (see
Appendix B). Double click the field to open the Image Data menu (see
below):
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Attachment -stored information files are linked to a component through this
field (see Appendix B). Double click the field to open the Attachment menu
(see below):



Calculated field -is an incredibly useful menu that allows the automatic
tallying of personnel, salaries and team budgets. The scope can be set to
branches, managers and subordinates (see below):
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This menu is accessed by double clicking in the following two data fields.


Headcount - default configuration for calculating number of personnel.



Team Budget - default configuration for calculating budget.

To view totals for a group of components -click on the parent component to
display the tallies for the parent and all its subordinates.

For more information and step-by step details on other options available in the
Calculated Field menu, please see Appendix B: Calculated Field - Headcount and
Team Budget.

Dynamic calculations with Headcount, Salary and Team Budget
Headcount, Salary and Team Budget all work together to make certain calculations
possible. This occurs because the Team Budget is determined from information
gathered from both the Headcount and Salary fields.
For step-by-step instructions on performing Headcounts and Team Budgets, please
see Appendix B: Calculated Fields - Headcount and Team Budget.
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Chart Data Set: mastering global data fields
In addition to the default Data Fields present in the Box Properties menu, new fields
can be created, modified or deleted globally through the Chart Data Set interface (see
below):

IMPORTANT: The Chart Data Set stores and creates data fields that can become
available to every component (globally). However, although these fields are available, they are not automatically included or visible in the final component. Only after
you set the data field to be accessible and visible will it then be available for the chart
building process.
Accessing the Chart Data Set interface:
There are several ways to access this area:



Main menu - go to Chart > Chart Data Set.



Box Item menu:

1. Open the Data View tab.
2. Click the Options button.
3. Choose Edit Chart Data Set from the drop down menu.
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Editing an existing data field:

There are five fields which can be edited in the Chart Data Set:


Name - to edit this field, do the following:

1. Click on the Name column of the chosen data field. The area will turn
blue, signifying that it is now editable.
2. Enter the new information.
3. Press ENTER, or click in another data field and the information will be
applied.


Type - there are nine different types of data fields: 1) text, 2) numerical, 3)
currency, 4) calculated, 5) link, 6) image, 7) attachment, 8) FormTool
document and 9) supervisor. To edit this field, do the following:

1. Click on the Type column of the chosen data field. The field will turn
blue and a small button will appear on the right side.
2. Click the button to open a drop down menu displaying the nine types of
fields listed above.
3. Click on your choice in the drop down menu.
4. The selection will now appear in the Type field.


Visible - determines whether the data field will be visible. Check this box to
toggle between visible and hidden.



Display Name - determines whether the title of the data field (such as Name,
Title, Photo, etc.) will appear in the component. (For example, in a
component with a person named ‘Mr. Sample’, the name would appear as
‘Title: Mr. Sample’ if Display Name was checked.) Check this box to toggle
the data field title between visible and hidden.



Formula - formulas are only available if certain types of data field were
selected in the Type column (i.e. numeric, currency, calculated, etc.). To edit
this field:

1. Click on the Formula column of the chosen data field. The field will turn
blue and a small button will appear on the right side.
2. Click the button to open a drop down menu displaying the Calculated
Field menu (see below):

Page 161 of 318

OrgChart Professional

Chapter 2: Chart Creation

3. Choose options from the drop down menus in the Operation, Affected
Column and Affected Scope areas and click OK.
4. The Calculated Field menu will close and your selection will now appear
in the Formula area of the Chart Data Set.
To create a new data field:

1. Click the New button. The Name column will turn blue and a new entry entitled ‘Unnamed’ will appear.
2. Type in a name for your new data field, then either hit ENTER or click in
another field to apply the change.
3. Choose your options, from the Type, Visible, Display Name and Formula
areas.
4. When you are done editing the data sets, click OK to close the interface.
5. The Add Columns in Data Views menu will open. This interface provides the
option to add your newly created data field to already existing Defined Data
Views (see below):
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To add your new field to an existing Defined Data View:
1. Check the box next to the views you want your new field to appear in.
2. Click OK.
3. The interface will close and you will be returned to the main work area.
4. (From this point on, whenever any of the views you checked is chosen in
the Box Item: Current Box Layout or Outline View: Data View Quick
Selector menus, your new data field will appear along with the other data
fields.)

To load a predefined data field:

OrgChart Professional comes with a library of predefined (previously designed) data
fields. To load from this library:
1. Click the Add Predefined button.
2. The Add Data Fields menu will appear (see below):
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3. Highlight the data field you wish to add and click the Add button.
4. The Add Data Fields interface will disappear and your selected, predefined
data field will appear in the Chart Data Set area.
Additional Chart Data Set buttons:



Delete - removes a data field from the Chart Data Set area. To use, simply
highlight the field you wish to remove and press Delete.



Set Title - sets the currently chosen data field as a title. If the currently highlighted field has already been set through this option, the button will
automatically switch to Remove Title.



Move Up - moves an item higher on the list. This option is inactive if the
selection is already at the top.



Move Down - moves an item lower on the list. This option is inactive if the
selection is already at the bottom.
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To complete the Chart Data Set process, choose from the following:


OK - accepts your choices and applies them universally to the data fields of
every component.



Cancel - closes the panel without making any changes.



Help - launches the Help menu.

Viewing & Controlling Data Views in Outline View
The Outline View Control Bar is one of the main interfaces used to work with data
views. Sitting atop the Outline View, it provides a convenient, central location to
access all the tools necessary to view, create and manipulate these powerful
resources.
Although this control bar has many options, this section will only focus on those
directly related to data views. These are:


Edit Chart Data Set.



Edit Current Data View.



Define Data Views.



Data View Quick Selector



View Options.

1. Edit Chart Data Set - launches the Chart Data Set menu. The Chart Data Set
interface sets global changes which can affect every component if you so choose.
From this menu you can: a) create new data fields, b) load predefined fields, 3)
edit fields, 4) rearrange the order in which fields appear and 5) delete existing
fields. (For more information on mastering data fields, please see the Chart Data
Set section.)
2. Edit Current Data View - launches the Edit Data View menu. By modifying the
currently selected data view, this interface determines what data fields and data
views will be available in the Box Item: Current Box Layout and Outline View:
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Data View Quick Selector drop down menus. It also determines the order in
which these fields are displayed (see below):



Creating a new data view in Edit Data View:

1. Type a new name in the Data View Name field.
2. Use the Add and Remove buttons to shift data fields between the Available
Data Columns and Selected Data Columns areas. Items may also be dragged
and dropped across panes.
3. Once all the desired data fields are present in the Selected Data Columns
pane, use the Move Up and Move Down buttons to determine how those
4. fields will appear in your final data view. Items may also be dragged and
dropped into the desired order.
5. Click OK to close the interface and apply the results.
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6. Back in the main work area, notice that the name of your new data view
appears in the Outline View: Data View Quick Selector.


Editing an existing data view in Edit Data View - follow the above
instructions but do not type a new name in the Data View Name field.

3. Define Data Views - launches the Define Data View menu. This interface is
used to add new data views which will then become available in the Box Item:
Current Box Layout and Outline View: Data View Quick Selector drop down
menus. It can also be used to edit currently existing data views.



Adding a data view using the Define Data View menu:

1. Click the Add button.
2. The Edit Data View menu will appear.
3. In the Edit Data View menu, type a new name into the Data View Name field
and choose which items you wish to populate your view (for more
information on using the Edit Data View menu please see the Edit Current
Data View section).
4. Click OK to close the menu and return to the Define Data Views menu.
5. Arrange your data views by using the Move Up and Move Down buttons.
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6. When you are satisfied with the entries and their arrangement, click OK to
close the interface.
7. To see the results of your change, open the Outline View: Data Quick View
Selector. Notice that your changes have been applied and are available for
immediate use.


Editing a data view using the Define Data View menu:

1. Click the Edit button.
2. The Edit Data View menu will appear.
3. In the Edit Data View menu, choose which items you wish to populate your
view (for more information on using the Edit Data View menu please see the
Edit Current Data View section).
4. Click OK to close the menu and return to the Define Data Views menu.
5. Arrange your data views by using the Move Up and Move Down buttons.
6. When you are satisfied with the entries and their arrangement, click OK to
close the interface and return to the main work area.
4. Data View Quick Selector - this drop down menu allows for the rapid selection
of available data views. This menu performs the same function as the Current
Box Layout drop down menu available in the Box Item area. To use, simply open
the menu and select the data view. It will be immediately applied.

5. View Options - provides a selection of display choices available in Outline
View. By using sophisticated identification, ordering and tagging techniques these
options utilize intelligent filtering - thereby allowing you see exactly the
information you need to see, when you need to see it.
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View Options can be accessed in the following ways:



Main menu - go to View > Data Outline Pane and choose the desired
option.



Outline View Control Bar - click the View Options button.

The following choices are available:


All records - displays all the components on the entire chart, including all
divisions and subdivisions.



Smart - displays only the selected components and their subordinates.



Division - displays only the components in the currently selected division



Division with Subdivisions - displays the current division and the subdivisions below it.



Found Results - this option works in conjunction with OrgChart’s Find
feature. Note: This option only becomes active after a successful search has
been initiated. Found Results then displays the latest results of the search. To
test this option, go to Edit > Find and run a search for an item you are certain
is in the chart. After Find returns a positive result, go to View Options and
select Found Results. The found component will appear in the Outline View
area.



Show Hierarchy - toggles the Outline View between hierarchy and list
formats (for visual examples of these styles, please see the Outline View
section).

Page 169 of 318

OrgChart Professional

Chapter 2: Chart Creation

Chart Wizard
The Chart Wizard is a streamlined series of five consecutive screens which guide the
user step-by-step through the process of making customized charts and templates.

Launching the Chart Wizard
There are three ways to launch the Chart Wizard:


Clicking the Chart Wizard button on the Main Menu.



Clicking on File > Chart Wizard.



Choosing the Chart Wizard icon on the Welcome Screen (please refer to the
Welcome Screen section for more details).

Chart Wizard - Start and Load Settings screen
The wizard opens with the Start and Load Settings screen (see below):

This screen contains the following options:
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Load Settings from previously designed charts. (Note: you must have a previously saved *.tcw file to load.) To Load Settings, do the following:

1. Click the Load Settings button.
2. Browse to the location of your *.tcw file in the Select Chart Wizard Settings File box.
3. Choose the file by either double clicking the file name or highlighting
the file and clicking Open.
4. A “Settings loaded successfully” message will appear. From here you can
either:


Click Finish. This will load the chart/template directly into the Main
Work Area without modification. (Note: the ‘Finish’ button will only
become active once a file is loaded. Until then, it will remain ‘grayed
out’.)



Click Next. This will load the chart/template into the wizard for
additional modification. The wizard’s next screen will then appear.

To complete this screen, you must select one of the following options:


Next > - start a new chart or modify a loaded template.



Cancel -close the wizard without saving and return to the Main Work area.



Help - launches the OrgChart Professional Help system.



Finish -this option is only available when a previously designed chart or template has been loaded through the Load Settings command (see Load Settings,
above). Until a chart is loaded, this button remains inactive and ‘grayed out’.
Once a chart is loaded, click this button to load the template into the work
area and close the wizard.
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Chart Wizard - Chart Design screen
The second area of the Chart Wizard is the Chart Design screen (see below). Here
you can specify the number of levels in a chart’s hierarchy, how many subordinates
are on each level and the appearance of each level’s components.

This screen contains the following:


Preview Window - the large area in the center of the screen which displays
the component design for the currently selected level (see Select Level,
below).

IMPORTANT: The diagram in the Preview Window does not show the entire
chart. Instead, it shows only a single (representational) component of the
selected level and its immediate subordinates. A more accurate diagram of
the entire chart appears later in the wizard.


Levels - this field determines the number of levels present in a chart’s hierarchy. This value will create a corresponding number of levels in the Select
Level area. There are two ways to set the number of levels:

1. Click the small up and down arrows to increase or decrease the number.
2. Place your mouse in the Levels area, highlight the number and type in a
new numeric value. Select Level - displays a list of levels currently
present in the chart. Highlight a level to display a single (representational)
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component of the level and its immediate subordinates in the Preview
Window.


Select Level -displays a list of levels currently present in the chart. Highlight
a level to display a single (representational) component and its immediate
subordinates in the Preview Window.
Parent Component
(component effected by modifiers)

Subordinate (child) Components
(NOT effected by modifiers except SET)
In this example, the Parent Component would be from Level 1
because Level 1 is the actively selected layer



Subordinates – this field determines the number of subordinate components
present in a level’s hierarchy. There are two ways to set the number of
subordinates:

1. Click the small up and down arrows to increase or decrease the
number.
2. Place your mouse in the Subordinates area, highlight the number and
type in a new numeric value.


Total boxes - the total number of components (boxes) that will be present in
the final chart. This counter is dynamic and instantly re-calculates every time
a change is made to the chart hierarchy
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Shape - this field contains a scrollable display of styles that can be applied to
modify a component’s outline. (For more details, please see the Shapes section.) To apply a shape in the wizard:

1. Highlight the desired level in the Select Levels area. A
representational diagram of a single component from the level and its
immediate subordinates will appear.
2. Choose an aesthetically pleasing design from the scrollable Shapes
area.
3. Double click the chosen shape.
4. The shape will be automatically applied to the component in the
Preview Window.


Fill - this button launches a multi-function, tabbed menu used to customize a
component’s color, gradient, pattern and can even apply pictures. (For more
details on controlling this powerful menu, please see the Fill Styles section.)



Border - this button initiates the Border Style menu. This controls the
appearance of the line which defines a component’s shape. From here you can
control the style, width, transparency and many other attributes of a
component’s border. (For more details, please see the Border Style section.)



Connector - this button launches the Connector Style menu. This interface
controls the appearance of the line(s) which connect one component to
another. (For more details, please see the Connector Style section.)



Set - this command automatically applies the changes made to the parent
component to all its subordinates.

Important: In the Chart Wizard, changes made through the Shapes, Fill,
Border and Connector commands can only be applied directly to the
components of the chosen level. To apply those changes to the subordinates,
use the Set button.
To complete this screen, choose one of the following options:


< Back - return to the previous Chart Wizard screen.



Next > - proceed to the next Chart Wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Chart Wizard - Data Fields Design screen
The third area of the Chart Wizard is the Data Fields Design screen (see below).
Here, you can add, remove and customize the Data Fields associated with the
components on any level.

Note: Some buttons will be inactive (‘grayed out’) under certain circumstances.
This screen contains the following:


Select Level -displays a list of levels currently present in the chart. Highlight
a level to display a single (representational) component of the level in the
Preview Window.



Diagram Fields - a list of currently available Data Fields. To choose which
field(s) will appear in your components, click in the box next to a field. A
check mark will appear in the box and the field will appear in the
component.



Preview Window -the large area on the right side of the screen which
displays the component and data field design for the currently selected level.



Modify Diagram Fields - this area contains six commands. To use these
functions, do the following:
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1. Choose a level in the Select level window:
2. Highlight a field in the Diagram fields area:
3. Choose from the following commands:


Add - launches the New Data Field box (see below):

From this interface, you can create new data fields which will be
added to the Diagram Fields area of the Chart Wizard and all the
Data Fields areas of your project. (For more details, please see the
New Data Field section.)


Remove - deletes a data field from the Diagram Fields area.



Move Up - moves a data field entry up the Diagram Fields list. Note:
the Move Up button will be inactive (‘grayed out’) if the data field is
already at the top of the list.



Move Down - moves a data field entry down the Diagram Fields list.
Note: the Move Down button will be inactive (‘grayed out’) if the
data field is already at the bottom of the list.



Field Font - launches the Font menu for setting the preferred type
style. Each different field can have its own unique font settings and
look (please see the Font Style section for more details).



Set Value - automatically inserts a User defined value (text or
numeric) into a chosen data field for every component of a given
level. (For example, you could place the word Manager automatically
in the Title data field for every component of Level 1, or the name of
your organization to appear in the Company data field for every
component of Level 2, etc.).
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Clicking the Set Value button launches the Default field value
interface (see below):

To use the Default field value interface:
1. Enter a value in the “Input default value for the field” area.
2. Choose one of the following options:


OK - accepts your choice and applies it to the data field.



Cancel - closes the panel without saving any data.



Help - launches the Help menu.

Note: In the Chart Wizard, changes made through the above data field commands are
only to be applied directly to the components of the chosen level. To apply those
changes to the subordinates, use the Set button (see below).


Set: this command automatically applies the changes made to the parent level
to all its subordinates.

To complete the Data Fields Design screen, choose one of the following options:


< Back - return to the previous Chart Wizard screen.



Next > - proceed to the next Chart Wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Chart Wizard - Customizing components for each level
The fourth area of the Chart Wizard is the Chart Wizard screen (see below). From
here, you can add, remove and modify components for any level, use the Arrange
features to create the overall look and structure of your chart and even save your
design for future use with the Save Settings As command.

Note: Some buttons will be inactive (‘grayed out’) under certain circumstances.
This screen contains the following:


Outline Structure area - displays an expandable list (tree) of components
currently present in the chart. Click on a selection in this view to highlight its
corresponding component in the Preview Window.

IMPORTANT: components can only be selected in the Outline Structure area.
They cannot be chosen in the Preview Window.


Preview Window -the large area on the right side of the screen which
displays the overall appearance of the chart.



Modification buttons - to use these functions, first highlight a selection in
the Outline Structure area, then choose from the following commands:



Add - adds a new subordinate component to the currently highlighted
selection.



Remove - deletes the currently selected component from the chart.
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Modify - opens the Data Properties menu for the selected item.



Create Division - creates a new Division (for more information, see
the Divisions section).



Arrange - opens up a menu of twelve automated arrangement
options. (For more information on auto-arranging components, see the
Arranging subordinate components section).



Save Settings As - this command allows you to save your chart as a
template for future use. When the Save As interface opens, choose the
location and name of your chart, then choose Save to save the chart as a *.tcw
file or Cancel to quit the menu without saving.



To retrieve and load your template, open the Chart Wizard and choose
Load Settings on the Start and Load Settings screen (please see the Chart
Wizard - Start and Load Settings section for details).

To complete this screen, choose one of the following options:


< Back - return to the previous Chart Wizard screen.



Next > - proceed to the next Chart Wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Chart Wizard - Finish screen
The fifth and final section of the wizard is used to save your chart as a new document,
a new chart or part of an already active chart (see below).

Click in the radio button to choose from the following:


New document - will save the chart as a new document.



New chart - creates a new, separate chart within the current document or
active chart.



Active chart - places the data into the currently active chart (regardless if the
current chart has components already present or not).

To complete this screen, choose one of the following options:


< Back - return to the Chart Wizard - Chart Wizard screen.



Next > - complete the wizard and enter the Main Work area.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Multiple charts and tabbed browsing
OrgChart Professional allows you to have several charts up and running at the same
time. This can be useful when scenario planning and for copying and pasting from
one chart to another. A tabbed browsing interface is used to switch between the
charts (see below).

Important: Tabbed browsing is only available when more than one chart is open.


To add or open multiple charts - go to Chart > Add. A new chart will
appear in the Main Work Area and a new tab will be placed on the chart
browser. A new tab will appear for each new chart that is added.



To browse between charts -click the chart’s corresponding tab.

 To remove a chart tab from the browser -close the chart.
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Chapter 3: Working with other formats
Now that you have mastered chart creation, it is time to share your vision. To do that,
this chapter will teach you how to print, import, export and publish - and in no time at
all, you will be sharing your masterpieces with the world.

Printing
There are many considerations when preparing a chart for printing. These include:


Number of pages.



Position of the components.



Page orientation.



Additional considerations (depending on each individual project).

Print Layout View
This mode is optimized for chart printing. When in this view: 1) dotted ‘printer safe’
lines will appear in the work area and 2) several ‘grayed out’ areas of the Print
Toolbar will become active.
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From this mode, you can:


Add and delete print pages.



Change page orientation between Portrait and Landscape modes.



Arrange multiple pages to optimize the printing of oversized charts (charts
larger than a single page).

Note: the user must be in Print Layout view for certain print functions to become
active.

Activating Print Layout view
There are two ways to activate Print Layout view:


Go to View > Print Layout View.



Press the Print Layout View button on the Select View Toolbar.
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Print Preview
The Print Preview screen allows you to see what a chart will look like before
committing to printing:

The Print Preview screen can be accessed in two ways:


Click the Print Preview button in the Main Toolbar.



Go to File > Print Preview. To exit Print Preview click the Close button.

Printing single page charts
There are three ways to print out a chart:


Press the Print button on the Main Toolbar (see above).



Go to File > Print.



Go to File > Print Preview and press the Print button on the preview page.

Note: All print options launch the standard Microsoft Windows print dialogue.
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Printing multiple page charts
OrgChart Professional can print charts which range from a single page to mega-sized
charts which fill an entire wall. To print these charts:
1. Open the Page Setup menu by choosing File > Page Setup (see below).

2. Choose the Layout Pages button to launch the Layout Print Pages interface.



For oversized charts (charts more than one page) - set the number of
pages to more than one in the Pages in Width and/or the Pages in Height
field.
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For single page charts - leave the Pages in Width and Pages in Height
fields set at 1.

3. To complete the process choose the following:


Orientation -click a radio button to set the page orientation to either Portrait or
Landscape.



Enlarge chart to fit all available area -check this box to re-size the chart to
spread correctly across all the pages.

4. Choose OK to accept the settings and close the Layout Print Pages screen.
5. On the Print Setup Page choose either Print to go directly to the print
interface or OK to return to the Main Work area.
Note: The Preview window on the Page Setup screen will only show the chart in
relative size to the entire work area. To see how the chart actually flows across the
different pages, close the Page Setup menu, return to the Main Work area and choose
Print Layout View (see below).
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Importing files
Importing files is a powerful way to take complex data created in other programs
(such as Excel) and convert them into captivating, easy to understand charts.

Supported formats
OrgChart can import the following formats:
1. Microsoft Excel files.
2. Microsoft Outlook contacts.
3. CSV (Comma Separated Values) files.
4. LDAP (Lightweight Directory Access Protocol) DataSource.
5. XML Document (OrgChart Schema)
6. OLE DB DataSource. OrgChart supports the following OLE DB Data
sources:


Microsoft ISAM 1.1 OLE DB Provider.



Jet 4.0 OLE DB Provider.



Microsoft OLE DB Provider for Indexing Service.



Microsoft OLE DB Provider for Internet Publishing



Microsoft OLE DB Provider for ODBC Drivers.



Microsoft OLE DB Provider for OLAP Services.



Microsoft OLE DB Provider for Oracle.



Microsoft OLE DB Provider for SQL Server.



MS Data Shape.



OLE DB Provider for Microsoft Directory Services.
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Import Wizard
The Import Wizard is designed to take the user step-by-step through the import
process. At each stage, the wizard will request information to be entered onto a page,
then proceed to the next screen through the use of Next buttons.


To open the Import Wizard - go to File > Import.

Import Wizard overview
The wizard uses the same basic system to import all six formats. Although certain
formats have unique screens for entering more technical settings, they all have the
following in common:


All formats begin the wizard the same. They all start with: 1) the
introduction screen and 2) a page to select the import format.



All formats finish the wizard the same. They all end with a Finish screen.



All formats use the same basic navigation buttons. Most pages have
Back, Next, Cancel and Help buttons at the bottom of the screen to move
back and forth through the wizard.

TIPS:



The data you intend to import must have a hierarchical structure for the
import to succeed.



Until the final (Finish) screen, you can move back and forth through the
wizard to change your choices before you commit to the final import.

This manual will take you step-by-step through the import process by importing an
Excel document.
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Import Wizard - Importing Excel
To import Microsoft Excel launch the wizard and proceed through the following
screens:

Import Wizard - Importing Excel - Introduction screen
This screen welcomes you to the Import Wizard (see below).

This screen is the first step for all publishing formats. To complete this page, choose
one of the following options:


Check the Do not show this page again box if you do not wish the
introduction screen to appear the next time the wizard is launched.



Next > - proceed to the next Import Wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Import Wizard - Importing Excel - Selecting import format
This screen offers five import choices (see below).

Click in a radio button to select which format to import. Choose from the following:











Microsoft Excel files.
Comma Separated Values (CSV) files.
Microsoft Outlook contacts.
OLE DB DataSource.
Lightweight Directory Access Protocol (LDAP) DataSource.
XML Document (OrgChart Schema).
Microsoft SQL Server
Oracle
Microsoft Access

To complete this screen, choose one of the following options:





< Back - return to the previous Import Wizard screen.
Next > - proceed to the next Import Wizard screen.
Cancel - close the wizard without saving and return to the Main Work area.
Help - launch the OrgChart Professional Help system.
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Import Wizard - Importing Excel - Selecting source file
This screen is used to choose which file to import (see below).

To select the file to import:
1. Left mouse click the Browse button. The Open menu will appear.
2. Browse to a location and select a file to import.
3. Click Open.
4. The destination path will be displayed in the Publishing Wizard.
To complete this screen, choose one of the following options:


< Back - return to the previous Import Wizard screen.



Next > - proceed to the next Import Wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Import Wizard - Importing Excel - Selecting data tables
This screen allows you to choose from available Excel tables and view their data
fields (see below).

This screen contains the following:


Available tables field - this scrollable pane displays all the available Excel
tables. Highlight a table to display its attributes in the Table Overview and
Data Field display areas.



Table Overview - displays the number of Columns and Records in the
selected table.



Data Field display area - this field is used to preview the data being
imported.



First data row contains column names box:



Checking this box places the names of the data fields at the top of
the table’s columns.



Un-checking this box places generic database headings at the top of
each column (i.e. F1, F2, F3, etc.).
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To complete this screen, choose one of the following options:


< Back - return to the previous Import Wizard screen.



Next > - proceed to the next Import Wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.

Import Wizard - Importing Excel - Setting hierarchy
This screen is used to set a simple hierarchy (see below).

The hierarchy can be set either manually or automatically. The default (and recommended) setting is to leave the Define chart hierarchical structure box checked.
To automatically set the hierarchy do one of the following:



Do nothing -Leave the Define chart hierarchical structure box checked and
simply click the Next button at the bottom of the screen to move to the next
page.



Uncheck the Define chart hierarchical structure box (In this configuration,
the ‘Position’ and ‘Report to’ fields will be inactive and appear ‘grayed out’).
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To manually set the hierarchy:



Make certain there is a check in the Define chart hierarchical structure box.
The ‘Position’ and ‘Report to’ fields will become active.



Choose an available data field from the ‘Position’ drop down menu.



Choose an available data field from the ‘Reports to’ drop down menu.

IMPORTANT: unless the ‘First data row contains column names’ box was checked
on the previous page, only generic database headings will be available
(i.e. F1, F2, F3, etc.).
A diagram of the data fields in a simple hierarchical structure is visible in the
preview area on the right of the screen.
To complete this screen, choose one of the following options:


< Back - return to the previous Import Wizard screen.



Next > - proceed to the next Import Wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Import Wizard - Importing Excel - Organizing data fields
This screen is used to select which data fields will appear in the final OrgChart. It
can also be used to set the data field order (see below).

To modify the list of available data fields -highlight a field and choose from the
following:



Add - adds a data field to the list.



Remove - deletes a data field from the list.



Reset - restores the default data field setup.



Move Up - moves an item higher on the list. This option is inactive if the
selection is already at the top.



Move Down - moves an item lower on the list. This option is inactive if the
selection is already at the bottom.

To complete this screen, choose one of the following options:


< Back - return to the previous Import Wizard screen.



Next > - proceed to the next Import Wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.

Page 195 of 318

OrgChart Professional
formats

Chapter 3: Working with other

Import Wizard - Importing Excel - Selecting import destination
This screen is used to set divisions and save your chart as a new document, a new
chart or part of an already active chart (see below).

Click in the radio button to choose from the following:


Do not create (Division) - no divisions will be created.



At Level (Division) - enter level numbers, separated by semicolons or comas
to specify where the divisions will be created.



Every (Division) - use the drop down menu to reveal the choice of currently
available options.



Using field - specifies which field you wish to use. Expand the drop down
menu to reveal a list of the currently available choices.



New Project - creates a new chart based on the imported information. This
option automatically closes any currently open OrgCharts, so you must save
any open projects or they will be lost.



New Chart - creates a new, separate chart in the current OrgChart session.
This chart can be accessed through the tabbed browsing feature.



Current chart - places the data into the currently active chart.
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To complete this screen, choose one of the following options:


< Back - return to the previous Import Wizard screen.



Next > - proceed to the next Import Wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.

Import Wizard - Importing Excel - Results page
This screen displays your intermediate importing results. This page generates its
report automatically after the previous wizard screen is completed.

All results, messages or errors are displayed in the Results report area. To complete
this screen, choose one of the following options:


< Back - return to the previous Import Wizard screen.



Next > - proceed to the next Import Wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Import Wizard - Importing Excel - Finish screen
This screen displays the final results of your import (see below). This page generates
its report automatically after the previous wizard screen is completed.

All final results, messages or errors are displayed in the Results report area. To
complete this screen, choose one of the following options:


Finish - complete the wizard and return to the Main Work area.



Cancel - close the wizard and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Importing Databases - the Data Link Properties screen
When importing OLE DB DataSource, the Data Link Properties screen is used to
choose the database provider, test the connection, set access permissions and specify
many other important settings (see below).

To access the Data Link Properties page:
1. Go to File > Import to launch the Import Wizard.
2. Click Next on the Introduction screen.
3. Choose OLE DB DataSource as the import format.
4. Click Build on the connection parameters page.
5. The Data Link Properties screen will appear.
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Data Synchronization
OrgChart Professional provides the latest in dynamic project creation through Data
Synchronization - an on-the-fly method of updating a chart’s information in almost
real time. With this amazing tool, you can constantly - and automatically - update
your OrgChart by linking it to a database containing your latest information. Then,
by simply clicking a button, or setting OrgChart to resynchronize when launched,
your chart will instantly reflect any new changes - without any additional effort on
your part.
OrgChart makes this possible because it automatically remembers the location of any
database you import. It can then find that database at a later time and import any
changes that have been made.
OrgChart even has the ability to link into different databases. So if you decide to
store your chart’s information in another file, OrgChart can be instructed where to
look. It can then retrieve the data and update your chart accordingly.
IMPORTANT NOTE: to enable Data Synchronization, the information must first be
imported from an external database file (such as Microsoft Excel).
Special OrgChart Tip: if you wish to first construct a chart, then make Data Synchronization possible, use the Export Wizard and save your project’s information as
an Excel file (or other supported format). Then go to Chart > Resync Properties to
map to the database file you just created. Data Synchronization will now be available
for that chart.
Data Synchronization is perfect for:


Adding and removing personnel.



Changing and assigning supervisors.



Changing the values in any field.



Adding and removing data fields to the chart.
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Setting up a chart to use Data Synchronization:

(Note: OrgChart Professional has the ability to import many different types of
database. For detailed instructions - and illustrations - on importing data please see
the Import Wizard section of this manual.)
1. Go to File > Import to launch the Import Wizard.
2. Follow the wizard’s step-by-step instruction screens to choose the import format, source file, and select the other appropriate options for your chart. Click
Finish on the final screen. The chart will appear in the main work area.
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3. Decorate and customize the chart to reflect the needs of your project.
4. In the future, when you change your data source’s information, you will be
able to use Data Synchronization to update your chart to reflect those
changes.
Using Data Synchronization:

Now that you have an appropriately constructed chart, do the following to enable
Data Synchronization.
1. Open the chart you want to synchronize.
2. Open the Chart menu on the main toolbar.
3. Click on Resync Data.

4. The data in your chart will update to reflect any changes that were applied in
the source database.
Automatic Data Synchronization (only available in certain versions):

A chart can be set to synchronize its data on load up. To do this:
1. Open the Chart menu on the main toolbar.
2. Click on Resync At Load. (Click this option again to toggle on & off.)
3. The chart will automatically synchronize its data the next time it loads.
Data Synchronizing from a different database or data location:

OrgChart can be set to synchronize data from different data sources or the same file
in different locations. To change the Data Synchronization path:
1. Open the Chart menu on the main toolbar.
2. Click on Resync Properties.
3. The Import Wizard will launch. Work through the screens.
4. On the Selecting source file screen, select the new file or location.
5. Finish the Wizard as normal. Your new source path will be set.
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Importing LDAP - special considerations
Many of the unique settings necessary for a successful LDAP import are entered on
this connection parameters screen (see below).

When importing LDAP, take the following into consideration:
1. Make certain the server you are importing from is up and running.
2. Obtain the Root DN and Root Password information. This information is
usually found on the server’s slapd.conf configuration file. (In the file, look
for the name of the root object (rootdn) and the password (rootpw).
3. Use the information gathered in Step #2 to fill in the Username and
Password fields of the LDAP connection parameters box (pictured above).
4. Make certain you correctly enter the LDAP connection string before proceeding to the next page.
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Publishing charts
Publishing is a powerful process which exports certain file formats, then can
immediately open up the associated program and display the results. (For example, if
you publish an OrgChart to MS Word, the chart would be saved in MS Word format
and then Microsoft Word would automatically load and display your chart.)
In addition, OrgChart Professional now offers Flash Publishing, which harnesses the
power of Macromedia Flash - one of the worldwide standards for internet graphics.
So now your charts can be posted on the internet and are viewable in any browser
installed with Macromedia Flash Player 8 or later (available for free download at
http://www.adobe.com).
OrgChart Professional publishes the following formats:


Microsoft PowerPoint



Microsoft Word



Microsoft Visio



Web Pages



Crystal Report



Adobe PDF



Image File



Scalable Vector Graphics (SVG)



Macromedia Flash 8

The Publishing Wizard incorporates the same essential workflow for all supported
formats. However not all screens are used for all publishing. The following listing of
wizard screens is in approximate order from start to finish, but will vary with each
individual format (see below).
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Publishing Wizard Workflow For Each Format

Note: all formats begin with the same three screens. All formats also end with the
same two final screens, except for Crystal Reports which launches an additional
Report Viewer.
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Publishing Wizard - Introduction screen
This screen welcomes you to the Publishing Wizard (see below).

This screen is the first step for all publishing formats. To complete this page, choose
one of the following options:


Check the Do not show this page again box if you do not wish the
introduction screen to appear next time the wizard is launched.



< Back - return to the previous Import Wizard screen.



Next > - proceed to the next Import Wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Publishing Wizard - Select publishing format
This screen offers eight publishing options (see below)

Click in a radio button to select which format you want your chart to be published in.
Choose from the following:











Microsoft PowerPoint
Microsoft Word
Microsoft Visio
Web Pages
Crystal Report
Adobe PDF
Image File
Scalable Vector Graphics (SVG)
Macromedia Flash 8

To complete this screen, choose one of the following options:





< Back - return to the Publishing Wizard Introduction screen.
Next > - proceed to the Select data source screen.
Cancel - close the wizard without saving and return to the Main Work area.
Help - launch the OrgChart Professional Help system.

Page 207 of 318

OrgChart Professional
formats

Chapter 3: Working with other

Publishing Wizard - Select data source
This page sets exactly what part of your chart is going to be published (see below).

Choose from one of the following options:
 Active chart - exports the entire chart and all additional (hidden) division
sub-charts.
 Active sheet - exports only the currently displayed sheet.
 Selection only - exports only the components which are currently selected.
Note: not all options will be available for all publishing formats. Unavailable
selections will be inactive (‘grayed out’).
Choosing Next will send each format to the following Publishing Wizard screens.
For each selection, please go to the corresponding area to complete the next stage of
the publishing process:
 Word, Visio, Web Pages, Adobe PDF and SVG -Select data fields.
 PowerPoint -Configuring PowerPoint titles, contents and index pages.
 Crystal Report -Choosing a Crystal Report template.
 Macromedia Flash 8 -Choose destination file path.
The following navigation options are also available at the bottom of the page:
 < Back - return to the previous wizard screen.
 Cancel - close the wizard without saving and return to the Main Work area.
 Help - launch the OrgChart Professional Help system.
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Publishing Wizard - Set data fields
This screen determines which data fields will appear in your published chart

Note: 1) This menu applies to all formats except PowerPoint and Image File. 2) For
Crystal Reports, one additional screen (for choosing report templates) will appear
prior to this menu (for more details, see Publishing Wizard - choosing report
templates).
Macromedia Flash Publishing Tip: For privacy purposes, choose only the fields you
want to appear in the final, published version.
Data fields are chosen by making selections from the Available columns area and
transferring them to the Output columns pane.
To move items between panes simply highlight a selection and use the appropriate button. The following options are available:



Add > - moves a selection from the Current datafields area to the Output
datafields pane.



Add all - moves ALL the selections from the Current datafields area to the
Output datafields pane.
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< Remove - moves a selection from the Output datafields area to the Current
datafields pane.



Remove all - moves ALL the selections from the Output datafields area to
the Current datafields pane.

The following options are available in the Output datafields area only:


Move Up - moves an item higher on the list. This option is inactive if the
selection is already at the top.



Move Down - moves an item lower on the list. This option is inactive if the
selection is already at the bottom.

Choosing Next will send each format to the following Publishing Wizard screens.
For each selection, please go to the corresponding area to complete the next stage of
the publishing process:


Word - the Select image type interface.



Visio - the Progress screen.



Web Pages - the Choosing the destination file path screen.

The following navigation options are also available at the bottom of the page.


< Back - return to the Select data source screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Publishing Wizard - Configuring PowerPoint titles, contents and
index pages
This page is unique to PowerPoint and applies to no other formats. This interface is
used to set the title, contents and index pages (see below).

This screen is divided into four areas:
1. Title page area:


Include Title Page - check this box to add a title page to your PowerPoint presentation.



Title field - type your presentation’s title in this field.

2. Contents Page area:


Include Contents Page - check this box to add a contents page to your
PowerPoint presentation.

3. Sheet Page area:


Show title - check this box to have the title appear on every page.

4. Index Page area:
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Include index page - check this box to add an index to your PowerPoint
presentation.



Select Field for Index - expand the drop down menu and choose a field
to index. This list is composed of the default data fields present when a
component is first placed on a chart.



Sort: Ascending / Descending - click the appropriate radio button to
specify if you wish the index to sort the selected index field in ascending
or descending order.

Choose Next to proceed to the Choosing image properties screen.
The following navigation options are also available at the bottom of the page.


< Back - return to the previous wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Publishing Wizard - Selecting a Crystal Report template (Crystal
Reports only)
Crystal Reports are a series of visually sophisticated templates that present information in the most professional and polished manner possible. To access these
templates, use the following interface (see below).

To choose a template do the following:
1. Highlight a name in the Available templates window. Currently, OrgChart
Professional provides six templates based on the Wave and Block formats
(see the illustrations below. Note: the words “Wave” and “Block” do not
appear on the final reports):
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Details about the highlighted template’s name, available datafields,
available parameter fields and the page’s orientation will be displayed in
the Description of template area.

2. Choose Next to accept your choice and proceed to the Select data fields page.
The following navigation options are also available at the bottom of the screen.


< Back - return to the Select data source screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Publishing Wizard - Selecting destination file path
This screen is used to set the published document’s location, name and file type

This screen applies to publishing Image Files, Scaled Vector Graphics (SVG), Adobe
PDFs and Web Pages. To set the destination file path, name and file type:
1. Left mouse click the “...” button. The Save As menu will open.
2. Browse to a location, enter a file name and choose a file type from the drop
down menu (note: available file formats will vary depending on which type of
document you are publishing).
3. Click Save.
4. The destination path will be displayed in the Publishing Wizard.


Choose Next to proceed to the Progress screen (all formats).

The following navigation options are also available at the bottom of the page.


< Back - return to the previous wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Publishing Wizard - Selecting image properties (PowerPoint
and MS Word only)
This screen is used to set the published data as a bit mapped image or as a metafile. It
is only used for PowerPoint and MS Word.

1. Choose to publish your chart from the following options:


Bitmapped image



Metafile (recommended)

2. Check the “Crop image around chart box” if you wish to apply cropping.
3. Choose Next to proceed to the Progress screen (all formats).
The following navigation options are also available at the bottom of the page.


< Back - return to the previous wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Publishing Wizard - Set template parameters (Crystal Report
only)
This screen is used to place information in a template’s available information areas
(see below). This screen is unique to Crystal Reports.

To use this screen, do the following:
1. Available parameters area - highlight a selection. Note: the choices inside
the Available parameters window will differ depending on which template
was chosen earlier in the wizard (see Publishing Wizard - choosing a Crystal
Report template for details).
2. Parameter value - type a title or other relevant information in this field.
3. Choose Next to proceed to the Progress screen.
The following navigation options are also available at the bottom of the page.


< Back - return to the previous wizard screen.



Next > - proceed to the next relevant wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Publishing Wizard - Progress screen
This screen is used to commit to the choices made in the wizard and initiate the
publishing process (see below).

Choose Start to commit your choices and publish your chart. Once the process starts:


Progress will be displayed in the Overall progress bar.



Any error messages will be displayed in the large center window.

This interface will automatically close and be replaced by the Results screen when the
process is complete.
If you choose not to publish your chart or wish to go back and make other selections,
choose one of the following:


< Back - return to the previous wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Publishing Wizard - Results screen
This screen displays your publishing results (see below). It activates automatically
after the previous wizard screen is completed.

The following areas and options are present on this page:


Results report area - displays the results of your export.



Errors report - displays any errors that may have occurred during the export
process.



Details - click this button for any additional information which may be available regarding the export of your document.

To complete this screen, choose one of the following options:


Finish - complete the wizard and return to the Main Work area (all formats
except Crystal Reports).



Cancel - close the wizard and return to the Main Work area.



Help - launch the OrgChart Professional Help system.

Note: the application you were publishing to may automatically open after the
Publishing Wizard is complete.
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Publishing Wizard - Crystal Report’s Report Viewer
The Crystal Report ‘Report Viewer’ is launched automatically after a Crystal Report
has been generated by the Publishing Wizard (see below).

The top of this screen is dominated by the following toolbar (see below):

1 2
3
4 5
6
These functions can be performed from this interface:

7

8

9

Print Report - launches the print dialogue.
Export Report - opens up the Crystal Report Export box (see below).
Magnification (zoom) - controls and displays the magnification of the page.
Go to first page - displays the first page of the report.
Go to previous page - displays the previous page of the report.
Page number - displays the current page (the number next to it is the total
number of pages in the report).
7. Go to next page - displays the next page.
8. Go to last page - displays the final page of the report.
9. Stop Loading - cancels the loading function.

1.
2.
3.
4.
5.
6.
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Exporting from the Report Viewer window
To export your Crystal Report from the Report Viewer window, click the Export
Report button. This will launch the Crystal Report Export box (see below):

The following formats can be exported from this menu:


Acrobat Format PDF



MS Excel 97-2000



MS Excel 97-2000 (Data only)



MS Word



Rich Text Format



Tab-separated text



Text



XML

To export through this interface:
1. Choose the Format and Destination from the available drop down menus
and click OK.
2. Choose the Page Range (which pages of your report you want exported) on
the Export Options menu and click OK.
3. Choose a location and report name in the Choose export file window and
click Save.
4. The report will be exported and the window will close.
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Emailing a Chart
OrgChart Professional makes it easy to share your creations with friends and
colleagues. Among the many forms of export available, OrgChart provides the option
to email your charts.
Tip: Save your chart with a unique name before emailing it. Otherwise, OrgChart
will assign an automatically generated name (such as OrgChart1.toc, OrgChart2.toc,
etc.) to the file it attaches to the email.
To email your chart:

1. Go to the File menu.
2. Choose Send as Mail.
3. Your default email client will launch in Compose mode with your OrgChart
already attached (the chart will appear as a *.toc file).
4. Address and compose your email message as you normally would.
5. Send your email.
6. Your message will arrive to its addressee with your chart (as a *.toc attachment) ready to download and view.

Exporting charts with the Export Wizard
Exporting is the process of saving OrgCharts in formats that can be opened and
utilized by other programs. In OrgChart Professional, this is done through the
Export Wizard. The wizard can export to the following formats:





Comma Separated Values (CSV) File.
Microsoft Excel File.
XML Document (OrgChart Schema).
OLE DB DataSource.

The export process is almost identical for all these formats. The only exception is
during the path selection phase, which appears on the third screen of the Export
Wizard. At that stage, Excel and OLE DB DataSource have a different selection
process. Once selection is complete, the rest of the wizard process is identical for all
formats.


To launch the Export Wizard go to File > Export.
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Export Wizard - Introduction screen
This screen welcomes you to the Export Wizard (see below).

To complete this screen, choose one of the following options:


Check the Do not show this page again box if you do not wish the
introduction screen to appear next time the wizard is launched.



Next > - proceed to the next screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Export Wizard - Select export format
This screen offers four export options (see below).

Click in a radio button to choose one of the following:



Comma Separated Values (CSV) File.



Microsoft Excel File.



XML Document (OrgChart Schema).



OLE DB DataSource.

To complete this screen, choose one of the following options:


< Back - return to the previous wizard screen.



Next > - proceed to the next screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Export Wizard - Select export path (CSV, Excel and XML only)
This page appears if CSV, Excel or XML is chosen. It sets the location (path) to
where the document will be exported (see below).

The path selection process differs slightly depending on the format type:


Comma Separated Values (CSV) File and XML Document (OrgChart
Schema):

1. Left mouse click the “...” button. The Browse for Folder menu appears:
2. Use the Browse for Folder screen to set a destination folder and click OK.
3. The export path will be displayed in the Export Wizard.
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Microsoft Excel File

1. Left mouse click the “...” button. The Save As menu will appear (see
below):

2. Browse to a location and set a file name. Click Save.
3. The export path will be displayed in the Export Wizard.
To complete this screen, choose one of the following options:


< Back - return to the previous wizard screen.



Next > - proceed to the Select data source screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Export Wizard - Data Source screen (OLE DB DataSource only)
This screen appears when OLE DB DataSource is selected (see below).

Choose one of the two following methods to set the DataSource:


Use connection string

1. Choose this radio button and click the Build button. The Data Link Properties menu will appear (see below).
2. Choose the correct OLE DB Providers. If necessary navigate to each area
by either clicking Next >> or selecting the appropriate tabs. When all the
areas are completed click OK.
3. The provider will appear in the Use connection string field.
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Use Universal Data Link (UDL) File

1. Left mouse click the “...” button. The Open menu will appear.
2. Browse to a location and set a file name. Click Open.
3. The file will appear in the Use Universal Data Link (UDL) File field.
To complete this screen, choose one of the following options:


< Back - return to the previous wizard screen.



Next > - proceed to the Select data source screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Export Wizard - Select data source screen
This page sets exactly what data is going to be exported (see below).

Choose from one of the following options:


Active chart - exports the entire chart and all additional (hidden) division
sub-charts.



Active sheet - exports only the currently displayed sheet.



Selection only - exports only the components which are currently
highlighted.

To complete this screen, choose one of the following options:


< Back - return to the previous wizard screen.



Next > - proceed to the Set data fields screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Export Wizard - Select data fields
This screen sets which data fields will be exported (see below).

Data fields are chosen by making selections from the Available datafields area and
transferring them to the Output datafields pane.
To move items between panes simply highlight a selection and use the appropriate button. The following options are available:



Add > - moves a selection from the Available datafields area to the Output
datafields pane.



Add all - moves ALL the selections from the Available datafields area to the
Output datafields pane.



< Remove - moves a selection from the Output datafields area to the
Available datafields pane.



Remove all - moves ALL the selections from the Output datafields area to
the Available datafields pane.
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The following options are available in the Output datafields area only:


Move Up - moves an item higher on the list. This option is inactive if the
selection is already at the top.



Move Down - moves an item lower on the list. This option is inactive if the
selection is already at the bottom.

To complete this screen, choose one of the following options:


< Back - return to the previous wizard screen.



Next > - proceed to the next wizard screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Export Wizard - Select data set title
This page sets the data set title for your exported document (see below).

To use, simply type the title into the Data set title field.
Note: a title can only contain either letters or numbers - it cannot contain both. In
addition, no spaces or wildcard symbols (asterisks, etc.) are allowed. To complete
this screen, choose one of the following options:


< Back - return to the previous wizard screen.



Next > - proceed to the Progress indicator screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Export Wizard - Progress screen
This screen activates automatically after the previous wizard screen is completed.
This page reports the progress of your export (see below).

IMPORTANT: export time is dependent upon the complexity of the chart. If the chart
is simple and the indicator does not update in a few seconds, or you believe that the
progress indicator is stuck, simply click Next to proceed to the final screen.
To complete this screen, choose one of the following options:


< Back - return to the previous wizard screen.



Next > - proceed to the Results screen.



Cancel - close the wizard without saving and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Export Wizard - Results screen
This screen displays the results of your export (see below).

The following areas and options are present on this page:


Results report area - displays the results of your export.



Errors report - displays any errors that may have occurred during the export
process.



Details - click this button for any additional information which may be available regarding the export of your document.

To complete this screen, choose one of the following options:


Finish - complete the wizard and return to the Main Work area.



Cancel - close the wizard and return to the Main Work area.



Help - launch the OrgChart Professional Help system.
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Internal Reports
Internal Reports are pragmatic, graphically simple reports usually produced for inhouse informational purposes. To create an Internal Report:
1. Go to File > Create Report. The Internal Report wizard will appear (see
below).

2. On the Existing Reports page, click New.
3. The Report Name page will appear (see below).
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4. Enter a new title in the Report Name field and click Next.
5. The Report Fields page will be displayed (see below).

6. On this screen, choose which fields you want (and don’t want) by
highlighting topics and clicking the arrow symbols. Click Next.
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7. The Report Criteria page is displayed (see below):



If you don’t want any additional criteria, click Finish to return to the
main wizard page.



If you want to add criteria, click the Add button. This will launch the Find
dialogue (shown below).

This is essentially a search/find function that will search your chart and place
the returned results into your report. Fill in the fields and click OK.
8. The Report Criteria page will be available again. Notice that your newly created report is listed in the Existing Reports window.
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9. Highlight a report in the Existing Reports window (Note: the Internal Report
button will remain inactive (‘grayed out’) if a report is not highlighted).
10. Click the Internal Report button.
11. Your report will be generated.

Viewing, printing and exporting Internal Reports
All Internal Report viewing, printing and exporting commands are accessed through
the Internal Reports - Report Viewer.
To view Internal Reports:

1. Highlight the report’s name in the Existing Reports window and click the
Internal Report button:
2. The report will be automatically displayed in the Internal Reports -Report
Viewer (see below).

To access all printing options in the Report Viewer:
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1. Left mouse click the Report button in the top left corner of the Report
Viewer. A list of options will appear (see below).

Choose from the following printing options:


Print - launches the standard Microsoft Windows Print interface.



Print Setup - launches the standard Microsoft Windows Print Properties
interface.



Print Preview - launches the OrgChart Professional Print Preview screen
(for more details, please see the Print Preview section).

(Note: Print, Print Setup and Print Preview follow all standard printing conventions outlined in Chapter 3: Printing.)
To export an Internal Report from the Report Viewer:

1. Left mouse click the Report button in the top left corner of the Report
Viewer. A list of options will appear (see above).
2. Choose Export > Excel.
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Appendix A: Interfaces
In this chapter you will find full descriptions of all the program’s interfaces, control
panels and modes.

Attachments - File Attachment Data menu
Files are attached to components through the File Attachment Data menu (see
below):

The File Attachment Data menu can be opened in the following ways:


Box Item -double click File Resume, or any custom designed data field
with an Attachment attribute.



Data Outline Pane - can launch the File Attachment Data menu in two
ways:

1. If no attachments are associated with the component -double
click File Resume, or any custom designed data field with an Attachment
attribute.
2. If attachments are already associated with the component double click the cell which contains the name of the attachment.
3. On-screen component -double click any visible data field which has
an Attachment attribute. Note: if no data fields with an Attachment
attribute are visible, go to the Box Item menu, choose a data field with an
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Attachment attribute (i.e. File Resume, etc.) and click in the visibility
column (for more details, see Box Item menu).

Attaching files
There are three steps to making attachments in the File Attachment Data menu:
1. Browse to the file - using the Browse button. When the Open box appears,
browse to the desired file and choose it by either double clicking the file or
highlighting it and clicking Open.
Note: once an attachment is chosen, an icon representing the file type will
appear in the lower left area of the menu (see the above illustration).
2. Name the attachment. The name that appears in the Display name field is
the name that will appear in the on-screen component. Names can be created
in the following ways:


Customize the attachment name - type a new name into the Display
name field to replace the file’s original name, then click OK or hit the
Enter key.



Use the attachment’s original name (no modification) - a file’s
original name is automatically placed in the Display name field when it is
chosen. To keep this name simply click OK or hit the Enter key.

Complete the process. Select one of the following options:



OK - accepts your choice and inserts it into the chart.



View - opens the file for viewing. Note: the View button will be inactive
(‘grayed out’) if the attachment is empty (such as a text file with no text).



Save As - allows you to save the attachment in a new location and with a
new name.



Clear data - clears all fields and resets the menu defaults.



Help - launches the Help menu.



Cancel - closes the panel without saving any data.
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Border Style
This menu controls the appearance of the line which defines a component’s shape.
You can control the following: Line Style, Line Width, Fill Style, Join Style and
Transparency.

Important: a border must be present on the chart or the Border Style menu will be
inactive (‘grayed out’).
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Accessing the Border Style menu
1. Select the current chart’s border (see Selecting Borders for details).
2. Access a Border Style menu by doing one of the following:


Go to Shape > Format > Border Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Border Style.

The following options are available for border style manipulation:


Line Style - a list of solid and dotted line styles.



Fill Style - this launches the Line Fill Style palette (a four tabbed menu
which is essentially identical to the Fill Style menu. For more details, see Fill
Style).



Line Width - this determines how thick a line is. Sizes can be chosen from
the list or typed in manually.



Join Style - this drop down menu provides a choice of three different corner
styles.



Transparency - this button toggles the line between complete opacity (0,0)
to complete transparency (255, 255).



Preview - this preview window allows you to see your choice before committing it to the on-screen component.



Help - this launches OrgChart Help.

To complete the process, you must select one of the following options:


OK - applies and saves your choices then closes the panel.



Cancel - closes the panel without saving the changes.
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Box Item menu
Dynamic in nature, this menu displays the Data Fields for any currently selected
component. (Note: the Box Item menu will only become active after an ‘on screen’
component has been selected.)

Hiding and revealing Box Item
To hide and reveal this item:
1. Go to View > Box Item.
2. The Box Item menu will toggle in and out of view accordingly. (Note: a
check mark will appear next to the item’s name to indicate if it is hidden or
visible.)

Data Fields information types found within Box Item
Information fields may of the following types:


Text - text information can be typed directly (or cut and pasted) into these
fields.



Salary - is a powerful field used for dynamic, on-the-fly calculations of budgets and expenditures. It is used in conjunction with the Headcount and Team
Budget fields. Single click to open.



Link - double clicking this field launches a new interface for link creation.



Image - stored images are linked to a component through this field.



Attachment - stored information files are linked to a component through this
field.
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Box Item Layout tab buttons
The following buttons are located on the Layout tab of the Box Item menu (see
below):

1 2 3

4

5

1. Options - opens a drop down menu providing different options on how data
is displayed in the selected onscreen component. These options include text
alignment, fonts and whether the title of the data field (such as Name, Title,
etc.) appears within the component.
2. Move down - changes the order of a selected data field by moving it higher
on the list.
3. Move up - changes the order of a selected data field by moving lower on the
list.
4. Font - launches a font menu to select how text is displayed in the onscreen
component.
5. Visibility icon - a check mark in the column beneath this indicates if a item
is visible or hidden.
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Box Item: Data View and Layout Tabs Overview
The Box Item area contains two tabs to help organize and display information conveniently.
Box Item Data View and Layout tabs

By understanding how these tabs work, you can arrange your work space and onchart components efficiently and with the greatest visual impact.


Data View tab - effects primarily the Box Item work space and data, specifically:

1. What specific data is entered into a component’s data fields (such as a
person’s name, their supervisor, phone number, etc.). Note: entering data
does not mean that the data will appear automatically in the on-chart
component. Which data appears in the chart is determined in the Layout tab.
2. How the data appears in the Box Item work space (such as an employee’s
photo, etc.). Note: this does not determine what appears in the on-chart
component.
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Layout tab - effects only the on-chart components:

1. What data fields appear in the on-chart components. (Check the ‘eye’ shaped
visibility box next to each field to determine if that field, such as a person’s
name or title, will appear in the on-chart component.)
2. How the data appears in the on-chart component. This includes: a) what
appears, b) the order it appears in, c) the alignment of text inside the
component (left, right or center) and d) the font of the text. Other options are
also available.

Box Item ‘Options’ button
The Options button appears on both Box Item tabs and provides different choices for
each section. The following is a diagram of the options provided for each tab.
Box Item ‘Options’ Button
Different options available in Data View and Layout tabs

As with the tabs themselves, the choices offered by the Options button effect different
aspects of the chart and work space.
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‘Options’ button on the Data View tab - effects primarily the Box Item
work space and data. As a result, most of the options launch either another
screen, or another dialogue to help organize, print or export the data itself.

The following is a list of options available from this drop down menu:
1. Edit Chart Data Set - launches the Chart Data Set menu. The Chart Data
Set interface sets global changes which can affect every component if you so
choose. From this menu you can: a) create new data fields, b) load predefined
fields, 3) edit fields, 4) rearrange the order in which fields appear and 5)
delete existing fields.
2. Edit Current Data View - launches the Edit Data View menu. This interface
is used to define and edit data views currently available in the Current Box
Layout drop down menu directly to the right of the Options button.

3. Define Data Views - launches the Define Data View menu. This interface is
used to add new data views which will then become available in the Current
Box Layout drop down menu. It can also be used to edit currently existing
data views.
4. Print - launches the standard Windows print interface. This prints the names
and values of the data fields currently displayed in the Box Item area.
5. Print Preview - launches a preview screen showing how the currently
displayed Box Item data fields will appear when printed out.
6. Copy Data - allows you to copy the information in a data field simply by
clicking on the title of the field (such as Name or Title, etc.). You can then
paste this information into any other field of any other component. To use: 1)
In the Box Item area, click on the title of a data field, then 2) click the Options
button and choose Data Copy, next 3) choose any other data field in any
component (by highlighting it onscreen or in the Box Item area) and finally 4)
paste the information into the new location (by using either Edit > Paste or
right clicking on the highlighted field in the on-chart component and choosing
Paste from the menu).
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7. Export - launches the Export Wizard, which takes the user step-by-step
through the process of exporting data fields to various formats and locations.
(For more information on exporting data, please see the Export Wizard
section of this manual.)
8. Show Column Name - toggles between displaying and hiding the data field
titles in the Box Item area.



‘Options’ button on the Layout tab -These effect only on-chart components.
The following is a list of options available from this drop down menu:

1. Display Column Name - toggles between displaying and hiding the data
field titles in the on-chart component (see below):

Note: this effects each data field independently, so one field could be set to
Display Column Name ‘on’, while another data field in the same component
could be set to have this option toggled off.
2.
3.
4.
5.

Align Left - aligns the text of the on-chart component to the left.
Align Center - centers the text of the on-chart component.
Align Right - aligns the text of the on-chart component to the right.
Font Style - launches the Font Style menu. This interface provides a wide
range of choices on how the text inside a component will appear.
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Displaying a Picture in Box Item View
In addition to displaying text or numerical information, images and pictures can now
be displayed in the Box Item area (see below):

This very powerful tool is great for browsing personnel photos or having instant
access to any other visual data you may wish to have associated with a component.
To display a picture in the Box Item area:
1. Click on a component in your chart to activate the Box Item area.
2. In the Box Item area, make certain the data view you have chosen contains
the Photo data field. (For more information on editing and choosing data
views, please see the Current Box Layout section.)
3. Click on the Photo data field. The field will
turn gray and a small button will appear.
4. Click the small button, this will launch the Image Data interface (see below)
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5. Click the Browse button and navigate to the location of the image you wish to
display.
6. Choose the image and click OK.
7. The image will now appear in the Preview Pane of the Image Data interface.
8. Choose the Display Size from the drop down menu and click OK.
9. The image will appear in the Box Item area.
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Box Properties interface
On-screen graphics are just a small part of what components can do. Components can
also contain vast amounts of information which can be entered, edited, exported and
even printed out. An important area for the manipulation of this information is the
Box Properties interface. (This area has two tabs. The image below shows the Box
Properties menu with the Edit Data tab selected).

Displaying the Box Properties interface
Once a component is selected, the Box Properties interface can be accessed in the
following ways:



Go to Shape > Properties.
Double click an empty area inside a component (an area with no text or
graphics, etc.).
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Right click a component to launch a pop-up menu. In the pop-up menu
choose Properties.



Use the hotkey combination of Alt + Enter.

Box Properties: Scope
Scope is a powerful and intuitive interface which allows you to quickly set the range
and locations of the data changes in your chart. It is found in the Apply To section at
the bottom of both Box Properties tabs. It has the following options:





Selection - only applies changes to the currently selected component(s).
Entire Chart - applies changes to every component in the chart.
Active Division - only applies the changes to the division of the currently
selected component.

Special Tip: Scope is one of OrgChart’s most useful features because it can be
applied to any data field in any combination anywhere on the chart. This means that
you can set certain fields, like the company’s name or telephone number, to appear in
every component in the division or chart, but leave all the other data fields
unaffected. Since you can have any data (or field) appear anywhere, the possibilities
and time saving features of scope are almost limitless.

Box Properties: Edit Data
This area is used to define what data will be associated with certain component(s). To
use this section:
1. Click in the right hand column of the data field you want to edit. The area
will turn blue in color.
2. Enter the data.
3. Press Enter or click in another field to apply the data.
4. Set the scope of the changes by going to the Apply To area and clicking one
of the available choices.
5. Click the OK button to apply the changes and close the menu.
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Box Properties: Define Layout
This area determines the visual appearance the data in the component. It determines
what is visible and where (see below):

This tab consists of the following areas:


The Data Field area - displays what data fields are available (this changes
depending on what data view you have chosen). It contains the following:

o Data field names in the left column.
o Visibility box in the right column. Check this box to toggle the selected
field between being visible and hidden.
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The Preview Pane - displays a simple diagram of the component. It shows:

o The data fields that will be visible - to change this, check or uncheck the
visibility box in the Data Fields area.
o The order of the data fields - to change the order, highlight the desired
field in the Data Fields area, then click the Move Up or Move Down buttons. (Note: The Move Up and Move Down buttons will only become
active if a data field with a check in the visibility box is selected. These
buttons will also either activate or deactivate depending which data field
is selected.)
o The component’s text font - this is selected in the Display Properties area
(see below).
o The component’s text alignment - this is selected in the Display
Properties area (see below).


The Display Properties area - determines certain visual properties of the
component. It contains the following:

o Display Column Name - check this box to make the title of the data field
appear in the component (for example, with the box checked a person
named ‘Mr. Sample’ would appear in the component as ‘Title: Mr. Sample’.)
o Text alignment buttons - click any of the three buttons to determine if the
text will be aligned on the left, center or right of the component.
o Font Style - click this button to open the font menu (for more details,
please see the Font Style section of this manual).


The Apply To area - determines the scope of the changes which have been
determined in the other areas (for more details, please see the Box Properties:
Scope and Apply Scope sections of this manual).

Once you have made your selections from the above sections, click the OK button to
apply the changes and close the menu.
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Calculated Field - Headcount and Team Budget
Calculated Field is an incredibly useful menu that allows the automatic tallying of
personnel, salaries and team budgets. It is applied to a parent component to keep
track of its subordinates. The scope can be set to branches, managers and subordinates (see below):

Accessing the Calculated Fields menu
1. Go to Box Item.
2. Double click either of the following data fields:


Headcounts



Team Budget

3. The Calculated Field menu will appear.
The following is an on screen example of a parent component with Headcount and
Team Budget applied. (Salary is also present since it is integral to calculating Team
Budget. For more information on using Salary, see Data Field - information types Salary).
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Performing Headcounts
To perform Headcounts, the following settings must be chosen for each corresponding field:
1. Operations field -Count
2. Affected Data Field -Headcount
3. Affected Scope - any setting may be applied (the default is Branch and Mgr.).
These settings appear by default when the Headcounts field is double
clicked. Under other circumstances, the settings may have to be manually
selected.

Note: the Affected Data Field is inaccessible (‘grayed out’) when Count is
selected in the Operation area. To make changes in the Affected Data Field:
1. Choose Sum in the Operation area, this will make the Affected Data
Field active.
2. Choose an option in the Affected Data Field.
3. Go to any other field and make any selection.
The following options are available in each area:
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Operation - 1) Sum and 2) Count.



Affected Data Field - 1) Headcount, 2) Salary and 3) Team Budget.



Affected Scope - 1) Branch and Mgr., 2) Branch Excl. Mgr., 3) Direct
Subordinates and 4) Mgr., Direct Subordinates Excl. Mgr.

Performing Team Budget
Team Budget derives its calculations from information gathered from the Head-count
and Salary fields of a parent component and its subordinates. As a result, a number
must be entered into at least one component’s Salary field or the Team Budget will be
zero.
To perform a Team Budget, do the following:
1. In Box Item, double click Team Budget.
2. Make certain Calculated Fields is set as followed:


Operations field -Sum



Affected Data Field -Salary



Affected Scope - any setting may be applied (the default is Branch and
Mgr.). (These settings appear by default when the Team Budget field is
double clicked. Under other circumstances, the settings may have to be
manually selected).

3. Make certain a number is entered in at least one component’s Salary field.
4. Highlight the parent component.
5. The Team Budget for the parent component and all its subordinates will be
displayed.
To complete the Calculated Fields menu, select one of the following options:


OK - accepts and saves your choices and closes the panel.



Cancel - closes the panel without saving the changes.
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Chart Data Set
In addition to the default Data Fields present in the Box Properties menu, new fields
can be created, modified or deleted globally through the Chart Data Set interface (see
below):

IMPORTANT: The Chart Data Set stores and creates data fields that can become
available to every component (globally). However, although these fields are avail
able, they are not automatically included or visible in the final component. Only after
you set the data field to be accessible and visible will it then be available for the chart
building process.
Accessing the Chart Data Set interface:
There are several ways to access this area:



Main menu - go to Chart > Chart Data Set.



Box Item menu:

1. Open the Data View tab.
2. Click the Options button.
3. Choose Edit Chart Data Set from the drop down menu.

Page 259 of 318

OrgChart Professional

Appendix A: Interfaces

Editing an existing data field:

There are five fields which can be edited in the Chart Data Set:


Name - to edit this field, do the following:

1. Click on the Name column of the chosen data field. The area will turn
blue, signifying that it is now editable.
2. Enter the new information.
3. Press Enter, or click in another data field and the information will be
applied.


Type - there are nine different types of data fields: 1) text, 2) numerical, 3) currency, 4) calculated, 5) link, 6) image, 7) attachment, 8) FormTool document
and 9) supervisor. To edit this field, do the following:

1. Click on the Type column of the chosen data field. The field will turn
blue and a small button will appear on the right side.
2. Click the button to open a drop down menu displaying the nine types of
fields listed above.
3. Click on your choice in the drop down menu.
4. The selection will now appear in the Type field.


Visible - determines whether the data field will be visible. Check this box to
toggle between visible and hidden.



Display Name - determines whether the title of the data field (such as Name,
Title, Photo, etc.) will appear in the component. (For example, in a component
with a person named ‘Mr. Sample’, the name would appear as ‘Title: Mr. Sample’ if Display Name was checked.) Check this box to toggle the data field title
between visible and hidden.



Formula - formulas are only available if certain types of data field were
selected in the Type column (i.e. numeric, currency, calculated, etc.). To edit
this field:

1. Click on the Formula column of the chosen data field. The field will turn
blue and a small button will appear on the right side.
2. Click the button to open a drop down menu displaying the Calculated Field
menu (see below):

Page 260 of 318

OrgChart Professional

Appendix A: Interfaces

3. Choose options from the drop down menus in the Operation, Affected
Column and Affected Scope areas and click OK.
4. The Calculated Field menu will close and your selection will now appear in
the Formula area of the Chart Data Set.
To create a new data field:

1. Click the New button. The Name column will turn blue and a new entry entitled ‘Unnamed’ will appear.
2. Type in a name for your new data field, then either hit Enter or click in
another field to apply the change.
3. Choose your options, from the Type, Visible, Display Name and Formula
areas.
4. When you are done editing the data sets, click OK to close the interface.
5. The Add Columns in Data Views menu will open. This interface provides the
option to add your newly created data field to already existing Defined Data
Views (see below):
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To add your new field to an existing Defined Data View:

1. Check the box next to the views you want your new field to appear in.
2. Click OK.
3. The interface will close and you will be returned to the main work area.
(From this point on, whenever any of the views you checked is chosen in the
Box Item: Current Box Layout or Outline View: Data View Quick Selector
menus, your new data field will appear along with the other data fields.)
To load a predefined data field:

OrgChart Professional comes with a library of predefined (previously designed) data
fields. To load from this library:
1. Click the Add Predefined button.
2. The Add Data Fields menu will appear (see below):
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3. Highlight the data field you wish to add and click the Add button.
4. The Add Data Fields interface will disappear and your selected, predefined
data field will appear in the Chart Data Set area.
Additional Chart Data Set buttons:
 Delete - removes a data field from the Chart Data Set area. To use, simply
highlight the field you wish to remove and press Delete.
 Set Title - sets the currently chosen data field as a title. If the currently highlighted field has already been set through this option, the button will
automatically switch to Remove Title.
 Move Up - moves an item higher on the list. This option is inactive if the
selection is already at the top.
 Move Down - moves an item lower on the list. This option is inactive if the
selection is already at the bottom.
 To complete the Chart Data Set process, choose from the following: OK accepts your choices and applies them universally to the data fields of every
component.
 Cancel - closes the panel without making any changes.
 Help - launches the Help menu.
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Chart Design Palette
This dynamic and rich interface is where most of the chart creation takes place.

The Chart Design Palette contains the following seven (7) expandable areas:








Themes: visual motifs which effect the appearance of the chart, applied
components and certain menu views.
Backgrounds: patterns which appear only on the chart (but don’t effect
components).
Borders: designs which appear only along the outer edges of the chart.
Shapes: styles that modify a component’s shape. IMPORTANT: a shape can
only be applied to components that are already present on the chart.
Components: the building blocks of a chart. Components can be moved,
linked, hidden and resized. By default, they display an entry’s Name and Title
but can show an almost infinite range of information.
AutoTexts - boxes which contain text and information which can be
automatically applied to the chart and customized.

Note: Information inside an AutoText can only be changed from the Divisions
View.
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To change the text in an AutoText, do the following:
1. Place an AutoText on the Chart.
2. Open up Divisions View.
3. In Division View, highlight the name of the level the AutoText is on.
The level will have a default name such as Chart, Division 1, Division
2, etc.
4. Press the F2 key to make the default Division name editable.
5. Input the text you wish to appear in the AutoText.
6. Hit Enter to apply the change.


Clipart: graphics and images designed to be inserted into charts to visually
enhance your presentations. OrgChart Professional comes with a preinstalled library of images. Users may also import images from almost any
source.

Connector Style
This controls the appearance of a component’s connector and of Dynamic Connectors. From here you can control: Line Style, Line Width, Join Style, Fill Style, and
how a connector starts and ends (i.e. with an arrow, plain, etc.).
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1) You cannot directly select the connector between two components
(if you wish to edit it). Instead, you must select one of the components
and then bring up the Connector Style menu.
2)An on screen component must be selected or the Connector Style
menu will be inactive (‘grayed out’).

Accessing the Connector Style menu
The Connector Style menu can be accessed in two ways:



Go to Shape > Format on the Main Menu and choose from the expanded list
of menus.
Right click an on screen component to launch a pop-up menu. When the
menu appears, go to Format and choose from the expanded list of menus.

Connector Style menu
The following options are available for connector style manipulation:










Line Style - a list of solid and dotted line styles.
Fill Style - this launches the Line Fill Style palette (a four tabbed menu
which is essentially identical to the Fill Style menu. For more details, see Fill
Style).
Start with - a drop down menu of styles to start the connector with. This list
includes various arrows, bulges and curved edges.
End with - a drop down menu of styles to end the connector with. This list
includes various arrows, bulges and curved edges.
Line Width - this determines how thick a line is. Sizes can be chosen from
the list or typed in manually.
Join Style - this drop down menu provides a choice of three different corner
styles.
Transparency - this button toggles the line between complete opacity (0,0)
to complete transparency (255, 255).
Preview - this preview window allows you to see your choice before committing it to the on-screen component.
Help - this launches OrgChart Help.

To complete the process, you must select one of the following options:



OK - applies and saves your choices then closes the panel.
Cancel - closes the panel without saving the changes.
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Customize columns (in Data Outline View)
The Customize Columns panel (see below) allows you to sort, add and delete
columns from the Data Outline View.

Customize Columns menu
To access this menu, do one of the following:


Go to View > Data Outline View > Customize Columns.



Right click the title bar of any field in the Data Outline View, then choose
Customize Columns (see below).

RULES: 1) Only items in the Selected Items pane appear in the Data Outline View.
2) A field must be ‘visible’ in at least one on-screen component for it to be
listed in Data Outline View (if it is hidden in all the components it will not
show up).
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Assigning Columns:



To add columns - choose items from the Available Columns pane (on the
left) and click the right arrow (>) button.



To remove columns - choose items from the Selected Columns area (on the
right) and click the left arrow (<) button.

Arranging Columns - highlight an item in the Selected Columns pane, then:



Move Up - moves an item higher on the list. This option is inactive if the
selection is already at the top.



Move Down - moves an item lower on the list. This option is inactive if the
selection is already at the bottom.

Data Link Properties screen
When importing OLE DB DataSource, the Data Link Properties screen is used to
choose the database provider, test the connection, set access permissions and specify
many other important settings.
To access the Data Link Properties page:

1. Go to File > Import to launch the Import Wizard.
2. Click Next on the Introduction screen.
3. Choose OLE DB DataSource as the import format.
4. Click Build on the connection parameters page.
5. The Data Link Properties screen will appear (see below).
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Data Outline View
Located at the bottom of the work area, the Data Outline View is an area that allows
the centralized management of component information. It can also be used to connect
components, assign Supervisors, and change Data Field content. (Note: Data Outline
View can only be toggled ‘on’ and ‘off’ through View > Data Outline View.)

Note: The main advantage of Data Outline View over the Box Item menu is that you
can manage all of the component data fields in one place.
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Hiding and revealing Data Outline View
The Data Outline View is not listed on the Toolbars menu; instead, it is found on the
View menu. To hide and reveal this palette:
1. Go to View.
2. Click on Data Outline View. The palette will toggle in and out of view
accordingly.

Data Field types in Data Outline View
Information fields may be of the following types:


Text - text information can be typed directly (or cut and pasted) into these
fields.



Salary - is a powerful field used for dynamic, on-the-fly calculations of budgets and expenditures. It is used in conjunction with the Headcount and Team
Budget fields. Single click to open.





Link - double clicking this field launches a new interface for link creation.
Image - stored images are linked to a component through this field.
Attachment - stored information files are linked to a component through this
field.

Connecting components in Data Outline View
1. Make certain two (unconnected) components are on the chart.
2. Go to Data Outline View. The names of both components are listed.
3. In the Name field, click on the first component’s name and drag and drop it
onto the name of the second component.
4. On the chart, the two components are now linked.
5. In the Data Outline View, the linking of the two components is signified by a
line which joins their names. (In the below illustration, Box 1 is the ‘parent’
and ‘Box 2’ is the ‘child’.)
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Collapsing Subordinates in Data Outline View
In Data Outline View, the hierarchical tree of linked components can be collapsed or
expanded by clicking the box next to the parent component’s name. (A plus sign (+)
in the box indicates that the tree is collapsed and a minus sign (-) indicates that the
tree is expanded.)

Additional Data Outline View commands
The following Data Outline View functions can be accessed by going to View on the
Main Menu:


Customize Data Outline View columns.



Intelligence sort.



Sort the List.



Field Hidden

Manually rearranging data fields in Data Outline View
To manually rearrange the data fields:
1. Click on the data field’s column header.
2. Hold down the Left Mouse Button and drag the header along the top of the
data fields area. Release the header when you reach the desired location. For
more details on resizing and rearranging the Data Outline View title bar,
please see Data Outline View in the first chapter of this manual.
(Note: the order of the data fields in Data Outline View does not influence how they
appear in the associated on-screen component.)
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Displaying and hiding a component’s data on the chart
A component can have dozens of Data Fields - far too many to be displayed on the
chart. To solve this, the user can control which fields are visible. By default, the
Name and Title fields are active. To select which fields will be displayed click in the
box on the far right of each line (see below):

An ‘x’ in the box signifies that the field is visible; an empty box indicates it is hidden.
(In the above illustration, Name and Title will be displayed in the component, but
Company will not.)

Data Fields information types
Information fields may of the following types:


Text - text information can be typed directly (or cut and pasted) into these
fields. Single click to open.



Salary - is a powerful field used for dynamic, on-the-fly calculations of budgets and expenditures. It is used in conjunction with the Headcount and Team
Budget fields. Single click to open.



Link - this is where links are created. Double click in the field to open the
Modify Link menu.



Image - stored images are linked to a component through this field. Double
click in the field to open the Photo Property menu.



Attachment - stored information files are linked to a component through this
field. Double click in the field to open the Attachment menu.

.
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Division View
Division View allows you to view and navigate complex charts easily. It does this by
displaying the entire chart - including all hidden division sub-charts - in an elegant
and simple tree structure (see below).

To access Division View:

1. Make certain that Data Outline View is active by choosing View > Data
Outline View.
2. Click the Division View tab at the bottom of the Data Outline View window.
Divisions View tree conventions:

1. Main chart - situated at the top of the tree in the upper left corner.
2. Highest tier Divisions - these first divisions run vertically along the left of
the diagram.
3. All additional (lower) divisions - run in a staggered (stair step) pattern
from left to right; starting from their Parent (first tier) divisions (see below).
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4. Navigating in Division View - simply click on the division’s name and
the chart for that division will appear in the Main Work Area.

Find
The Find function is a powerful search tool which allows the user to locate specific
components through their data fields (such as name, address, business, title, etc.). It is
pictured below:

Accessing the Find menu
The Find menu can be accessed in two ways.


On the Main Menu - go to Edit > Find.



Press CTRL + F.

Page 274 of 318

OrgChart Professional

Appendix A: Interfaces

Find search parameter fields
Find contains three search parameter fields. The following is a list of the filter fields
and their associated options (accessed through each field’s drop down menu).
1. Field Name - this area allows you to conduct a search based on the chart’s
data fields (i.e. name, title, company, etc.).


For the broadest search, choose Any Field.



To narrow the search, choose a specific data field listed in the drop down
menu.

2. Comparison - this filter tells the search engine how to interpret the text you
input into the Contents field. It tells the engine if it is looking for text that
matches, or text that doesn’t, etc. The following is a list of the available
options:


Equal to - searches for a data string that is equal to the value in the Contents field.



Not Equal to - searches for all data that is not equal to (does not match)
the value in the Contents field.



Not contains - this (strange sounding) filter searches for all data that
does not contain the value in the Contents field.



Empty - searches for components that contain empty fields.

3. Contents - this is where you type keywords relating to your search. A list of
previously entered keywords is located in the drop down menu.
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Fill Style
This powerful mega-menu is divided into four areas (pictured below):

Fill Style menu
Click on a tab to display any of the following four areas:


Color: choose a standard fill color or create a custom one.



Gradient: choose a gradient (gradual transition) from one color to another.



Pattern: choose from a menu of pre-loaded patterns.



Picture: choose a picture then apply a tint color (to change its shade).
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Accessing the Fill Style menu
1. Select a component or border.
2. Do one of the following:


Go to Shape > Format > Fill Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Fill Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Border Style. Once in the Border Style menu,
click the Fill button.

Font Style
This menu allows you to control font attributes in every OrgChart element where text
can be applied (see below):
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Accessing the Font Style menu
1. Select the border (see Selecting Borders for details).
2. Access a Font Style menu by doing one of the following:


Go to Shape > Format > Font Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Font Style.

The following options are available for font manipulation:


Font - a list of available alphabets.



Font Style - a list of choices on letter orientation and weight.



Font Size - where letter size is determined. Sizes can be chosen from the list
or typed in manually.



Effects - two effects are available: 1) Underline and 2) Strikeout (a line is
placed through the letters).



Fill Style - this button launches the Fill Style menu (see Fill Style).



Sample - this preview window allows you to see your choice before committing it to the on-screen component.



Script - this offers the following encoding options: Western, Hebrew, Arabic
and Greek.



Help - this launches OrgChart Help.

To complete the process, you must select one of the following options:


OK - applies and saves your choices then closes the panel.



Cancel - closes the panel without saving the changes.
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Gradient
A Gradient is a gradual transition from one color to another. The Gradient menu is
located on the second tab of the Fill Style menu (see below):

Accessing the Gradient menu
1. Select a component or border.
2. Do one of the following:




Go to Shape > Format > Fill Style.
Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Fill Style.
Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Border Style. Once in the Border Style menu,
click the Fill button.

3. Choose the Gradient tab.
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The following options are available for gradient creation:


Colors - this determines the gradient’s start and end colors. Click the Start
Color and End Color fields to launch a palette of colors to choose from.



Transparency - these sliders determine the transparency of the colors
chosen in the Start Color and End Color fields. On the slider scale, the left
end equals 100% opacity and right end equals 100% transparency.



Shading Style - select one of these radio buttons to determine the gradient’s
pattern.



Sample - this preview window allows you to see your choice before committing it to the on-screen component.

To complete the gradient process you must select one of the following options:


OK - accepts and saves your choices then closes the panel.



Cancel - closes the panel without saving the changes.



Apply - applies and saves the changes without leaving the panel.

Image Data menu
Photos and images are managed in the Image Data menu (pictured below):
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To open up this screen, double click the Photo field in the Box Item menu or
Data Outline View areas.

Inserting a picture into a chart
1. Go to either Box Item or Data Outline View and double click on the Photo
field.
2. In the Photo Property box, click the Browse button.
3. Browse to the location that has your image.
4. Choose the image file and click Open. A preview of the picture will appear
in the Photo Property preview window.
5. Select from the following options:


Display Size - determines how large the picture is displayed in the onscreen component. Choices range from 32x32 to 1024x1024 pixels. (512
x 512 is recommended.



OK - accepts your choice and inserts it into the chart.



Save As - allows you to browse to a save location, assign a file name and
save the image as a BMP, JPEG, GIF, TIFF or PNG.



Clear data - erases all changes and resets the panel defaults.



Help - launches the Help menu.



Cancel - closes the panel without saving any data.
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LDAP - special considerations
Many of the unique settings necessary for a successful LDAP import are entered on
this connection parameters screen (see below).

When importing LDAP, take the following into consideration:
1. Make certain the server you are importing from is up and running.
2. Obtain the Root DN and Root Password information. This information is
usually found on the server’s slapd.conf configuration file. (In the file, look
for the name of the root object (rootdn) and the password (rootpw).
3. Use the information gathered in Step #2 to fill in the Username and
Password fields of the LDAP connection parameters box (pictured above).
4. Make certain you correctly enter the LDAP connection string before proceeding to the next page.
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Layout Print Pages
OrgChart Professional can print charts which range from a single page to mega-sized
charts which fill an entire wall. The workhorse for this feature is the Layout Print
Pages menu (see below).

To access this menu:
1. Go to File > Chart Page Setup.
2. On the Page Setup screen, choose the Layout Pages button.
The main purpose of this interface is to create charts which span as many pages as
you require. To achieve this, do the following:
1. Fit Chart On area - set the number of pages your chart will be printed out
on:


For oversized charts (charts more than one page) - set the number of
pages to more than one in the Pages in Width and/or the Pages in Height
field.



For single page charts - leave the Pages in Width and Pages in Height
fields set at 1.

2. Orientation area - click a radio button to set the page orientation to either
Portrait or Landscape.
3. Enlarge chart to fit all available -check this box to re-size the chart to
spread correctly across all the pages.
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4. Choose OK to accept the settings and close the Layout Print Pages screen.
5. On the Print Setup Page choose either Print to go directly to the print
interface or OK to return to the Main Work area.

Link Data menu
All links are controlled from the Link Data menu (see below):

Note: the Browse button is only active when “file://” is chosen. In all other instances
it will be inactive and ‘grayed out’.
The Link Data menu can be opened in the following ways:


Box Item -double click e-mail office, e-mail home, or any custom designed
data field with a Link attribute.



Data Outline Pane - can launch the Link Data menu in two ways:

o If no links are associated with the component - go to Box Item and
click in the visibility column of e-mail office, e-mail home, or any custom
designed data field with a link attribute. The item will now appear in the
Data Outline View. Once the item is present, go to Data Outline View and
double click the cell which contains the name of the link.
o If links are already associated with the component -double click
the cell which contains the name of the link.


On-screen component -double click any visible data field which has a
link attribute. Note: if no data fields with a link attribute are visible, go to the
Box Item menu, choose a data field with a link attribute (i.e. e-mail, etc.) and
click in the visibility column (for more details, see Box Item menu).
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Link creation in the Link Data menu
There are three steps to creating a successful link:
1. Choose the Link type. Click the small down arrow to expand the Link To
drop down menu. The following types of links are available:


file:/// - use by clicking the Browse button to locate a valid entry then
click Open. The choice will be displayed the upper field.



mailto - requires a valid email address be typed into the upper field.



http:// - requires a valid internet address to be typed into the upper field.



ftp:// - requires a valid ftp (file transfer protocol) address to be typed into
the upper field.

2. Name your link. The name that appears in the Display As field is the name
that will appear in the on-screen component. Names can be created in the
following ways:


Customize the link name - type a new name into the Display As field,
then click OK or hit the Enter key.



Use the link’s original name (no modification) - leave the Display As
field empty then click OK or hit the Enter key.

3. Test the link. Your link will appear, underlined in blue, in the area beneath
the Display As field and above the navigation buttons (see the underlined
mailto: link in the above illustration).
4. Complete the process. Select one of the following options:


OK - accepts your choice and inserts it into the chart.



Clear data - clears all changes and resets the menu defaults.



Help - launches the Help menu.



Cancel - closes the panel without saving any data.
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Multiple Shapes
This special dialogue allows multiple shapes to be simultaneously placed on the chart
(see below):

Accessing the Multiple Shapes menu
This menu is automatically launched when the Multiple Shape component
is applied to the chart.

Multiple Shape menu
The following options are available from the Multiple Shapes menu:


Number of Shapes - this determines how many components will be
automatically placed on the chart. The number can be chosen by using the
arrows or typed in manually.
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Shape Box - this scroll bar displays all available shape designs. Click on an
icon to choose that style. All styles will be immediately updated in the
Preview area.



Preview - this preview window allows you to see your choice before committing to a final decision.



Fill Style - this launches the Fill Style menu (for more details, see Fill Style).



Border Style - this launches the Border Style menu (for more details, see
Border Style).



Connector Style - this launches the Connector Style menu (for more details,
see Connector Style)



Font Style - this launches the Font Style menu (for more details, see Font
Style).



Font Title - this also launches the Font Style menu (for more details, see
Font Style).



Help - this launches OrgChart Help.

To complete the Multiple Shapes process, you must select one of the following:


OK - applies and saves your choices then closes the panel.



Cancel - closes the panel without saving the changes.
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Options Screen
The Options screen is used to set certain global defaults in OrgChart Professional. It
is comprised of the General and Default Fields Set screens. To access the Options
screen - go to Tools > Options.

Options Screen - General
This menu is used to set which introductory screens and messages will be displayed
(see below).

Tell OrgChart to show or hide pages by checking or un-checking boxes:


To display a screen -Check the corresponding box.



To hide a screen -Uncheck the corresponding box. The following screens
can be set to be displayed or hidden:

Welcome Screen:



Display on application startup.



Unfold tips section.
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Wizard Dialogs:



Show Import Wizard intro page.



Show Publish Wizard intro page.



Show Export Wizard intro page.

Find Dialog:



Show not found message.



Show restart search message. .

Options screen - Setting default fields
The Chart Data Set screen creates global changes that determine which Data Fields
will be present in every component in the project (see below).

For full details on how to use this screen, please see the Modifying Datafields Default Fields Set section.
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Page Setup menu
This interface is used to set the paper attributes for your chart (see below). To access
this menu, go to File > Chart Page Setup.

This screen contains the following:


Layout Pages - this button launches the Layout Print Pages menu, which is
used to set the physical size of the chart by setting how many pages it will be
printed out on (for more information on printing multiple page charts, see
Printing multiple page charts and Layout Print Pages).



Restore - resets the page defaults.



Paper area - contains options for: 1) Size (allows you to choose from an
extensive list of paper sizes and shapes from the drop down menu and 2)
Source (sets the paper source. The default is ‘Automatically select’).



Margins area - displays the Left, Right, Top and Bottom margins. These can
be altered by manually entering new values in the fields for each margin.
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Pattern
OrgChart Professional provides a suite of patterns which can be applied to components. This catalog of choices is located on the Pattern tab of the Fill Style menu
(pictured below):
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To Access the Patterns menu:

1. Select a component or border.
2. Do one of the following:


Go to Shape > Format > Fill Style. Right click in the chart to launch a
pop-up menu. When the menu appears, go to Format > Fill Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Border Style. Once in the Border Style menu,
click the Fill button.

3. When the Fill Style menu appears, click the Pattern tab.
The following options are available for pattern creation:


Pattern - each button represents a different pattern which can be applied to
the component. Click the button to choose a pattern.



Color - this determines the pattern’s foreground and background colors.
Click the Foreground and Background fields to launch a palette of colors to
choose from.



Transparency - these sliders determine the transparency of the colors
chosen in the Foreground and Background fields. On the slider scale, the left
end equals 100% opacity and right end equals 100% transparency.



Sample - this preview window allows you to see your choice before committing it to the on-screen component.
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Picture
In addition to gradients and patterns, OrgChart Professional allows you to place
pictures on a component. Imagine not just having the name of a friend on your chart,
but their photo as well! The possibilities are limitless - and the Picture tab on the Fill
Style menu is where you can make it happen (see below):

Accessing the Picture menu
1. Select a component or border.
2. Do one of the following:


Go to Shape > Format > Fill Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Fill Style.



Right click in the chart to launch a pop-up menu. When the menu
appears, go to Format > Border Style. Once in the Border Style menu,
click the Fill button.

3. When the Fill Style menu appears, click the Picture tab.
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The following options are available for picture import and manipulation:


Picture - this preview window allows you to see your choice before committing it to the on-screen component.



Browse - click this button to browse to your picture’s location.



Style - this drop down menu provides different choices for your picture’s orientation and dimensions. They are as follows:



Tile -this takes pictures that are too small and repeats them to fill the frame.



Flip Horizontally - this flips a picture horizontally.



Flip Vertically - this flips a picture vertically.



Flip Horizontally and Vertically - this creates a mixed flip for an interesting effect.



Center - this takes a picture and centers it in the frame.



Stretch - this takes a picture that is too small and stretches it to fit the frame
(so it doesn’t need to be tiled).



Clear - this removes the chosen picture (and simultaneously clears the
preview window).



Tint Color - this area allows the imported picture to be tinted in different
hues. It includes:



Tint Color - this is a tiny preview window that displays the color selected in
Pick Color.



Pick Color - this opens a palette of available tinting hues.



Intensity - this is very similar to transparency, except it dictates how strongly
the tint color effects the imported picture.



Transparency - these sliders determine the picture’s transparency. On the
slider scale, the left end equals 100% opacity and right end equals 100%
transparency.
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Report Viewer - Crystal Reports
The Crystal Report Viewer is launched automatically after a Crystal Report has been
generated by the Publishing Wizard (see below).

The top of this screen is dominated by the following toolbar (see below):

1

2

3

4 5

6

7 8

9

These functions can be performed from this interface:
1.
2.
3.
4.
5.
6.

Print Report - launches the print dialogue.
Export Report - opens up the Crystal Report Export box (see below).
Magnification (zoom) - controls and displays the magnification of the page.
Go to first page - displays the first page of the report.
Go to previous page - displays the previous page of the report.

Page number - displays the current page (the number next to it is the total
number of pages in the report).
7. Go to next page - displays the next page.
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8. Go to last page - displays the final page of the report.
9. Stop Loading - cancels the loading function.

Exporting from the Report Viewer window
To export your Crystal Report from the Report Viewer window, click the Export
Report button. This will launch the Crystal Report Export box (see below):

The following formats can be exported from this menu:









Acrobat Format PDF
MS Excel 97-2000
MS Excel 97-2000 (Data only)
MS Word
Rich Text Format
Tab-separated text
Text
XML

To export through this interface:
1. Choose the Format and Destination from the available drop down menus
and click OK.
2. Choose the Page Range (which pages of your report you want exported) on
the Export Options menu and click OK.
3. Choose a location and report name in the Choose export file window and
click Save.
4. The report will be exported and the window will close.
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Report Viewer - Internal Reports
All Internal Report viewing, printing and exporting commands are accessed through
the Internal Reports - Report Viewer.
To view Internal Reports:

1. Highlight the report’s name in the Existing Reports window and click the
Internal Report button:
2. The report will be automatically displayed in the Internal Reports -Report
Viewer (see below).
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To access all printing options in the Report Viewer:

1. Left mouse click the Report button in the top left corner of the Report
Viewer. A list of options will appear (see below).

2. Choose from the following printing options:


Print - launches the standard Microsoft Windows Print interface.



Print Setup - launches the standard Microsoft Windows Print Properties
interface.



Print Preview - launches the OrgChart Professional Print Preview screen
(for more details, please see the Print Preview section).

(Note: Print, Print Setup and Print Preview follow all standard printing conventions
outlined in Chapter 3: Printing.)
To export an Internal Report from the Report Viewer:

1. Left mouse click the Report button in the top left corner of the Report
Viewer. A list of options will appear (see above).
2. Choose Export > Excel.
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Wizards
OrgChart Professional has a variety of wizards to streamline importing, exporting,
publishing and report generation. The following is a listing of the main interface for
each. To launch the Export Wizard go to File > Export.

Export Wizard
Exporting is the process of saving OrgCharts in formats that can be opened and
utilized by other programs. In OrgChart Professional, this is done through the
Export Wizard. The wizard can export to the following formats:


Comma Separated Values (CSV) File.



Microsoft Excel File.



XML Document (OrgChart Schema).



OLE DB DataSource.

The export process is almost identical for all these formats. The only exception is
during the path selection phase, which appears on the third screen of the Export
Wizard. At that stage, Excel and OLE DB DataSource have a different selection
process. Once selection is complete, the rest of the wizard process is identical for all
formats.
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Export Wizard - Export Selection screen
This screen offers the following export options (see below).

Click in a radio button to choose one of the following:






Comma Separated Values (CSV) File.
Microsoft Excel File.
XML Document (OrgChart Schema).
OLE DB DataSource.

To complete this screen, choose one of the following options:





< Back - return to the previous wizard screen.
Next > - proceed to the next screen.
Cancel - close the wizard without saving and return to the Main Work area.
Help - launch the OrgChart Professional Help system.

For a detailed, screen-by-screen walkthrough of the export process, please see
Exporting charts with the Export Wizard.
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Import Wizard
The Import Wizard is designed to take the user step-by-step through the import
process. At each stage, the wizard will request information to be entered onto a page,
then proceed to the next screen through the use of Next buttons.
To open the Import Wizard - go to File > Import.

Import Wizard overview
The wizard uses the same basic system to import all six formats. Although certain
formats have unique screens for entering more technical settings, they all have the
following in common:


All formats begin the wizard the same. They all start with: 1) the
introduction screen and 2) a page to select the import format.



All formats finish the wizard the same. They all end with a Finish screen.



All formats use the same basic navigation buttons. Most pages have
Back, Next, Cancel and Help buttons at the bottom of the screen to move
back and forth through the wizard.

IMPORTING TIPS:



The data you intend to import must have a hierarchical structure for the
import to succeed.



Until the final (Finish) screen, you can move back and forth through the
wizard to change your choices before you commit to the final import.
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Import Wizard - Import selection screen
This screen offers five import choices (see below).

Click in a radio button to select which format to import. Choose from the following:



Microsoft Excel files.



Comma Separated Values (CSV) files.



Microsoft Outlook contacts.



OLE DB DataSource.



Lightweight Directory Access Protocol (LDAP) DataSource.



XML Document (OrgChart Schema).

For a detailed, screen-by-screen walkthrough of the import process, please see the
Import Wizard section.
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Publishing Wizard
Publishing is a powerful process which exports certain file formats, then can
immediately open up the associated program and display the results. (For example, if
you publish an OrgChart to MS Word, the chart would be saved in MS Word format
and then Microsoft Word would automatically load and display your chart.)

Publishing Wizard - Publishing selection screen
This screen offers eight publishing options (see below).

Click in a radio button to select which format you want your chart to be published in.
Choose from the following:










Microsoft PowerPoint
Microsoft Word
Microsoft Visio
Web Pages
Crystal Report
Adobe PDF
Image File
Scalable Vector Graphics (SVG)
Page 303 of 318

OrgChart Professional

Appendix A: Interfaces

Note: The Publishing Wizard incorporates the same essential workflow for all supported formats but some formats use different screens and a slightly different
sequence. For a detailed, screen-by-screen walkthrough of the publishing process,
please see the Publishing Wizard section.

Report Wizard - Internal Reports
Internal Reports are pragmatic, graphically simple reports usually produced for inhouse informational purposes. To start the wizard go to File > Create Report. The
Internal Report wizard will appear (see below).

To start a new report click New. To view a report, click Internal Reports. For a
detailed, screen-by-screen walkthrough of the publishing process, please see the
Internal Reports section.
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Add Print Page
Press to add a new print page.

Add Shape...
Press to add a new shape on the work area. (If you select another shape prior to this,
the new shape will be a subordinate of the first one.)

Arrange Print Pages
Press to arrange print pages on the screen in such a way to cover the entire chart.

Arrange Subordinates...
Press to arrange subordinates into logical patterns. (Note: the parent component must
be chosen or this function will not become active.)

Auto arrange Components
Press to automatically arrange components into logical patterns.

AutoTexts
Boxes with the words Chart & Division which can be dropped on to chart levels. To
change AutoTexts, go to Division View, highlight a division level and press F2.

Border Style...
Press to call the Border Style menu. This controls all the border characteristics of a
selected component.

Box Item Menu
A menu which displays a components data field information.

Cascade
Click this item to make all windows cascade on the screen.

Change Page Orientation
Press to toggle the selected page orientation between portrait and landscape.

Chart Design Palette
This menu contains tools for working with charts.

Page 305 of 318

OrgChart Professional

Appendix B: Glossary

Close
Press to close the active project. If there are unsaved changes, the program will
prompt you to save them before closing.

Columns Intelligent Sort
Mark this item to maintain the relationship between the data fields order on the Data
Properties panel and their order in the Data Outline View table. Moreover, adding a
new properties field within the Data Properties panel (for any component) will
produce the new column in the Data Outline View table. (Note: changing the column
order in the Data Outline View table cancels this mode.)

Connector Style...
Press to call the Connector Style menu. This controls the appearance of both
Dynamic Connectors and the connectors belonging to individual components.

Copy
Press to make a copy of the selected data. The data will be stored in the clipboard.

Create Report...
Press to call a wizard that will guide you step-by-step through the report creation
process.

Customize Data Outline View Columns
Press to call up the Data Outline View customization menu. From here, you can set
data field visibility and arrange data field order.

Cut
Press to place the selected item into the clipboard. (The item will disappear from the
project area.)

Data Outline View
Press to display the Data Outline View on the screen. This table displays every chart
component, their associated data fields and their relationships to each other.

Data Properties...
Press to call the special Data Fields dialogue corresponding to the selected
component.
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Delete
Press to delete the selected object (component or text).

Delete Print Page
Press to delete the selected print page.

Disconnect From Parent
Press to disconnect the selected component from its parent.

Divisions
Sub-groups and sub-charts used to break up (and simplify) large charts.

Division View
A tabbed section in Data Outline View that displays a simplified hierarchy of Subgroups and sub-charts.

Drop Shadow
Press to place a drop shadow on all selected components. Drop Shadows are used to
give a component a three dimensional feel.

Edit
This will display the edit tools and provide access to the program’s setup.

Email Chart...
Press to email the chart. Your default email program will launch and the chart will
appear as an attachment.

Exit
Press to close the program.

Export
Press to export a project’s data to different formats.

Field Hidden
Press this to hide a data field from the selected cell in Data Outline View.

File
Under this menu you can find essential tools related to general program options.
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Fill Style...
Press to call the Fill Style dialogue. From here, you can control a variety of
component properties including: color, gradient, pattern and photo.

Find...
Searches all components. Also allows the user to define additional search filters.

Find Next
Press to find the next item which meets your search criteria.

Fit to Window
Press to resize the work area to match the screen size for maximum overall visibility.

Font Style...
Press to call the Font Style dialogue. This controls all aspects of font control.

Full Screen
Press to expand the work area to fill the entire screen.

Help
Use this menu to launch OrgChart Help.

Hide Background
Press to toggle the current background between hidden and visible.

Hide Shape
Press to hide the selected components from the screen. (Note: the data fields of
hidden items are still displayed in areas such as Data Outline View.)

Hide Subordinates
Press to hide all of a chosen component’s subordinates. (Note: the parent component
must be chosen or this function will not become active.)

Import
Displays a list of available import formats. Once you choose a format, OrgChart will
convert the other program’s file so it can be read (and displayed) within the program.
(Note: if necessary, OrgChart will launch an appropriate Import Wizard to guide you
through the import process.)
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Move Subordinates
Place the cursor over this item and choose an appropriate move direction:
• Left/Up. Moves the selected component to the left in the object tree within
one level.
• Right/Down. Moves the selected component to the right in the object tree
within one level. (Note: the parent component must be chosen or this function
will not become active.)

New
Press to create a new project. The new work area will appear on the screen. To switch
between work areas go to the Windows menu and choose an appropriate area from
the corresponding menu.

Normal View
Press to return the program to the Normal view mode. In this mode, you can work
with components independent of which print page they are on.

Open
Press this item to open an existing (previously created and saved) project.

Options screen
Set OrgChart General and Data Fields Set options (this menu makes global changes).

Page Background...
Press to launch a menu where you can select and apply a background to the chart.

Paste
Press to place items (cut or copied) on the clipboard into the project area. You can
use this function to connect components. To do so, select a parent component on the
work area and paste the copied/cut component on top of it. When the pasted
component appears, it will be connected to the parent.

Print...
Press to print your chart. Before printing, you will be prompted to confirm printing
options in the standard Microsoft Windows dialogue box.

Print Layout View
Press to turn the program to the Print Layout View. In this mode, you can prepare
your chart to print arranging it on print pages of your choice.
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Print Preview
Press to go to the Preview mode. Here you can check the appearance of your
document before printing. Documents can also be printed directly from the Print
Preview window.

Print Setup...
Press to launch the standard Windows Print Options dialogue box.

Publish
Press to publish (export and display) the project in one of the available program
formats.

Redo
Press to cancel the previous undo action. (This essentially ‘un-does’ undo.)

Save
Press to save all changes in the project.

Save as...
Press to choose a new destination and name for the project you are saving.

Select All
Press to select all the components in the work area.

Shape
This menu provides a list of aesthetic shapes which can be applied to components.

Shape Style
Press to call a menu where you can select a new style for the selected component.

Show Grid
Press to superimpose a reference the grid over the work area. (Note: although the grid
is visible on the screen, it is never printed out.)

Show Rulers
Press to display rulers at the top and left side of the screen.

Snap to Grid
Press to make components snap to grid coordinates (this is good for precision work).
Page 310 of 318

OrgChart Professional

Appendix B: Glossary

Sort the List
Place the cursor over this item to choose an appropriate order for the Data Outline
View data fields:

•
•

Ascending.
Descending.

Status Bar
Select this to show the narrow information bar at the bottom of the screen.

Text Align
Place the cursor over this menu to choose a component’s text alignment (left, right,
centered, etc.).

Tile
Click this item to tile the screen with windows.

Toolbars
Point the cursor over this menu to choose the toolbar you wish to hide or make visible:
• Arrange – displays the tools for automatically arranging components.
• Format - displays various font modification tools.
• Arrange Subordinates - displays the tools for automatically arranging
subordinate components.
• Box Item – displays all data fields associated with the currently highlighted
component.
• Chart Design – presents all the items necessary for complete chart creation.
• Main Toolbar – contains essential OrgChart Professional settings and
options.
• Select View - presents tools for changing view and component modes.
• Themes - a drop down menu where different Themes can be chosen.
• Show Level - a drop down menu allowing for the choice of different chart
levels.
• Zoom – displays the magnification tools.

Undo
Press to cancel the previous action.

View
Toggles between Normal and Print Layout View modes.
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Window
Under this menu you can find tools to arrange windows on the screen.

Zoom In
Press to zoom in (increase magnification).

Zoom Out
Press to zoom out (decrease magnification).
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You can call up some useful program features and actions without a mouse via
shortcut hot keys.

Main Shortcuts
Shortcut

Action

Ctrl+N

New chart

Ctrl+O

Open chart

Ctrl+S

Save project

Ctrl+Y

Redo

Ctrl+Z; Alt+Backspace

Undo

Ctrl+A

Select All

Ctrl+X: Shift+Del

Cut

Ctrl+Ins; Ctrl+V

Past

Del

Delete

Alt+Enter

Data Properties

Alt+=; Alt++

Zoom In

Alt+

Zoom Out

Alt+Ctrl+A

Arrange Subordinates

Ctrl+F

Find

F3

Find Next

Alt+A

Add Component

Ctrl+F

Find

Working with components on the work area can be done by using key combinations.
It is assumed one component is selected on the work area.

Component Shortcuts
Shortcut

Action

Arrow keys

Navigate chart

Ctrl+

Collapse branches

Ctrl++

Unroll branches

Ctrl+Down Arrow

New component the level below

Ctrl+Right Arrow

New component the same level
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We value our customers. Please visit us online at http://www.officeworksoftware.com for additional tips, tutorials and the latest events in the Org-Chart
Professional world. Please refer to the following links for OrgChart related
information and support:
•

Homepage - http://www.officeworksoftware.com/productfamily.php

•

Technical support - http://www.officeworksoftware.com/supportservices.php

•

Update - http://www.officeworksoftware.com/updates.php
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